help with my EDGE - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by imported_BLKTRUCK1, this thread has received 1 replies and been viewed 404 times.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-01-2006, 02:14 AM Thread Starter
 
Join Date: Feb 2006
Posts: 37
Points: 505
Thanks: 0
Thanked 0 Times in 0 Posts
Question help with my EDGE

LOOKING FOR SOME HELP. 95 7.3 . I JUST GOT MY EDGE EVOLUTION AND INSTALLED IT. I DON'T SEE ANY DIFFS WITH IT BUT IT SHIFTS INTO DRIVE TO FAST. IT GOES THROW THE GEARS AND GO TO DRIVE AT 45 MPH. RUNS LIKE A DOG. IS THIS OK OR IS THERE SOME THING WRONG. IT SEEMED STRONGER IN STOCK MODE.:shrug: :shrug: :shrug: CAN SOME ONE HELP. THANKS ROD
imported_BLKTRUCK1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-01-2006, 02:35 AM
 
Join Date: Mar 2006
Posts: 1,592
Points: 52,891
Thanks: 0
Thanked 1 Time in 1 Post
try putting it back to stock, then unhook batterys for 30 minutes. connect batterys and check voltage. make sure everything is off all acces, reinstall evolution. your battery voltage must be good, just make sure nothing is useing power during the install.
imported_diesel71 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome