Temp Gauge Doesn't Work - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by TBoy34, this thread has received 1 replies and been viewed 698 times.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-05-2014, 09:23 PM Thread Starter
Junior Member
 
Join Date: Feb 2014
Location: Boston MA
Posts: 11
Points: 3,711
Thanks: 0
Thanked 0 Times in 0 Posts
Temp Gauge Doesn't Work

Hey everyone, the temp gauge on my dash hasn't worked since ive owned the truck...it goes from below the white line on the cold side and rises a tad until the needle is right over the white line then doesn't move at all after that...the truck warms up and runs fine, but with summer almost here and long trips ahead planned id like to get it working just in case it gets a little too hot. Any ideas what might be bad or what to look for? Id look for corroded wires but don't really know where to start...any help would be appreciated!!
Thanks, Nick
TBoy34 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-05-2014, 10:06 PM
Old Fart
 
dbennett48's Avatar
 
Join Date: Nov 2009
Location: Ukiah, Ca
Posts: 889
Points: 53,536
Thanks: 194
Thanked 180 Times in 155 Posts
Garage
It is probably the Temp Sending unit. It is screwed into the intake manifold, in a water passage. The dial indicator is much more $$ and effort.

Dave

2004 Ford F-350 Regular cab with 6.0.
Completely Stock.

KK6TNI - HAM Radio

http://bennettlaneshopping.com/ - Our Outdoor/Garden and Kitchen Ware store
dbennett48 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Temp gauge doesn't work gm1236 5.9L Cummins (2003-2007.5) 0 12-18-2010 01:58 AM
Reason why my tranny temp gauge doesn`t work astro General Ford Truck and Excursion 3 03-01-2008 01:11 AM
Overdive disengage button doesn't work coreystroke02 1994-2003 7.3L Power Stroke 2 11-01-2007 08:18 PM
Tow Haul button doesn't work STLChevyHD General GM Truck Forum 4 07-12-2006 10:00 PM
Help--Cruise control doesn't work. jvencius General Ford Truck and Excursion 1 07-05-2006 03:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome