Check Engine and RPM Jump - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by TBoy34, this thread has received 6 replies and been viewed 880 times.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-22-2014, 01:12 AM Thread Starter
Junior Member
 
Join Date: Feb 2014
Location: Boston MA
Posts: 11
Points: 3,711
Thanks: 0
Thanked 0 Times in 0 Posts
Check Engine and RPM Jump

Hey everyone, so just recently i went out and started my truck and noticed on startup that it was a bit rough and the check engine light came on, i turned the truck off after about a minute or so and fired it back up, truck ran fine and no light, the next day it did the same exact thing, so i let the truck idle with the light and after about a minute the light went out and the RPMs jumped a tad then came right back down, truck only seems to do it when it hasnt run for about 5 or 6 hours, ive checked the gas caps to make sure everythings tight and it is, any ideas what could be setting it off? i figured something fuel pressure related, thanks!, Nick, white 97 OBS
TBoy34 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-22-2014, 07:50 PM
Stuck in Commiefornia...
 
IdahoF350's Avatar
 
Join Date: Dec 2008
Location: Clearfield, Utah
Posts: 1,296
Points: 81,305
Thanks: 102
Thanked 447 Times in 315 Posts
Garage
If the CEL comes on, there should be codes. You need to figure out what codes are associated with the CEL being on first.

The Current Truck (Oct-2013 to Present):
1999 (Early) F-350 Lariat, CCLB, SRW, Black/Tan

7.3L Powerstroke, 4R100, 4x4, 3.73, 37x13.50-18s, '05 Axle Swap, 6" Fabtech lift, GTP38 "D66" turbo upgrade, SCT 4-position chip with custom tuning by me, Straight Piped 4" down pipe through 5" dual stacks, N-Fab full length triple steps, Pro-Tech cab guard and tool box, louvered 5th wheel gate, Hella 500 Fog and Driving lamps, much more to come...
The one I'll miss, (Mar-2009 to Jan-2014):
2000 Excursion XLT 4x4

6.8L V-10, 4R100, 4.30, 285/75-18, 271whp / 388wtq
The one I won't, (Jul-2005 to Sep-2012):
2005 F-350 XLT, CCLB, SRW, 4x4 FX4

6.0L PSD, ZF-6S650, 3.73, 35x12.5-18, 4.5" Lift
IdahoF350 is offline  
post #3 of 7 (permalink) Old 07-22-2014, 10:30 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Feb 2014
Location: Boston MA
Posts: 11
Points: 3,711
Thanks: 0
Thanked 0 Times in 0 Posts
Ive tried to scan it but it wouldnt read, the light would go out before the scanner could read it and wouldnt give me anything
TBoy34 is offline  
post #4 of 7 (permalink) Old 07-22-2014, 10:53 PM
Old Fart
 
dbennett48's Avatar
 
Join Date: Nov 2009
Location: Ukiah, Ca
Posts: 889
Points: 53,536
Thanks: 194
Thanked 180 Times in 155 Posts
Garage
How did you scan it? Not every scanner will work with Ford trucks. They need to be able to read CAN interface.

Dave

2004 Ford F-350 Regular cab with 6.0.
Completely Stock.

KK6TNI - HAM Radio

http://bennettlaneshopping.com/ - Our Outdoor/Garden and Kitchen Ware store
dbennett48 is offline  
post #5 of 7 (permalink) Old 07-23-2014, 04:07 AM
Stuck in Commiefornia...
 
IdahoF350's Avatar
 
Join Date: Dec 2008
Location: Clearfield, Utah
Posts: 1,296
Points: 81,305
Thanks: 102
Thanked 447 Times in 315 Posts
Garage
Dave an OP,
1994.5-2003 7.3Ls use SAE/PWM OBD-II
2003.5-2015 6.0/6.4/6.7 use CAN Protocol OBD-II

My E99 is a bugger to get codes out of even with a professional grade scan tool, the engine had to be running, and scanning causes the engine to stall, the trick is to leave the key on, and the codes are there. Your '97 is the same computer architecture as my E99, give it another try, hitting scan as soon as the truck starts, and let it run with the light on while scanning. If it continues to fail to read codes, try and get access to an aftermarket programmer like the SCT XCalibrator 2/XCalibrator SF/X3/SF3, which do much better reading codes on these trucks for some reason.

Final suggestion is if you have a chip, turn the key off and remove the key, then remove the chip, then try starting the truck and scanning codes, sometimes a chip will prevent a scan, happens on a friends 7.3, no matter the scan tool/programmer used, and if we pull the chip it scans just fine and shows codes.

The Current Truck (Oct-2013 to Present):
1999 (Early) F-350 Lariat, CCLB, SRW, Black/Tan

7.3L Powerstroke, 4R100, 4x4, 3.73, 37x13.50-18s, '05 Axle Swap, 6" Fabtech lift, GTP38 "D66" turbo upgrade, SCT 4-position chip with custom tuning by me, Straight Piped 4" down pipe through 5" dual stacks, N-Fab full length triple steps, Pro-Tech cab guard and tool box, louvered 5th wheel gate, Hella 500 Fog and Driving lamps, much more to come...
The one I'll miss, (Mar-2009 to Jan-2014):
2000 Excursion XLT 4x4

6.8L V-10, 4R100, 4.30, 285/75-18, 271whp / 388wtq
The one I won't, (Jul-2005 to Sep-2012):
2005 F-350 XLT, CCLB, SRW, 4x4 FX4

6.0L PSD, ZF-6S650, 3.73, 35x12.5-18, 4.5" Lift
IdahoF350 is offline  
The Following User Says Thank You to IdahoF350 For this addition to TDG:
dbennett48 (07-23-2014)
post #6 of 7 (permalink) Old 07-23-2014, 04:19 AM
Old Fart
 
dbennett48's Avatar
 
Join Date: Nov 2009
Location: Ukiah, Ca
Posts: 889
Points: 53,536
Thanks: 194
Thanked 180 Times in 155 Posts
Garage
Thanks IdahoF350. I was not correct on my CAN description. I could not remember the word 'protocol'.

Dave

2004 Ford F-350 Regular cab with 6.0.
Completely Stock.

KK6TNI - HAM Radio

http://bennettlaneshopping.com/ - Our Outdoor/Garden and Kitchen Ware store
dbennett48 is offline  
post #7 of 7 (permalink) Old 07-25-2014, 12:12 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Feb 2014
Location: Boston MA
Posts: 11
Points: 3,711
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks guys, my girlfriends father scanned it and i couldn't even really make out what kind of scanner it was so that definitely might be it, my friends got a shop down the street and definitely has a decent scanner so ill give that a shot! thanks guys ill let you know whats going on when i find out.
TBoy34 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
CAT C10- Low Engine RPM mathura Medium and Heavy Duty 11 11-16-2011 11:24 PM
Alternator rpm vs. engine rpm Red Diesel Medium and Heavy Duty 7 12-19-2009 01:57 AM
#08-06-04-054: Snow Intrusion into Air Cleaner, Check Engine Light On, Engine Reduced ripmf666 GM TSB Info 0 08-10-2009 04:46 AM
Engine RPM Surge @ Idle ??? DemonicF350 2003-2007 6.0L Power Stroke 0 12-11-2006 08:52 PM
RPM's jump immediately after startup Fantom3993 1994-2003 7.3L Power Stroke 2 06-18-2006 02:52 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome