02 F250 7.3 Surge or Miss at Constant Speed - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Drake, this thread has received 1 replies and been viewed 1073 times.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-24-2016, 10:25 AM Thread Starter
Junior Member
 
Join Date: Apr 2016
Posts: 3
Points: 241
Thanks: 0
Thanked 0 Times in 0 Posts
02 F250 7.3 Surge or Miss at Constant Speed

Hope someone can help me out. Bought my truck in 05 with 50,000 miles on it and now has 150,000. Been a good truck until last year when it developed a surge or miss when driving at a constant speed mostly thru town. Usually starts around 35 mph and goes up to about 60 mph. If I step on pedal and speed up it quits. Does not do it all the time either. Took truck to mechanic that said engine was OK and thought something was going on with Transmission. Took it to a transmission shop and they said nothing showed up on there scanner and they thought it was in the engine. Then I took it to the Ford Dealer that was suppose to have a good mechanic. First told me I had bad fuel and should drive it awhile with additive they put in it. This was about a $300 charge. Still missed and took it back in 2 weeks. This time I was told that I still had bad fuel and that mechanic did a flow test on injectors and that I needed #1,3,4 and 8. They were not flowing 100%. I did get to talk to mechanic and he told me to get good fuel and just run it hard and it might clean out those injectors. Found water pump leak and oil leak also, charged me $900 more. Engine still missing/surging 2 months later. Was hauling hay and truck got hot. Blew out transmission fluid. Had transmission overhauled and also installed new radiator. Truck ran good and didnt miss anymore until this past week, and now it has started again missing, surging. Taking back to transmission shop this coming week but I'm pretty sure he's going to say that nothing shows up on scan. What should I do next??? Thanks
Drake is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-01-2016, 03:30 PM
Junior Member
 
FORDsuperduty's Avatar
 
Join Date: Oct 2016
Posts: 14
Points: 2,041
Thanks: 0
Thanked 0 Times in 0 Posts
i had a similar issue on my 99.5 i have 355k miles on it now but i had surging issues from drop in fuel pressure was only 50 psi idle then WOT dropped to 40 or so and cruising would be at 45psi weak FPR spring and weak fuel pump which im suprised at 355k i still have all my stock original injectors. but did you find out what the issue was?

99.5 F250 7.3 ECSB 4x4
4'' silverline exhaust
3'' leveling kit
285/75/16 cooper MT
gauges
no power mods......yet

RIP 05 6.0 lol
FORDsuperduty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 F250 6.0L surge/misses armybassanglers_james 2003-2007 6.0L Power Stroke 6 08-13-2014 03:39 AM
7.3 has miss and constant white smoke (video inside) Bellflower 1994-2003 7.3L Power Stroke 14 02-15-2010 01:27 AM
NTC 400 BC1 - Feels like it has a high speed / high load miss bell206b3 Medium and Heavy Duty 20 01-01-2010 02:21 AM
Surge/Miss Ncbosshoss 2003-2007 6.0L Power Stroke 2 06-01-2009 03:50 AM
Hyw speed surge... imported_BillM2004 5.9L Cummins (2003-2007.5) 5 02-26-2008 02:29 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome