96 pcm issues need help badly!!! - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by cumminsCody, this thread has received 2 replies and been viewed 735 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-18-2017, 05:35 AM Thread Starter
Junior Member
 
Join Date: Nov 2017
Location: Indiana
Posts: 4
Points: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
96 pcm issues need help badly!!!

Ok guys i have a 96 f350 7.3l that has burnt up 3 pcms! I bought it with the engine out and guy said it just died well i dug in and found the plug in the back of the timing cover fell out causing loss of oil pressure. I fixed that or the whole truck back togethor and there is no wts light and no odo. Narrowed it down to the pcm, borrowed a friends pcm and back in buisness wts light I odo on truck runs so i bought one put it in rechecked fluids getting ready to drive it and i shut the hood and truck died. Popped hood looked for pinched wires the hood could have hit and nothing was found but the pcm wasn't working again. Checked fuse 22 checked all other fuses all good. I then got another pcm and nothing fried it before i even got to try to start it still no blown fuses put pcm In other truck and nothing. I have power going into pcm, i have 5 volt reference at all sensors truck won't start no wts no odo numbers, did not find anything as to why it keeps burning pcms the first pcm is the original so something had to have happened when the engine was pulled but what could short and how do i find it now? Please help these things get expensive after 3 or 4 you buy in afraid to hook the new one up i have.
cumminsCody is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-19-2017, 01:10 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2017
Location: Indiana
Posts: 4
Points: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Well hell guess I'll just scrap it then
cumminsCody is offline  
post #3 of 3 (permalink) Old 11-20-2017, 12:40 PM
Junior Member
 
Jasong's Avatar
 
Join Date: Feb 2015
Location: Plant City Fl
Posts: 309
Points: 35,544
Thanks: 41
Thanked 26 Times in 25 Posts
Check the wiring going to the glow plug relay.
Make sure the glow plug load isn't being applied to the pcm.
I can't remember if the 7.3 has a FICM, check it's wiring closely as well.
Jasong is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Buddy needs help really badly... 4cstr 2003-2007 6.0L Power Stroke 10 05-22-2009 09:36 PM
OASIS request badly needed Mike B Ford Oasis requests 2 05-24-2007 03:16 AM
Needed Badly 7.3l PS ThorsF350 Whats Been Sold 4 06-24-2006 02:22 AM
24 valve smoking badly BILL 5.9L Cummins (1998.5-2002) 7 01-03-2006 07:46 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome