7.3L Runs BAD!! - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by wforacing61, this thread has received 5 replies and been viewed 1096 times.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-10-2007, 01:22 AM Thread Starter
 
Join Date: Jan 2007
Posts: 5
Points: 111
Thanks: 0
Thanked 0 Times in 0 Posts
7.3L Runs BAD!!

I have a 1999 F-450 There are two probmels that I'm having

1) From time to time when you step on the gas pedel there's no tesponce like the truck is in nutral but after stepping on it a few time the truck wakes up and them goes.

2) When I drive the truck dow the road under exceloration it seams like the truck is getting too much fuel or not enough fuel it blows white / blue smoke and dose not want to shift, or when it dose the truck won't shift till 3k rpm or the fuel finely seems to presurise properly.

3)Also have the isue when trying to get it to down shift into a passing gear.

4) In the A.M first fire up the truck either will not ge like there's no power or it goes like a bat out of Heck then after that it rund bad.

Does any one have any sugestions on where to start?

I would realy appriciate it
wforacing61 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-10-2007, 01:35 AM
Senior Member
 
CSIPSD's Avatar
 
Join Date: Sep 2005
Location: Bend OR
Posts: 6,337
Points: 55,131
Thanks: 19
Thanked 78 Times in 70 Posts
Need to pull the codes first off. Your going to need a new petal ***. that is a common part that goes out. I would guess that would take care of 3 of your issues... Try that first.

01 F-250 SC PSD,210k,16 Isspro Gauges, AFE-2,CCV Mod,IAH delete,map reg,Modded H2e, 6.0 IC, GTS Hybrid injectors, Studs, 910 Valve springs, Forged rods Water injection,Swamps tuned, MBRP 4" dual's, Aero, 6" tip's, 100 axl tank, 4" Revtek lift, 37-14.50-17 TOYO MT's 469hp and 1068tq...

Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
CSIPSD is offline  
post #3 of 6 (permalink) Old 01-10-2007, 02:23 AM
 
Join Date: Mar 2006
Posts: 1,132
Points: 20,038
Thanks: 7
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by CSIPSD
petal ***. .


I agree with joe for once:
kainers is offline  
post #4 of 6 (permalink) Old 01-11-2007, 01:54 PM Thread Starter
Threadstarter
 
Join Date: Jan 2007
Posts: 5
Points: 111
Thanks: 0
Thanked 0 Times in 0 Posts
I'ld like to thank you both on the advice but had to brake down and take it to the shop
wforacing61 is offline  
post #5 of 6 (permalink) Old 01-11-2007, 07:07 PM
Senior Member
 
Join Date: Dec 2008
Posts: 862
Points: 22,480
Thanks: 2
Thanked 112 Times in 85 Posts
I'm betting it's not the pedal assembly.
Pocket is offline  
post #6 of 6 (permalink) Old 01-13-2007, 02:52 PM Thread Starter
Threadstarter
 
Join Date: Jan 2007
Posts: 5
Points: 111
Thanks: 0
Thanked 0 Times in 0 Posts
The problem with the truck was a multiple of thinfs 1) The aftermarket fuel filter had come apart (I guess that's a reocuring problem with the aftermarket filters. 2) the fue presure regulator came apart 3) the fuel drain valve was leaking and finally 4) the air box has a hole in it and they said that the comprossor wheel eroded an dit how only has 9 psi of boost The mechanic sail it shouls be 15 so I'm going to save my pennies and get a new turbo. As far as the pedal the electronic conection was warn out and had to be replaced. Again I thank you all for your help but when you only have 2 tow trucks and one goes down you have to take it to the mechanic.

Chris
wforacing61 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome