Hopefully some one can help! - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by MYSHO1, this thread has received 0 replies and been viewed 484 times.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-10-2007, 10:58 PM Thread Starter
 
Join Date: Jan 2007
Posts: 31
Points: 360
Thanks: 0
Thanked 0 Times in 0 Posts
Hopefully some one can help!

I just picked up my first powerstoke (99 f-350) with about 112,000 miles, It ran great all the time when i first bought it, but now when its cold it acts like it wants to stall... then it will stall. After a few minutes of cranking with my foot on the pedal it will fire up and sound like it has a thrown rod until it warms up, then runs like a 12,000 pound raped ape...I replaced the fuel filter and was sure that fixed it until i was leaving work today. Any one know what i should do?

It also has a very bad exhaust leak there a common place for a gasket to kick the bucket on one of these?
:thanks:
MYSHO1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome