Need Help Battery Light is on - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by imported_CWAGO, this thread has received 7 replies and been viewed 1234 times.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-19-2007, 02:26 PM Thread Starter
 
Join Date: Feb 2006
Posts: 158
Points: 1,625
Thanks: 0
Thanked 0 Times in 0 Posts
Need Help Battery Light is on

I changed both batteries last night. Bought brand new ones from Advance Auto. This morning the truck starts fine. On the way to work the battery light keeps flashing.

Whats going on? Anyone have this happen?


This is on the womans 01 F-250.

Thanks
Cody
imported_CWAGO is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-19-2007, 02:29 PM
Super Moderator
 
John_G's Avatar
 
Join Date: Dec 2008
Location: Tyler, TX
Posts: 4,247
Points: 74,599
Thanks: 101
Thanked 407 Times in 347 Posts
Cody,

The battery light in an indication of ALTERNATOR function, not battery condition. Yup, stupid I know.

I would suspect that alternator is failing, although unusual, it happens. It could also be that the key supplied power to the alternator is too low for it to work properly, this can be caused by a bad ignition switch, corroded connection, or bad/correded fuse or fuse holder.

'93 F-250 HD, 7.3L IDI, 5spd - FARM TRUCK
I Support: Trailer brakes an every axle over the towing vehicle's GVW; CDLs for RVers; Safety inspections for ALL vehicles and 6 axle trucks (97K GVW proposal).

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote - Benjamin Franklin

I vote for LIBERTY!
John_G is offline  
post #3 of 8 (permalink) Old 01-19-2007, 02:48 PM Thread Starter
Threadstarter
 
Join Date: Feb 2006
Posts: 158
Points: 1,625
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks John,

I had to give her a jump on one battery and use a jump box on the other yesterday when she got off work. I went ahead and bought the batteries anyways, they were the original 01's.

I will take it to Auto Zone or Advanced and get the alternator checked this afternoon.


Thanks

Cody
imported_CWAGO is offline  
post #4 of 8 (permalink) Old 01-19-2007, 02:57 PM
 
Join Date: Feb 2005
Posts: 1,181
Points: 20,039
Thanks: 0
Thanked 0 Times in 0 Posts
A loose Alt connection will make the light flicker. John covered same i guess. If it tests 13V output wiggle em. May as well let the store test em since your a customer.
RacerX is offline  
post #5 of 8 (permalink) Old 01-19-2007, 06:11 PM
 
Join Date: Dec 2006
Posts: 333
Points: 3,383
Thanks: 0
Thanked 0 Times in 0 Posts
Changed one battery last week and had this same thing happen for several days and now it hasn't happened again. Battery light would come on and then maybe flash for several minutes or just stay on continually for a while. Mysterious...yes Leaves me feeling warm and fuzzy all over...no
hopeful 6.0 is offline  
post #6 of 8 (permalink) Old 01-20-2007, 02:38 AM
Senior Member
 
Join Date: Sep 2006
Posts: 382
Points: 18,810
Thanks: 2
Thanked 0 Times in 0 Posts
hey also check the power cable for the starter if it is loose be careful when you tighten it it is connected to plastic and it will break very easily.

2006 lariat fx4. Straight piped. SCT tuner.

SLAPS MEMBER

SINGLES MEMBER #125
platinum01 is offline  
post #7 of 8 (permalink) Old 01-22-2007, 02:59 PM Thread Starter
Threadstarter
 
Join Date: Feb 2006
Posts: 158
Points: 1,625
Thanks: 0
Thanked 0 Times in 0 Posts
thanks guys.

On the way to Auto Zone, she run the truck out of fuel . So I called one of buddys and had it towed to the house. Got up the next morning and got her started. Went to A.Z. and got a new Alternator. Got it back home and noticed the casting was wrong and wouldnt let my bolt go through the hole. Took it back and went next door to O Reilys. They matched A.Z. price. Installed the Alt in the rain: Drove it down the road and it still flashes laugh . Guess I will check the starter wire and if that dont work take it back to OReilys and have it tested.


Cody
imported_CWAGO is offline  
post #8 of 8 (permalink) Old 01-23-2007, 02:45 PM Thread Starter
Threadstarter
 
Join Date: Feb 2006
Posts: 158
Points: 1,625
Thanks: 0
Thanked 0 Times in 0 Posts
Well, I found out the problem with the new alternator.......... I didnt have the plug all the way on. I was messing with everything and when i touched the plug the light under the hood got brighter

thanks for all your help!!
imported_CWAGO is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome