no oil pressure after fixing leak - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by smokin dually, this thread has received 7 replies and been viewed 750 times.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-09-2007, 06:31 AM Thread Starter
soot junkie
 
Join Date: Feb 2006
Posts: 194
Points: 24,264
Thanks: 0
Thanked 2 Times in 2 Posts
no oil pressure after fixing leak

I replaced the orings in the oiil cooler on a 95 F350. I got the truck back runnning after changing the oil an dnow it will not any oil pressure. I got about a quart and a half of coolant out of the oil pan. I have a manual gauge in the block and it shows no pressure there either. Short of pulling the motor is there anything else I could check? The truck ran fine before I fixed the leak. I read on another forum about some valve inside the end of the cooler. does this sound right, and if so could it cause the oil to bypass and not build pressure? Sorry for the long post, but the guy is needing the truck back in a hurry. :shrug:

01 F350 CC Dually, DP tuner, fuel system w/Aeromotive pump, 360cc Stage III Hybrids, Stealth Big Oil, H2 Hybrid, Head Studs, Hypermax rods, balanced rotating assembly, Comp Cams valve springs and push rods, ATS trans fixed by BTS, Best 1/4 [email protected] best 1/8 [email protected]
2000 F250 6sp, Dp Tuner
Early 99 F350 2wd daily driver Dp Tuner
smokin dually is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-09-2007, 02:16 PM
FRANKEN STROKE
 
Join Date: Dec 2006
Posts: 189
Points: 14,225
Thanks: 0
Thanked 0 Times in 0 Posts
I cant find my book yet but i will call later good luck!:Thumbup:

96 F-250 4X4,DP Tunner, EZmod, up graded IDM, custom drive shafts, staight axle up grade, 5-speed,head studs, bps bypass, dual HPOP's, AFE Filter, aeromotive fuel system, tubes, springs, oringed, copper head gaskets, 5" stacks (all chrome), south-bend dd clutch, H2E big spinny thing, some hugh-jazz injectors, 3" body lift (had to fit the turbo in), homemade traction bars fromt and rear, blood sweat & lockers!!
Four different trucks had to die to make this one!!!!!!!!!!!Thats why we call him FRANKEN STROKE! Too much fuel, and not enough money

Sled pulling in NC,TENN,VA,and anywere else theyll let us!!!!!

P.S. Dont be afraid of the sawzall! It can fix anything!

[email protected]

DONATIONS EXCEPTED!!!!!!
Franken-stroke is offline  
post #3 of 8 (permalink) Old 02-09-2007, 05:21 PM
Senior Member
 
Join Date: Jan 2007
Posts: 455
Points: 44,381
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Docluv2577 Send a message via Yahoo to Docluv2577
there is a pressure relief valve in the rear oil cooler head these are known to fall out and it is possible if it did and you didnt notice the header was reinstalled without it and thus no oil pressure. I would drop the cooler again and check for this regulater its round and sits in a bore of the header and is pegged into place check that it is there and not stuck wide open

84 f 250 ex cab 4x4 w/92 7.3 ATS turbo 3 in exhaust no muffler K&N filter pumped tweaked 25%
Navistar Diesel electronics specialist( mechanic..lol) 19 years at local dealer
Photos of The Beast

DOC
Docluv2577 is offline  
post #4 of 8 (permalink) Old 02-10-2007, 02:39 AM
Member
 
Join Date: Dec 2008
Location: Newnan Georgia
Posts: 63
Points: 1,884
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
spin the oil filter off. u should see the valve. but most likely its gone. if its ping then its none serviceable. the head will have to be replaced. the new one is not ping its held in with a c clip.

Roscoe Stroker is offline  
post #5 of 8 (permalink) Old 02-10-2007, 03:18 AM
Senior Member
 
Join Date: Jan 2007
Posts: 455
Points: 44,381
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Docluv2577 Send a message via Yahoo to Docluv2577
you wont be able to see the valve by just removing the filter you have to take the cooler off the block it is installed from the gasket surface side of cooler head

84 f 250 ex cab 4x4 w/92 7.3 ATS turbo 3 in exhaust no muffler K&N filter pumped tweaked 25%
Navistar Diesel electronics specialist( mechanic..lol) 19 years at local dealer
Photos of The Beast

DOC
Docluv2577 is offline  
post #6 of 8 (permalink) Old 02-11-2007, 01:57 AM
Member
 
Join Date: Dec 2008
Location: Newnan Georgia
Posts: 63
Points: 1,884
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
There are 2 valves. A pressure regulator and a bypass valve. the pressure regulator is between the block and filter head. the bypass valve is between the filter head and the filter. the bypass valve is the one that usually fallls out
when you repair the oil cooler. either one of the valves will cause your problem.

Roscoe Stroker is offline  
post #7 of 8 (permalink) Old 02-11-2007, 02:39 AM Thread Starter
soot junkie
Threadstarter
 
Join Date: Feb 2006
Posts: 194
Points: 24,264
Thanks: 0
Thanked 2 Times in 2 Posts
Thanks for everyones help. I took the oil cooler back off and neither one of the valves were in it. I did not find any parts in the parts washer so they must have fallen out somewhere else. The truck has been returned to its owner (with a new oil pump).

01 F350 CC Dually, DP tuner, fuel system w/Aeromotive pump, 360cc Stage III Hybrids, Stealth Big Oil, H2 Hybrid, Head Studs, Hypermax rods, balanced rotating assembly, Comp Cams valve springs and push rods, ATS trans fixed by BTS, Best 1/4 [email protected] best 1/8 [email protected]
2000 F250 6sp, Dp Tuner
Early 99 F350 2wd daily driver Dp Tuner
smokin dually is offline  
post #8 of 8 (permalink) Old 02-11-2007, 03:03 AM
Senior Member
 
Join Date: Jan 2007
Posts: 455
Points: 44,381
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Docluv2577 Send a message via Yahoo to Docluv2577
roscoe I have never seen a bypass valve fall out and it shouldnt cause no oil pressure if it did its job is just to bypass oil if the filter plugs so at worst with it gone oil would just not flow thru the filter but should still build pressure...

as for the vehicle at hand so this was a customers truck and you sent it back with a new oil pump it didnt need and parts missing from the oil cooler that were not missing when it came in ??

84 f 250 ex cab 4x4 w/92 7.3 ATS turbo 3 in exhaust no muffler K&N filter pumped tweaked 25%
Navistar Diesel electronics specialist( mechanic..lol) 19 years at local dealer
Photos of The Beast

DOC
Docluv2577 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome