Exhaust back pressure valve? - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by des6120, this thread has received 13 replies and been viewed 1759 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 02-17-2007, 01:44 PM Thread Starter
 
Join Date: Feb 2007
Posts: 24
Points: 1,337
Thanks: 0
Thanked 0 Times in 0 Posts
Exhaust back pressure valve?

1996 7.3L SD


After reading many threads I understand that in the cold weather the EBPR will cause loss of power. Is it normal for the check engine light to come on when this happens? Light goes off when power comes back.

Thanks
des6120 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 02-17-2007, 04:29 PM
Super Moderator
 
John_G's Avatar
 
Join Date: Dec 2008
Location: Tyler, TX
Posts: 4,247
Points: 74,591
Thanks: 101
Thanked 407 Times in 347 Posts
It is never "normal" to have CEL on at any time during operation.

'93 F-250 HD, 7.3L IDI, 5spd - FARM TRUCK
I Support: Trailer brakes an every axle over the towing vehicle's GVW; CDLs for RVers; Safety inspections for ALL vehicles and 6 axle trucks (97K GVW proposal).

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote - Benjamin Franklin

I vote for LIBERTY!
John_G is offline  
post #3 of 14 (permalink) Old 02-17-2007, 04:36 PM Thread Starter
Threadstarter
 
Join Date: Feb 2007
Posts: 24
Points: 1,337
Thanks: 0
Thanked 0 Times in 0 Posts
So in your opinion what would cause the CEL to go on? Light goes on when I exprience the loss of power but goes off when power is back.
des6120 is offline  
post #4 of 14 (permalink) Old 02-17-2007, 04:41 PM
Super Moderator
 
John_G's Avatar
 
Join Date: Dec 2008
Location: Tyler, TX
Posts: 4,247
Points: 74,591
Thanks: 101
Thanked 407 Times in 347 Posts
There is any number of things that can cause a CEL and loss of power. One is a malfunctioning EBPV.

You need to get the codes read. Active or recent codes NEED to be fixed before going on to other possible problems that may or may not, be there.

'93 F-250 HD, 7.3L IDI, 5spd - FARM TRUCK
I Support: Trailer brakes an every axle over the towing vehicle's GVW; CDLs for RVers; Safety inspections for ALL vehicles and 6 axle trucks (97K GVW proposal).

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote - Benjamin Franklin

I vote for LIBERTY!
John_G is offline  
post #5 of 14 (permalink) Old 02-17-2007, 05:04 PM Thread Starter
Threadstarter
 
Join Date: Feb 2007
Posts: 24
Points: 1,337
Thanks: 0
Thanked 0 Times in 0 Posts
Thank you. I'm in the process of working on these issues with my mechanic. Codes for a malfuntioning EBPV are coming up. So I'm hoping once the EBPV has been repaired the CEL issue will be solved. The only noticable symptoms are loss of power during cold engine conditions.(CEL light comes on) Once engine is warm power comes back (CEL goes off) Other threads I've read say power lose is caused by the funtioning of the EBPV, but nobody mentioned if the CEL light goes on or not, was just inquiring. I want to have as much info as possible.
des6120 is offline  
post #6 of 14 (permalink) Old 02-17-2007, 08:57 PM
 
Join Date: Dec 2008
Posts: 1,870
Points: 11,987
Thanks: 0
Thanked 1 Time in 1 Post
My EBPV died a slow and painful death.
See here. http://webshots.com/user/gregrob20
gregrob is offline  
post #7 of 14 (permalink) Old 02-17-2007, 09:27 PM Thread Starter
Threadstarter
 
Join Date: Feb 2007
Posts: 24
Points: 1,337
Thanks: 0
Thanked 0 Times in 0 Posts
Even if I remove the EBPV I don't know if this will clear up the CEL.
des6120 is offline  
post #8 of 14 (permalink) Old 02-17-2007, 10:06 PM
 
Join Date: Dec 2008
Posts: 1,870
Points: 11,987
Thanks: 0
Thanked 1 Time in 1 Post
If you have a check engine light, you have a code. What is the code?
gregrob is offline  
post #9 of 14 (permalink) Old 02-17-2007, 11:33 PM Thread Starter
Threadstarter
 
Join Date: Feb 2007
Posts: 24
Points: 1,337
Thanks: 0
Thanked 0 Times in 0 Posts
I don't remember the exact code from the mechanic, but he said it had to do with the EBPV. When I talk to him I will ask for the code.
des6120 is offline  
post #10 of 14 (permalink) Old 02-19-2007, 11:24 PM
 
Join Date: Sep 2006
Posts: 49
Points: 523
Thanks: 0
Thanked 0 Times in 0 Posts
This sounds like exactly the same problem I am having. But I have not had time to get it scanned yet so i don't know what the code is for yet. Hopfully I will get it scanned friday.
Does your run really rough too when the light comes on? let me know what you find out.
ScottyB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome