well here it goes - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Andy, this thread has received 14 replies and been viewed 691 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-11-2007, 01:36 AM Thread Starter
 
Join Date: Sep 2005
Posts: 173
Points: 2,563
Thanks: 0
Thanked 0 Times in 0 Posts
well here it goes

well got my new sensors in and relized i should put new batteries in the truck. while i was putting the one new battery in my buddy said he would put in the other. thats when i shoudl have said no but anyways he hooked it up wrong and melted the battery terminal and now the truck wont start at all. please help would could he have wiped out.
Andy is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-11-2007, 01:53 AM
 
Join Date: Dec 2006
Posts: 1,769
Points: 23,270
Thanks: 6
Thanked 24 Times in 23 Posts
Ouch
Fast_Ashley is offline  
post #3 of 15 (permalink) Old 03-11-2007, 03:20 AM Thread Starter
Threadstarter
 
Join Date: Sep 2005
Posts: 173
Points: 2,563
Thanks: 0
Thanked 0 Times in 0 Posts
yeah i checked all the fusses and they were fine. dosen't seem to be getting fuel, NO SMOKE, I put a new cam sensor and ICP sensor no go. I even unhooked ICP sensor see if the new one was bad, still no go. what the hell is wrong. don't know if he did something or still fighting old wars. thanks.
Andy is offline  
post #4 of 15 (permalink) Old 03-11-2007, 03:32 AM
 
Join Date: Dec 2006
Posts: 1,769
Points: 23,270
Thanks: 6
Thanked 24 Times in 23 Posts
Does it even crank or turn over?? Does it even click?
Fast_Ashley is offline  
post #5 of 15 (permalink) Old 03-11-2007, 03:42 AM Thread Starter
Threadstarter
 
Join Date: Sep 2005
Posts: 173
Points: 2,563
Thanks: 0
Thanked 0 Times in 0 Posts
yeah it cranks over and the gauges all work but thats as far as it goes. i pulled the chip and it didn't change anything.
Andy is offline  
post #6 of 15 (permalink) Old 03-11-2007, 04:14 PM
Senior Member
 
pontiacross's Avatar
 
Join Date: Dec 2008
Location: Mexico, MO
Posts: 2,509
Points: 50,781
Thanks: 145
Thanked 82 Times in 79 Posts
dose your check engine and wait to start light come on.

Ross
Show-ME Smokers 2.6 modified street pulling truck "The Lone Stroke" My Videos
1996 f350, powerstroke, 4x4, 5-speed, 4.56 gears, Swamps 450/600 injectors, Swamps BFH turbo, Swamps Idm, Swamps tunes, BTS oil, SBC clutch, studs, springs, tubes, air to water intercooler, fuel system, factory rods!


Tow Rig
1997 f350, srw, reg cab, 4x4, 5 speed, 4.10 gears, 3in down pipe, straight pipe, mystery chip.

Becker Brothers Enterprises
pontiacross is offline  
post #7 of 15 (permalink) Old 03-12-2007, 01:58 AM Thread Starter
Threadstarter
 
Join Date: Sep 2005
Posts: 173
Points: 2,563
Thanks: 0
Thanked 0 Times in 0 Posts
yeah all the lights come on when cranking, today i tries it and only the back solinoid for the glow pulgs was clicking, why do theses 99 have two glow pug relays. and which one does what.
Andy is offline  
post #8 of 15 (permalink) Old 03-12-2007, 02:02 AM
 
Join Date: Dec 2006
Posts: 1,769
Points: 23,270
Thanks: 6
Thanked 24 Times in 23 Posts
Of the two relays on top the engine, the one closest to the turbo is the glow plug relay. The one closest to the fuel bowl is the air intake heater. But this is only on late 99 and up trucks.
Fast_Ashley is offline  
post #9 of 15 (permalink) Old 03-12-2007, 02:06 AM Thread Starter
Threadstarter
 
Join Date: Sep 2005
Posts: 173
Points: 2,563
Thanks: 0
Thanked 0 Times in 0 Posts
i really can't tell you, it's not mine and i'm not near it to find out. but these are in a line the one closest to the grill i didn't feel pop the one right behind it closest to the turbo i felt pop. is that the glow plug one. and are they the same.
Andy is offline  
post #10 of 15 (permalink) Old 03-12-2007, 02:08 AM
Chitowns Biggest Baller
 
6.4lkid's Avatar
 
Join Date: Oct 2006
Posts: 517
Points: 34,405
Thanks: 23
Thanked 1 Time in 1 Post
My buddy just did the same thing and burned his IDM up.

Formerly 6.0lkid
2008 F250 FX4 Loaded
SCT TUNED
6.4lkid is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome