My Dad's '95 F250 7.3L is DEAD!!!! Help Please. - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by FX4DUDE, this thread has received 9 replies and been viewed 816 times.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-17-2007, 02:23 AM Thread Starter
 
Join Date: Jun 2007
Posts: 252
Points: 255
Thanks: 0
Thanked 0 Times in 0 Posts
My Dad's '95 F250 7.3L is DEAD!!!! Help Please.

My Dad & Mom were up Moose hunting today in the back country of Wyoming. First of all, they got a huge bull moose (my mom shot it with her trusty 270 Seiko with 158 grain bullets) It took her 26 years to get the permit and she was stoked. (Not to be confused with Stroked)

Anyway, my dad was trying to get the truck to a road closer to the moose, which was still about 300 hard timber yards from this road. He was going up the hill and the check engine light came on and it started running like it was on 4 cylinders. Then it died, he stopped, and then got it running again, and ran smooth for like 200 ft and died again. Long story short- my bro pulled him all the way back to camp with his '06 6.0. It still will not start.

Here is what they have tried:

1) Changed fuel filter, and drained water.
2) Changed camshaft position sensor.
3) Checked oil level (perfect).
4) Glow plugs and relay working fine.
5) Cranks over just like normal.
6) Batteries are brand new.
7) Airfilter, and belt are brand new.

Still no start......

One guy suggested that the main plug that goes to the injectors under the valve cover has come unplugged because they get brittle from the heat over time and then that bank of injectors don't work because they aren't plugged in. Some guys say they plug them back in and zip tie it tight so they don't come undone again....

What do you guys think? :shrug: :shrug: :shrug:

The truck is about 150 miles from home in the mountains right now, and my bro and dad are going back tomorrow to get it. They would love to be driving this beast back.

It has 100,000 miles.

1995 F-250 7.3L 4x4 Reg Cab XLT Automatic
FX4DUDE is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-17-2007, 02:34 AM
Senior Member
 
pontiacross's Avatar
 
Join Date: Dec 2008
Location: Mexico, MO
Posts: 2,509
Points: 50,704
Thanks: 145
Thanked 82 Times in 79 Posts
do you have any way of reading the codes?
a few things to check

check the fuel pressure there is a scrader valve on the fuel pressure regulate on the driver side of the fuel bowl you can unscrew it and use a guage with a 1/8 pipe fitting

On top of the high pressure resivore there is a plug you can pull out and see if it is full of oil. if not crank it over and see if it fills up.

Do they have any fuel or oil leaks?

Ross
Show-ME Smokers 2.6 modified street pulling truck "The Lone Stroke" My Videos
1996 f350, powerstroke, 4x4, 5-speed, 4.56 gears, Swamps 450/600 injectors, Swamps BFH turbo, Swamps Idm, Swamps tunes, BTS oil, SBC clutch, studs, springs, tubes, air to water intercooler, fuel system, factory rods!


Tow Rig
1997 f350, srw, reg cab, 4x4, 5 speed, 4.10 gears, 3in down pipe, straight pipe, mystery chip.

Becker Brothers Enterprises
pontiacross is offline  
post #3 of 10 (permalink) Old 10-17-2007, 02:39 AM
Senior Member
 
pontiacross's Avatar
 
Join Date: Dec 2008
Location: Mexico, MO
Posts: 2,509
Points: 50,704
Thanks: 145
Thanked 82 Times in 79 Posts
this may helphttps://www.thedieselgarage.com/forum...2&d=1158384628

https://www.thedieselgarage.com/forums/attachment.php?attachmentid=6751&d=1158384628

Ross
Show-ME Smokers 2.6 modified street pulling truck "The Lone Stroke" My Videos
1996 f350, powerstroke, 4x4, 5-speed, 4.56 gears, Swamps 450/600 injectors, Swamps BFH turbo, Swamps Idm, Swamps tunes, BTS oil, SBC clutch, studs, springs, tubes, air to water intercooler, fuel system, factory rods!


Tow Rig
1997 f350, srw, reg cab, 4x4, 5 speed, 4.10 gears, 3in down pipe, straight pipe, mystery chip.

Becker Brothers Enterprises
pontiacross is offline  
post #4 of 10 (permalink) Old 10-17-2007, 03:23 AM Thread Starter
Threadstarter
 
Join Date: Jun 2007
Posts: 252
Points: 255
Thanks: 0
Thanked 0 Times in 0 Posts
no leaks
FX4DUDE is offline  
post #5 of 10 (permalink) Old 10-17-2007, 04:33 AM
Member
 
Join Date: Sep 2007
Posts: 158
Points: 4,760
Thanks: 0
Thanked 0 Times in 0 Posts
i bet that the cps cam postion sensor went out... just my guess from what your saying you have all the symptoms for a cps going out???

Early99 F-250XLT 4x4
H2E 62/17. Stock AB's. Swamps Tunes. Autometer guages. Afe PG7 filter. 6in stacks. Ats billet trans. 5star-conv. 4in lift ridin on 20x10 XD Diesels rapped in 35in procomp Xterrains.
HeffPsDiesel is offline  
post #6 of 10 (permalink) Old 10-17-2007, 04:39 AM
Formerly CursedtoFirst45
 
StrokeThis's Avatar
 
Join Date: Dec 2008
Location: Gilbert, Az
Posts: 1,225
Points: 26,449
Thanks: 52
Thanked 64 Times in 57 Posts
Quote:
Originally Posted by HeffPsDiesel
i bet that the cps cam postion sensor went out... just my guess from what your saying you have all the symptoms for a cps going out???
in his post he said that he already checked that.

camshaft position sensor= cps

Eric

1994 Dodge Ram 2500

Quote:
You can take our information, you can try to shut us down, but we're still here, and we're going to be better than ever!!
-John DeereGreen
StrokeThis is offline  
post #7 of 10 (permalink) Old 10-17-2007, 04:49 AM
TDG MAFIA MEMBER #77
 
TooLoudTooBad's Avatar
 
Join Date: Jul 2006
Posts: 940
Points: 22,827
Thanks: 13
Thanked 11 Times in 10 Posts
Sounds fuel related. Have they been able to check the pressure?

I would also look at the UVC harnesses and check all of the fuses.

Just an idea....unplug the fuel bowl heater and give her shot.

1999.5 PSD, 4x4, Auto trans, 6.0 Trans cooler, ZooDad Mod, ISSPRO Trans - boost - EGT gauges, Wicked Wheel, 5inch Stainless tip, 315 75 17 BFG AT's, ProComp 9000's at the corners, Fumatomo Valve, Pooned tank, DP Tuner F5 w/ 80 tow, 80 econo, 120 race and permagrin!
TooLoudTooBad is offline  
post #8 of 10 (permalink) Old 10-17-2007, 04:49 AM
TDG MAFIA MEMBER #77
 
TooLoudTooBad's Avatar
 
Join Date: Jul 2006
Posts: 940
Points: 22,827
Thanks: 13
Thanked 11 Times in 10 Posts
Oh yea, I would like to see a pic of Moms moose!

1999.5 PSD, 4x4, Auto trans, 6.0 Trans cooler, ZooDad Mod, ISSPRO Trans - boost - EGT gauges, Wicked Wheel, 5inch Stainless tip, 315 75 17 BFG AT's, ProComp 9000's at the corners, Fumatomo Valve, Pooned tank, DP Tuner F5 w/ 80 tow, 80 econo, 120 race and permagrin!
TooLoudTooBad is offline  
post #9 of 10 (permalink) Old 10-19-2007, 04:17 PM
The Irishman
 
Caos56's Avatar
 
Join Date: Oct 2007
Location: West Palm Beach, FL
Posts: 68
Points: 4,098
Thanks: 5
Thanked 7 Times in 7 Posts
Hey check your Injector Control Module. Its located on the drivers side fender. Three bolts hold it on, and water tends to get trapped in the unit. Mine got water in it and drove for two weeks before it died... Only downside is, if it is that part, ford wants like $600 for it, but i hear theres somewhere that rebuilds them for cheap.
Good luck
Billy
Caos56 is offline  
post #10 of 10 (permalink) Old 10-20-2007, 02:25 AM
Senior Member
 
Join Date: Dec 2008
Posts: 191
Points: 10,612
Thanks: 15
Thanked 9 Times in 9 Posts
I will try another CPS, maybe the new one is junk. Or check the UVC harness
STROKER#1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome