Check Engine light on & rough running - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by dieselbrad, this thread has received 2 replies and been viewed 1081 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-30-2007, 10:01 PM Thread Starter
 
Join Date: Oct 2007
Posts: 1
Points: 8,253
Thanks: 0
Thanked 0 Times in 0 Posts
Check Engine light on & rough running

First of all, hello! I have been reading this for the past month or two and now need help. I have a 95 F350. I installed new fenders and power washed the engine all at the same time. Since putting it all back together, it now runs like $^%$! At first start up, it purrs. Then after a second or two, the check engine lightt comes on and it sounds as if iut is only hitting on 4-6 cylinders. Any ideas on where to start since I don't know if something got wet or something didn't get hooked up. I've checked all grounds and retightned the injection box on the left fender. Thanks dieselbrad
dieselbrad is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-30-2007, 10:17 PM
strokin now cummin later!
 
Orangepstroke's Avatar
 
Join Date: Dec 2008
Location: Owensboro, KY
Posts: 1,116
Points: 32,155
Thanks: 6
Thanked 11 Times in 10 Posts
there is a big wire harness going across the valley (i forgot whats its called)of the motor unplug it and see if these water in it. it happened to me before and it coses it to run on the left side or right side only.

Erik, 2001 psd 4x4 lariat ext cab pulling truck
Ts 140hp 6pos chip, 100hp split shots, stealth 2 pump,h2e turbo, tranny, afe stage 2,
5" exhaust turbo back, 10" stack, 3.9k mod on a switch, shimmed fpr,hx crossover hose, tc lock up switch. Custom weight rack and ladder bars, f550 springs, custom paint,5%+15% window tint, clear lights,custom billet grille, very big stereo, 20x10 moto meatals wrap with 33x13.50x20 ss iroks
.


1996 2500 12v 2wd auto reg cab, flat bed, afc mods, sdx 140hp sticks, 4gsk, 60lbs springs, 191dv's, head studs, 16* timing, phat shaft 62/65/14 no plate, exhaust, intake, tanny, auto meter, adjustable overflow valve.

Singles Club #42
Orangepstroke is offline  
post #3 of 3 (permalink) Old 10-31-2007, 12:49 AM
Senior Member
 
Join Date: Dec 2008
Posts: 169
Points: 17,168
Thanks: 0
Thanked 1 Time in 1 Post
Look for water in the ICP connector.....

Rick....

Supporter/End user of ShiftSolutions THE CURE E4/4R Trans Control. Helping Cancer patients and families
www.fordtransmissioncure.com
Special thanks to RacerX USA
action4478 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome