Doesn't run right! PLEASE HELP!!!!!!!!! - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by 2tonePSD, this thread has received 4 replies and been viewed 571 times.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-30-2007, 11:35 PM Thread Starter
Senior Member
 
2tonePSD's Avatar
 
Join Date: Dec 2008
Location: Yorkville, IL
Posts: 420
Points: 12,799
Thanks: 1
Thanked 2 Times in 2 Posts
Exclamation Doesn't run right! PLEASE HELP!!!!!!!!!

I just put in a new set of glow plugs and now it runs real real ruff. I don't know what us going on, Please help I need this truck for tomorrow.

RIP.......
96 F-350 Regular cab: 5" to 6" exhaust. autometer Z series a pillar pod for gauges. Window tint.
2tonePSD is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-30-2007, 11:41 PM
Senior Member
 
Join Date: Jun 2006
Posts: 645
Points: 6,288
Thanks: 1
Thanked 44 Times in 41 Posts
you sure you didnt knock any injector connectors off? checkengine light on?
maing any funny noises or anything?

Ford certified diesel tech.
96 F350 reg cab, black. stage Is, exhaust intake TS 6pos chip and a few small tricks. tranny built up a little and a billet converter. 4in lift 35 bfg muds.
3" cowl hood, billet grille, bumper with billet grille and fog lights, 10in drop rear bumper with lights and a dropped hitch.

90 mustang lx 347 afr 185s, vic jr efi, aeromotive fuel system, c4 , 4.10 31 spline, tube k member and control arms coil overs and control arms in the rear, 10pt cage.

05 f250 red ext cab grey int, 4x4 6.0 suncoast tranny, ats 275cc injectors, studs, aeromotive fuel system, turbonetics 70mm ceramic coated turbo, dual 5 inch stacks turnned out. ALL PARTS FOR SALE
fordboyyfm is offline  
post #3 of 5 (permalink) Old 10-30-2007, 11:44 PM Thread Starter
Senior Member
Threadstarter
 
2tonePSD's Avatar
 
Join Date: Dec 2008
Location: Yorkville, IL
Posts: 420
Points: 12,799
Thanks: 1
Thanked 2 Times in 2 Posts
The check engine light is not on. it's not making any funny noises either just runs real ruff.

RIP.......
96 F-350 Regular cab: 5" to 6" exhaust. autometer Z series a pillar pod for gauges. Window tint.
2tonePSD is offline  
post #4 of 5 (permalink) Old 10-31-2007, 12:44 AM
Senior Member
 
Join Date: Dec 2008
Posts: 169
Points: 17,167
Thanks: 0
Thanked 1 Time in 1 Post
Re check the wiring. ....

re check the wiring...

re check the wiring....

Rick....

Supporter/End user of ShiftSolutions THE CURE E4/4R Trans Control. Helping Cancer patients and families
www.fordtransmissioncure.com
Special thanks to RacerX USA
action4478 is offline  
post #5 of 5 (permalink) Old 10-31-2007, 03:11 AM Thread Starter
Senior Member
Threadstarter
 
2tonePSD's Avatar
 
Join Date: Dec 2008
Location: Yorkville, IL
Posts: 420
Points: 12,799
Thanks: 1
Thanked 2 Times in 2 Posts
I got it. the glow plug all the way up against the fire wall wasn't hooked up all the way.
. I'm an idiot. lol

RIP.......
96 F-350 Regular cab: 5" to 6" exhaust. autometer Z series a pillar pod for gauges. Window tint.
2tonePSD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome