99 F 450 powerstroke stalling - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by squishy, this thread has received 5 replies and been viewed 2293 times.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-09-2009, 10:33 PM Thread Starter
Junior Member
 
Join Date: Jan 2009
Posts: 26
Points: 2,274
Thanks: 18
Thanked 2 Times in 2 Posts
99 F 450 powerstroke stalling

The truck will start up run rough until warmed up then it will run okay and then out of nowhere loose power and stall out and will not restart. If you wait an hour or two and try to start it it will fire up and run fine. I have changed the cps to a new one and then back to the old one thinking that had something to do with the problem it mad no difference. I have unplugged the IPR and still the same problem. Could the IDM be the culprit? Any help would be greatly appreciated.
squishy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-09-2009, 11:11 PM
 
Join Date: Jan 2009
Posts: 300
Points: 18,064
Thanks: 2
Thanked 21 Times in 10 Posts
Check out the uvc harness (the wiring under the valve covers and the valve cover gaskets themselves), that may be your issue. How many miles are on your truck? Any weird smoke?

-Brad Desatnik
trick76cj5 is offline  
post #3 of 6 (permalink) Old 09-10-2009, 06:22 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Jan 2009
Posts: 26
Points: 2,274
Thanks: 18
Thanked 2 Times in 2 Posts
The truck will puff blue smoke when you rev it up. The truck has just shy of 600,000 kms on the odo and the injector o rings were replaced about a month ago as well as the hpop ipr the cps and the fpr as well.
squishy is offline  
post #4 of 6 (permalink) Old 09-10-2009, 08:00 PM
Member
 
SmokeCloud's Avatar
 
Join Date: Aug 2009
Location: Levittown PA
Posts: 634
Points: 26,060
Thanks: 19
Thanked 48 Times in 48 Posts
Quote:
Originally Posted by squishy View Post
The truck will puff blue smoke when you rev it up. The truck has just shy of 600,000 kms on the odo and the injector o rings were replaced about a month ago as well as the hpop ipr the cps and the fpr as well.
blue smoke sounds like an oil leak to me, have you done a compression test, on a side note definitely check to see if your UVC is pinched.

Real Trucks Burn Diesel!
SmokeCloud is offline  
The Following User Says Thank You to SmokeCloud For this addition to TDG:
squishy (09-16-2009)
post #5 of 6 (permalink) Old 09-11-2009, 01:16 AM
Senior Member
 
Join Date: Dec 2008
Posts: 626
Points: 4,619
Thanks: 25
Thanked 88 Times in 55 Posts
Quote:
Originally Posted by SmokeCloud View Post
blue smoke sounds like an oil leak to me, have you done a compression test, on a side note definitely check to see if your UVC is pinched.
Compression check would be a good idea--with ~375,000 miles on the odometer it wouldn't be out of line for the rings to be worn, especially if the air intake wasn't sealed up tight the whole time.

2K2 F350 PSD/ZF6, Fluidampr/Melling LPOP, AirDog/ITP RR, DP F5, Tymar/high-flow outlet/MBRP 4", Dynatrac Free-Spin hub conversion
jvencius is offline  
The Following User Says Thank You to jvencius For this addition to TDG:
squishy (09-16-2009)
post #6 of 6 (permalink) Old 09-11-2009, 03:28 PM
 
Join Date: Jan 2009
Posts: 300
Points: 18,064
Thanks: 2
Thanked 21 Times in 10 Posts
A rough idle when cold is common on high mileage injectors. 7.3 injectors are typically due for a rebuild at 250k, obviously depending on oil and fuel services though. The stalling and not starting thing is not related to injector wear though, nor would it be related to low compression. What is your oil pressure? Could you be draining your HP oil reservoir over time due to low oil pressure? No oil in the HPOP oil resevoir would cause the injectors to not fire, then you would have to crank the truck for a while to refill the reservoir. 2 potential issues come to mind: 1) you're low on oil, 2) your LP oil pump is going out or you have excessive clearances in your motor that is causing too much internal oil losses when you're oil heats up. . .try running a Lucas Oil additive to your oil and see if it helps your situation. It would just be a band-aid, but would get you running and help isolate your problem.

-Brad Desatnik
trick76cj5 is offline  
The Following User Says Thank You to trick76cj5 For this addition to TDG:
squishy (09-16-2009)
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
E 04 stalling out? camojeeper Duramax 2001-2004 (LB7) 12 08-05-2009 03:01 AM
03 6.0 stalling out 03lariatsd 2003-2007 6.0L Power Stroke 3 03-15-2009 11:30 PM
stalling rodney960 1994-2003 7.3L Chips & Tuners Forum 8 08-10-2007 05:08 AM
Stalling 6.0 powerstroke03 2003-2007 6.0L Power Stroke 8 07-10-2006 04:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome