got a problem and need help!! got a miss!! - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by powersmoke18, this thread has received 7 replies and been viewed 1227 times.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-08-2010, 02:32 AM Thread Starter
Member
 
Join Date: Nov 2006
Posts: 81
Points: 7,041
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to powersmoke18
got a problem and need help!! got a miss!!

well i had a customer come to me with a no start 7.3. he said he did injectors because they failed. well after a little check over we found the relief valve on the filter housing had an oring jammed in it. so we replaced it and got her up and running. today i got a call that the engine wouldn't even pull the truck up over the hill by his house and it stalled out. so i went down to take a look and it fired right up when i got there and ran great. it idles fine and it has full rpm but when you drive it down the road it starts missing and eventually misses so bad it shuts off. any ideas?? so far it has new injectors, new pressure relief valve, new fuel filters.

thanks guys!!!
powersmoke18 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-08-2010, 02:39 AM
Senior Member
 
plainredtruck's Avatar
 
Join Date: Dec 2008
Location: Hickory Tavern, SC
Posts: 4,090
Points: 30,118
Thanks: 275
Thanked 444 Times in 285 Posts
Images: 11
what year is it?

Check the under valve cover wiring harness (UVCH).

Did you ask him where he got the new injectors? Has he had them tested since they were installed?

Any other info you can provide?

prt

'99 F250 X-cab 2wd

powered by DP-Tuner

My Photography addiction


Mafia # 27






plainredtruck is offline  
post #3 of 8 (permalink) Old 04-08-2010, 03:12 AM Thread Starter
Member
Threadstarter
 
Join Date: Nov 2006
Posts: 81
Points: 7,041
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to powersmoke18
the international dealer he said. they were all new tho. not rebuilt. i checked over the harnesses in the heads they look good. its a 99.5. wish he would have brought it to me first. we are doing the work for free because he kinda screwed himself. plus he had 2 strokes in the past 9 months so hes had some bad luck.
powersmoke18 is offline  
post #4 of 8 (permalink) Old 04-08-2010, 01:29 PM Thread Starter
Member
Threadstarter
 
Join Date: Nov 2006
Posts: 81
Points: 7,041
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to powersmoke18
well hes been running biofuel to come to find out. collapsed line maybe??
powersmoke18 is offline  
post #5 of 8 (permalink) Old 04-08-2010, 01:33 PM
Senior Member
 
plainredtruck's Avatar
 
Join Date: Dec 2008
Location: Hickory Tavern, SC
Posts: 4,090
Points: 30,118
Thanks: 275
Thanked 444 Times in 285 Posts
Images: 11
Change the filters again.

He could easily have a clogged filter running biodiesel.

Might want to check the fuel pressure as well.

prt

'99 F250 X-cab 2wd

powered by DP-Tuner

My Photography addiction


Mafia # 27






plainredtruck is offline  
post #6 of 8 (permalink) Old 04-08-2010, 01:59 PM Thread Starter
Member
Threadstarter
 
Join Date: Nov 2006
Posts: 81
Points: 7,041
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to powersmoke18
ya ill try the filter but i just think theres more to it.
powersmoke18 is offline  
post #7 of 8 (permalink) Old 04-08-2010, 05:29 PM
7.3 addict
 
Join Date: Jul 2007
Location: waterloo Il. (stlouis)
Posts: 644
Points: 44,434
Thanks: 82
Thanked 48 Times in 42 Posts
Garage
i run 100% bio on my 99 and have never had a prob other than filtes getting dirty. doubt about a line collapsing

1) 99 f-350 srw 7.3 6pos. bully dog, afe intake, mrbp 4" exhaust,250,000 miles and still rollin.
2) 2000 excursion 7.3 afe intake, mrbp 4" exhaust. chip coming
3) NEW TO ME2000 cc drw 7.3 let the mods begin
4) FOR SALE 87 f250 6.9 9' utility body.
5) SOLD 91 f150 good truck just well used.Gonna miss the old girl allways started even after sitting for 6 months.

I think i'm trailer poor ) 22' w\18' tilt car hauler, 18' flat bed, 2 horse D&D, 12' utility, 19' "v" nose, and 37' 5er

"quote from tank"
"I use baby wipes.....


Because if you think that a wadded up piece of paper is actually getting the chit off of your butt.....then I have to ask a question....

.....if you wiped a turd on your arm....would you just use a paper towel to get the turd off?.....or would you wash your arm?...


...let that thought roll around in your head for a moment...


" thank you tank for that insightful thought

#46 AMERICAN (blood) club
#241 singles club
# ? Dually club
# ? Excursion club
jestersv is offline  
post #8 of 8 (permalink) Old 04-10-2010, 06:48 AM Thread Starter
Member
Threadstarter
 
Join Date: Nov 2006
Posts: 81
Points: 7,041
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to powersmoke18
well we put some compressed air thru the lines and bam!! truck runs great!! dropped the tank hoping to find something but no luck. so who knows. transfer pump holds a steady 65psi pulling big hills. thanks for the help guys!!!
powersmoke18 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hit or miss? bmoeller 5.9L Cummins (1998.5-2002) 2 03-25-2009 02:22 AM
mystery problem/miss? Super10lbz 5.9L Cummins (2003-2007.5) 3 12-05-2007 11:56 PM
did I miss something? rockpsd The Parking Lot 9 04-03-2006 12:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome