Truck loses power while driving. - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by bigdieselpower, this thread has received 19 replies and been viewed 15097 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 05-30-2010, 07:08 PM Thread Starter
Junior Member
 
Join Date: Jan 2008
Location: Waterford,WI
Posts: 49
Points: 4,065
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via AIM to bigdieselpower Send a message via MSN to bigdieselpower Send a message via Yahoo to bigdieselpower
Truck loses power while driving.

My buddy has a 1997 F350 7.3L when he is driving down the road the truck loses power while about 35-50mph, when it does it the wait to start light comes on, and you have to let off the throttle completely and get back on it and its fine for abit. The ABS light also cames on once and again, when it does that the truck lunges at a stop and the RPM's go up to 1500RPM, and yougotta trow it in Neutral or you'll run over the *****s in front of you. I hooked my chip up to it and it read Cam sensor so i swapped it out and its still doing it. Any Help on this would be greatly appreciated, this is his daily driver. THANKS!!!

1995 Ford F250 7.3L Powerstroke. Edge Evolution programmer, 4" bully dog turbo back strait pipe exhaust, cold air kit, 4 corner strobe, LED lightbar,35" Mud Terrains, 5th wheel, Panasonic Toughbook mounted on a laptop mount with Garmin Mobile PC.
bigdieselpower is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 05-31-2010, 02:42 AM
Junior Member
 
Join Date: May 2009
Posts: 9
Points: 15,910
Thanks: 0
Thanked 0 Times in 0 Posts
Any codes?
burningoil is offline  
post #3 of 20 (permalink) Old 05-31-2010, 03:37 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Jan 2008
Location: Waterford,WI
Posts: 49
Points: 4,065
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via AIM to bigdieselpower Send a message via MSN to bigdieselpower Send a message via Yahoo to bigdieselpower
At first i got a Cam position sensor code, and cleared it, that hasnt come back yet that i know of.

1995 Ford F250 7.3L Powerstroke. Edge Evolution programmer, 4" bully dog turbo back strait pipe exhaust, cold air kit, 4 corner strobe, LED lightbar,35" Mud Terrains, 5th wheel, Panasonic Toughbook mounted on a laptop mount with Garmin Mobile PC.
bigdieselpower is offline  
post #4 of 20 (permalink) Old 05-31-2010, 04:36 AM
********* and Mafia #90
 
Bcarriveau's Avatar
 
Join Date: Jul 2007
Location: New Berlin, WI
Posts: 14,261
Points: 91,898
Thanks: 943
Thanked 1,333 Times in 985 Posts
Garage
Send a message via AIM to Bcarriveau Send a message via Yahoo to Bcarriveau
To loose power you need to loose fuel.. change fuel filters. Don't get the cheap ones..




Bill Carriveau OFFICIAL POO HAULER

ARP studs, sct, Leveling kit,Airdog set at 62psi with no factory pump, leveling kit,5" stacks, under cab lights, Large in the way Fan shroud Removed, bed Lights being Re-did. Large Alternator(250amps)(130 amps was so 2003). On 3rd set of Hgs(soon to be 4th), 2nd set of heads, 2nd tubro, egr cooler, FICM and more. When i Turn the Key it does return a Favor, not always in MY Favor.
Da Rules..Here
http://i449.photobucket.com/albums/q...g?t=1249694332
Windows 7 Takes the WIN!
Windows 8 might take that Win
http://www.bcarriveau.com/
Dear Tequila:
We had a deal. You were supposed to make me sexier, smarter and a better dancer. But I saw the video. And I think we need to talk..


How you name your Thread is Important. Read Here

The TDG TOTQ


Bcarriveau is offline  
post #5 of 20 (permalink) Old 05-31-2010, 01:33 PM
Junior Member
 
Join Date: May 2009
Posts: 9
Points: 15,910
Thanks: 0
Thanked 0 Times in 0 Posts
How is the engine oil? These need to be full of good oil. I have seen it before, the owner said it was and all it needed to run rite was a oil change.
burningoil is offline  
post #6 of 20 (permalink) Old 06-01-2010, 02:03 PM
********* and Mafia #90
 
Bcarriveau's Avatar
 
Join Date: Jul 2007
Location: New Berlin, WI
Posts: 14,261
Points: 91,898
Thanks: 943
Thanked 1,333 Times in 985 Posts
Garage
Send a message via AIM to Bcarriveau Send a message via Yahoo to Bcarriveau
I dont know much about the 7.3 but could this be a sign of a bad HPOP?




Bill Carriveau OFFICIAL POO HAULER

ARP studs, sct, Leveling kit,Airdog set at 62psi with no factory pump, leveling kit,5" stacks, under cab lights, Large in the way Fan shroud Removed, bed Lights being Re-did. Large Alternator(250amps)(130 amps was so 2003). On 3rd set of Hgs(soon to be 4th), 2nd set of heads, 2nd tubro, egr cooler, FICM and more. When i Turn the Key it does return a Favor, not always in MY Favor.
Da Rules..Here
http://i449.photobucket.com/albums/q...g?t=1249694332
Windows 7 Takes the WIN!
Windows 8 might take that Win
http://www.bcarriveau.com/
Dear Tequila:
We had a deal. You were supposed to make me sexier, smarter and a better dancer. But I saw the video. And I think we need to talk..


How you name your Thread is Important. Read Here

The TDG TOTQ


Bcarriveau is offline  
post #7 of 20 (permalink) Old 06-01-2010, 02:37 PM
Senior Member
 
plainredtruck's Avatar
 
Join Date: Dec 2008
Location: Hickory Tavern, SC
Posts: 4,090
Points: 30,170
Thanks: 275
Thanked 444 Times in 285 Posts
Images: 11
I know you don't have any other codes, but check the TPS - Throttle Position Sensor

'99 F250 X-cab 2wd

powered by DP-Tuner

My Photography addiction


Mafia # 27






plainredtruck is offline  
post #8 of 20 (permalink) Old 06-01-2010, 09:55 PM
TwinStacks
 
SmknDzl's Avatar
 
Join Date: Dec 2008
Location: Maryland
Posts: 184
Points: 38,230
Thanks: 23
Thanked 12 Times in 12 Posts
I had an issue of not getting any throttle response here and there but idled fine and turned out to be the speed control sensor in the rear. check the ring gear and/or sensor and wires to it.

good luck and hope you get it figured out soon.

Chris Cayer- www.facebook.com/SmknDzl or www.myspace.com/smkndzl send a request


Early '99 Black Lariat F-350 cclb dually-TS 6 position, AFE StageII, Autometer UltraLite Gauges, 6" Turnout Stacks, Muffler/Cat Delete, Built Trans from RacerX with .670 Line Mod Valve and Full LockUp Valve, 6.0L Trans Cooler, Boost Relief Valve, Oil X-Over, 5% Tint Around With 20% On The Windshield and 5% Strip On Top, Tinted Tail Lights, 2003 Clear Headlights, VisionX 8K H.I.D. Kit, JVC InDash DVD, APS997 Remote Start and Alarm, Painted Grille and Mirrors, WhiteNight Reverse Lights
Competition Cobra29, DaveMade Comp 2x2, 2x4 and 5pill boxes on VOLTS, Modified Wilson 5000...YEAH IM TALKING
Nathan Airchime P5 Train Horns @ 200PSI
SmknDzl is offline  
post #9 of 20 (permalink) Old 06-02-2010, 02:35 AM
Senior Member
 
plainredtruck's Avatar
 
Join Date: Dec 2008
Location: Hickory Tavern, SC
Posts: 4,090
Points: 30,170
Thanks: 275
Thanked 444 Times in 285 Posts
Images: 11
I've seen the VSS throw the ABS light and knock out the speedo, but never cause the truck to stumble.

Not sayin' it can't happen, just that I've never seen it or heard of it.



prt

'99 F250 X-cab 2wd

powered by DP-Tuner

My Photography addiction


Mafia # 27






plainredtruck is offline  
post #10 of 20 (permalink) Old 06-02-2010, 03:54 AM
Junior Member
 
Join Date: May 2010
Posts: 44
Points: 7,317
Thanks: 3
Thanked 1 Time in 1 Post
Inside the sending unit in the fuel tank there are two plastic screens/filters. Those may be stopped up too
bigdaddy60 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
6.9 loses power, then it's ok, then loses power islander16 7.3L and 6.9 IDI (Pre 1994) 1 02-26-2010 10:30 AM
Taho loses power and blows black smoke firecop 6.5L Diesel Engine 5 03-23-2008 01:04 AM
no power when first start driving teamroper24 1994-2003 7.3L Power Stroke 9 11-28-2007 03:45 AM
truck boggs down and loses power at low rpm ford_truck_1976 1994-2003 7.3L Power Stroke 7 01-17-2007 03:23 AM
7.3 Loses Power on Highway NoWake200 1994-2003 7.3L Power Stroke 6 09-13-2006 03:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome