So I fried my ECM with the edge... - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by easy money, this thread has received 6 replies and been viewed 2674 times.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-03-2009, 05:14 AM Thread Starter
Junior Member
 
easy money's Avatar
 
Join Date: Dec 2008
Location: ECI indiana,northeast of indianapolis
Posts: 272
Points: 26,527
Thanks: 25
Thanked 7 Times in 7 Posts
So I fried my ECM with the edge...

What are the do's and dont's with tuners?


I followed the directions with the edge evo, but I could've made a misstake in all the excitment.
easy money is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-03-2009, 11:42 AM
Dieselis' Maximus
 
driximus's Avatar
 
Join Date: Mar 2006
Posts: 1,744
Points: 23,706
Thanks: 11
Thanked 30 Times in 27 Posts
ensure the keys are not in the ignition when putting in chips or taking them out. I always disconnect my batteries also.

"Why in hell can't the Army do it if
the Marines can. They are the same
kind of men; why can't they be like
Marines."
Gen. John J "Black Jack" Pershing, USA; 12 February
1918
driximus is offline  
post #3 of 7 (permalink) Old 07-04-2009, 12:11 AM
git-r-done
 
TSGS69400's Avatar
 
Join Date: Aug 2007
Posts: 457
Points: 24,623
Thanks: 1
Thanked 7 Times in 6 Posts
Call edge and they will hook u up with a new tuner that will load the files completely. My friend did this a week ago.
Let me guess,, it will only flash the glow plug light and will crank but wont start.
We changed PCMs temporarily to get the truck home.

Thad Seybert
2008 F-350 crew cab short bed Lariat 4x4 6.4 with 3.73's Spartan flash update 250 210 175 150, S&B intake, MBRP cool duals, Rockford amps, Infinity speakers, Tuff Tonneau,
1996 F-250 extended cab short bed 4x4 7.3 5-spd with 3.55's , DIY STG 1's, 4" Diamond Eye duals, DIY Intake, dp tuner, Cobalt gauges, Adrenaline pump, SD springs, D66 turbo, 6.0 intercooler, Custom electric regulated fuel system, Truetrac.
TSGS69400 is offline  
post #4 of 7 (permalink) Old 07-04-2009, 07:47 PM Thread Starter
Junior Member
Threadstarter
 
easy money's Avatar
 
Join Date: Dec 2008
Location: ECI indiana,northeast of indianapolis
Posts: 272
Points: 26,527
Thanks: 25
Thanked 7 Times in 7 Posts
Quote:
Originally Posted by TSGS69400 View Post
Call edge and they will hook u up with a new tuner that will load the files completely. My friend did this a week ago.
Let me guess,, it will only flash the glow plug light and will crank but wont start.
We changed PCMs temporarily to get the truck home.


You sir are 100% correct. I had to do the pcm change also.
easy money is offline  
post #5 of 7 (permalink) Old 07-06-2009, 05:31 PM
Truck pullin' S.O.B.
 
OffKilter's Avatar
 
Join Date: Dec 2008
Location: North Eastern Pa
Posts: 162
Points: 23,248
Thanks: 21
Thanked 6 Times in 5 Posts
Images: 13
What causes this we went through this a couple of years w/ my dads 97. Edge sent us something I can't remember if it was a new pcm or the evo. But my dad never reinstalled the evo. Edge said it was because of the location of the pcm and the length of the harness and that the older pcms didn't like switching between tunes. I have the Evo (same one) in my 03 7.3L now and I haven't had any trouble but I don't switch tunes all that much I went from stock- tow- race then back to tow since I installed it in oct 08. Now after reading this I'm afraid to switch for fear the truck will be down and I use it for work but I really miss the power on race.


1999 F-250 Lariat, Red, Super Cab, Short Box, 6.8L V-10
2003 F-350 XLT Regular Cab Long Box 6.0L 6-speed, tinted windows, push bar, 4inch MBRP exhaust, Edge Juice w/ attatude.
1969 F350 "The Shillelagh" future pulling truck, 428ci, 4-speed, 4:10 gears.
OffKilter is offline  
post #6 of 7 (permalink) Old 07-08-2009, 06:51 PM
GOS
Supporting Vendor
 
GOS's Avatar
 
Join Date: Aug 2005
Location: Livingston, MT
Posts: 2,150
Points: 62,970
Thanks: 1
Thanked 67 Times in 49 Posts
It is usually always a voltage problem, especially on the 94-07 vintage. Edge will send you a stock writer according to the catch codes on the computer. It will simply restore a stock program into the vehicle. If you have a battery booster pack. Hook it up to the batteries while programming. This will usually take care of any voltage problems. If Edge hasn't sent you a stock writer yet, let me know I've got most of them. As far as changing programs, change as much as you like, just be sure to have good voltage.

Contact 1-800-620-4467
Fax 1-406-222-4926
[email protected]

GOS Performance, Livingston, Mt. Wholesale distributor for Edge, Superchips, SCT, Quadzilla, Smarty, Diablo, Dr Performance, Bully Dog, MBRP, Magnaflow, aFe, S&B, Industrial Injection, High Tech Turbos, BD Diesel, ATS Diesel, SunCoast, South Bend Clutch, Haisley Machine, ARP, DiPricol, Autometer, Revtek, Superlift, Rancho, ProFab, Destroked Conversions, family owned and operated since 1994. Dealer Inquiries welcome.
GOS is offline  
post #7 of 7 (permalink) Old 07-09-2009, 05:08 AM Thread Starter
Junior Member
Threadstarter
 
easy money's Avatar
 
Join Date: Dec 2008
Location: ECI indiana,northeast of indianapolis
Posts: 272
Points: 26,527
Thanks: 25
Thanked 7 Times in 7 Posts
Quote:
Originally Posted by OffKilter View Post
What causes this we went through this a couple of years w/ my dads 97. Edge sent us something I can't remember if it was a new pcm or the evo. But my dad never reinstalled the evo. Edge said it was because of the location of the pcm and the length of the harness and that the older pcms didn't like switching between tunes. I have the Evo (same one) in my 03 7.3L now and I haven't had any trouble but I don't switch tunes all that much I went from stock- tow- race then back to tow since I installed it in oct 08. Now after reading this I'm afraid to switch for fear the truck will be down and I use it for work but I really miss the power on race.
I haven't hooked up the edge either kind of scared.
easy money is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranny fried? Dozer 2003-2007 6.0L Power Stroke 5 02-13-2009 02:54 AM
Fried Powerstroke smokedrail The Parking Lot 16 03-11-2008 08:44 AM
Transmission is fried!!!! WBV06CTD 5.9L Cummins (1998.5-2002) 11 02-09-2007 10:28 PM
Fried Chicken Song Ramprat The Parking Lot 7 09-25-2006 03:13 AM
95Ford350-fried transmission Rol250 1994-2003 7.3L Power Stroke 8 10-27-2005 03:10 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome