glow plugs - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by dirtrider490, this thread has received 5 replies and been viewed 1358 times.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-06-2010, 12:38 AM Thread Starter
Junior Member
 
Join Date: Sep 2010
Posts: 7
Points: 16,849
Thanks: 2
Thanked 0 Times in 0 Posts
glow plugs

i have checked the glow plugs and replaced them and also replaced the glow plug relay so i think the control sensor might be bad any input is useful because i need this truck to work
dirtrider490 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-06-2010, 03:47 AM
TDG MAFIA
 
Cincinnati Guy's Avatar
 
Join Date: Dec 2008
Location: DTT
Posts: 730
Points: 31,151
Thanks: 135
Thanked 69 Times in 57 Posts
Garage
More information will help us help you better. What are you having difficult starting it? Have you verified the glow plugs are not working? Also we need to know the year of your truck because there are two different types of glow plug systems that are very different.

FORMERLY SMOKIN85

Ryan
1994 F-350 SRW Crew Cab 4x4 Dana 60 Front, 4.10 Gears with a E4OD

SOLD-1992 F350 7.3
Ryans 92 Diesel Pictures

SOLD-1985 F250 6.9 NA
Ryans 85 Diesel Pictures

The Diesel Garage Mafia
Singles Club
Ridin' Dirty Club #24



Don't forget to vote in TOTQ
Cincinnati Guy is offline  
post #3 of 6 (permalink) Old 09-06-2010, 04:38 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Sep 2010
Posts: 7
Points: 16,849
Thanks: 2
Thanked 0 Times in 0 Posts
glow plug problem

its a 1986 ford f 350 dually 6.9l idi having trouble starting it glow plugs dont seem to work changed them and the relay the previous owner installed a push star button key still needed. used either to start after running it starts right up again.
dirtrider490 is offline  
post #4 of 6 (permalink) Old 09-06-2010, 05:12 AM
TDG MAFIA
 
Cincinnati Guy's Avatar
 
Join Date: Dec 2008
Location: DTT
Posts: 730
Points: 31,151
Thanks: 135
Thanked 69 Times in 57 Posts
Garage
Ok put that can of ether away, its actually a bad idea to use on our trucks. The push button for the glow plugs is a common modification for the 6.9 IDI Glow plug system, because some have problems with the controller on the back of the block. Take a test light and attach it to the ground and have a buddy turn on the key and do this to all 8 and verify if your getting any power to the plugs. Does your wait to start light come on? Also make sure the glowplugs in the motor are only Motorcraft as most others expecially Autolites will burn the tip off and fall into your intake causing BIG problems.

FORMERLY SMOKIN85

Ryan
1994 F-350 SRW Crew Cab 4x4 Dana 60 Front, 4.10 Gears with a E4OD

SOLD-1992 F350 7.3
Ryans 92 Diesel Pictures

SOLD-1985 F250 6.9 NA
Ryans 85 Diesel Pictures

The Diesel Garage Mafia
Singles Club
Ridin' Dirty Club #24



Don't forget to vote in TOTQ
Cincinnati Guy is offline  
post #5 of 6 (permalink) Old 09-06-2010, 04:24 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Sep 2010
Posts: 7
Points: 16,849
Thanks: 2
Thanked 0 Times in 0 Posts
glow plugs

the wait to start light does not come on the push button is only to crank the motor over the key is still needed to turn on the power for the cab and other electronics ill try the wiring to the plugs to see if they get power what do i ground the test light to
dirtrider490 is offline  
post #6 of 6 (permalink) Old 09-06-2010, 06:43 PM
Super Moderator
 
John_G's Avatar
 
Join Date: Dec 2008
Location: Tyler, TX
Posts: 4,247
Points: 74,641
Thanks: 101
Thanked 407 Times in 347 Posts
It sounds like the main engine connector in the RH side inner fender area may be a problem. Over time the connections can get loose or corroded and if that happens the GP system might not work and the starter might not work normally.

Personally, I HATE that "slow-start" 12V GP system I have ripped it off every truck I had with it and installed the updated "Fast Start" system which is MUCH more reliable.

You could have a bad controller, loose power or ground wire to it, or even a bad relay for the GP system. Those are a bear to correctly diagnose, luck is your best bet with the "Slow Start" system

'93 F-250 HD, 7.3L IDI, 5spd - FARM TRUCK
I Support: Trailer brakes an every axle over the towing vehicle's GVW; CDLs for RVers; Safety inspections for ALL vehicles and 6 axle trucks (97K GVW proposal).

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote - Benjamin Franklin

I vote for LIBERTY!
John_G is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
glow plugs Sabbath5.9 2003-2007 6.0L Power Stroke 2 10-26-2009 12:18 AM
glow plugs mhale0312 1994-2003 7.3L Power Stroke 4 03-26-2009 01:58 AM
Glow Plugs or Glow Plug Relay BillsFan 1994-2003 7.3L Power Stroke 6 12-19-2007 12:51 AM
glow plugs smoker420 7.3L and 6.9 IDI (Pre 1994) 1 12-02-2007 05:09 PM
glow plugs pitjeep 1994-2003 7.3L Power Stroke 7 08-17-2007 02:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome