Boys i need some help! - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by trapper24-7, this thread has received 11 replies and been viewed 1870 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 11-30-2010, 05:43 PM Thread Starter
Junior Member
 
Join Date: Nov 2010
Location: Indiana
Posts: 28
Points: 21,043
Thanks: 11
Thanked 0 Times in 0 Posts
Send a message via AIM to trapper24-7
Angry Boys i need some help!

I just bought a new glow plug relay because my old one went bad and burned up all my glow plugs. And we were messing around with the old relay before we took it off the truck to see if that was what was wrong and we touched something wrong and it sparked and my Wait TO Start light would not come on we just blew the relay fuse. Ok so no great big deal but we put the new relay on last night and the new fuse in and when i went to turn on the key the Wait To Start light comes on for about 1 sec and then goes off and the relay will just tick, like tick tick tick tick tick. So now what the heck is wrong??
trapper24-7 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 12-01-2010, 03:59 AM
Junior Member
 
hayjayhorses's Avatar
 
Join Date: Dec 2006
Location: Palmer, Massachusetts
Posts: 645
Points: 73,882
Thanks: 3
Thanked 48 Times in 48 Posts
they are a pain in the ***

I had a few of them trucks, I just installed a push button to excite the relay. I worked very well, as long as you didn't hold it to long, I would dow 20 seconds max when real cold. 10 second worked well for most starts.

Jay Noone
413-222-8286
I got hay
abolish the Federal Reserve, they are the real problem

Vote Ron Paul 2012
hayjayhorses is offline  
post #3 of 12 (permalink) Old 12-01-2010, 02:14 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2010
Location: Indiana
Posts: 28
Points: 21,043
Thanks: 11
Thanked 0 Times in 0 Posts
Send a message via AIM to trapper24-7
Ok thank you i will keep that in mind. I took back the new relay, we think it might be bad but if it does the same thing i will have to try that.
trapper24-7 is offline  
post #4 of 12 (permalink) Old 12-01-2010, 06:35 PM
TDG MAFIA
 
Cincinnati Guy's Avatar
 
Join Date: Dec 2008
Location: DTT
Posts: 730
Points: 31,153
Thanks: 135
Thanked 69 Times in 57 Posts
Garage
What year truck we talking about? There are two different systems depending if you have the 6.9 or 7.3 motor. Did you install Motorcraft glow plugs/

FORMERLY SMOKIN85

Ryan
1994 F-350 SRW Crew Cab 4x4 Dana 60 Front, 4.10 Gears with a E4OD

SOLD-1992 F350 7.3
Ryans 92 Diesel Pictures

SOLD-1985 F250 6.9 NA
Ryans 85 Diesel Pictures

The Diesel Garage Mafia
Singles Club
Ridin' Dirty Club #24



Don't forget to vote in TOTQ
Cincinnati Guy is offline  
post #5 of 12 (permalink) Old 12-02-2010, 06:35 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2010
Location: Indiana
Posts: 28
Points: 21,043
Thanks: 11
Thanked 0 Times in 0 Posts
Send a message via AIM to trapper24-7
It is a 1993 7.3 turbo. i am getting Beru's, is that a pretty good brand of glow plugs? The glow plugs were bad in the truck when i got it so i bought all new Auto Lights and it burned those all up the relay was staying on. I was talking to a guy and he said the Auto Lights are a really crappy bran and they swell a lot or brake off. Is Motercraft better then Beru's?
trapper24-7 is offline  
post #6 of 12 (permalink) Old 12-04-2010, 01:44 AM
TDG MAFIA
 
Cincinnati Guy's Avatar
 
Join Date: Dec 2008
Location: DTT
Posts: 730
Points: 31,153
Thanks: 135
Thanked 69 Times in 57 Posts
Garage
Ok you have the newer version glow plugs (solid State system) And yes Beru is also motorcraft so your good there! Yes Autolight and champion are the two worst plugs to ever buy for an IDI. Everyone swears by the Motorcraft/Beru plugs.

Just remember Motorcraft is Beru.

FORMERLY SMOKIN85

Ryan
1994 F-350 SRW Crew Cab 4x4 Dana 60 Front, 4.10 Gears with a E4OD

SOLD-1992 F350 7.3
Ryans 92 Diesel Pictures

SOLD-1985 F250 6.9 NA
Ryans 85 Diesel Pictures

The Diesel Garage Mafia
Singles Club
Ridin' Dirty Club #24



Don't forget to vote in TOTQ
Cincinnati Guy is offline  
post #7 of 12 (permalink) Old 12-04-2010, 05:28 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2010
Location: Indiana
Posts: 28
Points: 21,043
Thanks: 11
Thanked 0 Times in 0 Posts
Send a message via AIM to trapper24-7
Ok thanks Ryan.
trapper24-7 is offline  
post #8 of 12 (permalink) Old 12-04-2010, 05:28 PM
Super Moderator
 
John_G's Avatar
 
Join Date: Dec 2008
Location: Tyler, TX
Posts: 4,247
Points: 74,642
Thanks: 101
Thanked 407 Times in 347 Posts
Quote:
Originally Posted by trapper24-7 View Post
Ok so no great big deal but we put the new relay on last night and the new fuse in and when i went to turn on the key the Wait To Start light comes on for about 1 sec and then goes off and the relay will just tick, like tick tick tick tick tick. So now what the heck is wrong??
At what temperature?

Let me take a photo of how the GPR should be wired...

The GPR is activated by the GPC it is mounted to based on GP temperature. High resistance = high temperature, if the GPC sees high resistance in the GP circuit it will think the engine is warm, whether it is or not. Therefore, it is important to make SURE all the terminals are clean and tight and the bullet connectors seat well onto the GPs. With one bad GP the GPC will short-cycle the GPs and you may have a misfire or hard start below about 30*F, with two bad, it will more than likely not start at all because the GPC will not think the engine is cold enough to need the GPs on very long - even at -20*F.

'93 F-250 HD, 7.3L IDI, 5spd - FARM TRUCK
I Support: Trailer brakes an every axle over the towing vehicle's GVW; CDLs for RVers; Safety inspections for ALL vehicles and 6 axle trucks (97K GVW proposal).

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote - Benjamin Franklin

I vote for LIBERTY!
John_G is offline  
post #9 of 12 (permalink) Old 12-05-2010, 01:35 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2010
Location: Indiana
Posts: 28
Points: 21,043
Thanks: 11
Thanked 0 Times in 0 Posts
Send a message via AIM to trapper24-7
The truck was cold and it was about 32 out. Thanks for the help John. I took back the GPC and i am just going to run a push button to the glow plugs and i hope that works. I have had a lot of guys tell me the GPC are a pain in the butt. And + that will save me 83 dollars so we will give it a try. Thank you all for the help! Mitch
trapper24-7 is offline  
post #10 of 12 (permalink) Old 12-05-2010, 02:37 AM
Super Moderator
 
John_G's Avatar
 
Join Date: Dec 2008
Location: Tyler, TX
Posts: 4,247
Points: 74,642
Thanks: 101
Thanked 407 Times in 347 Posts
Boy don't hold the button over 8 seconds or so, 12 max and that is ONLY if it's REALLY cold, like below 0*F or you will burn up those GPs!

The solid state controllers are excellant, I have never needed to replace one. The older "slow start" systems and all GMs, yea, they were junk.

'93 F-250 HD, 7.3L IDI, 5spd - FARM TRUCK
I Support: Trailer brakes an every axle over the towing vehicle's GVW; CDLs for RVers; Safety inspections for ALL vehicles and 6 axle trucks (97K GVW proposal).

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote - Benjamin Franklin

I vote for LIBERTY!
John_G is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
here boys SOOTBANDIT 6.7L Cummins (2007.5-2011) 29 09-06-2009 01:13 AM
bye boys... blackcloudCTD95 The Parking Lot 14 08-21-2009 04:12 AM
Boys I need HELP on this one! DSLGRL 1994-2003 7.3L Power Stroke 3 03-29-2008 03:48 PM
Ok boys eat this up. What do you think about rap? 1996 StrokerKid The Parking Lot 23 11-27-2007 07:31 PM
What up boys SPAZBOY Duramax 2004.5-2005(LLY) 10 02-26-2006 09:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome