Ticking sound in my 6.9 IDI - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by International6.9IDI, this thread has received 3 replies and been viewed 2223 times.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-10-2010, 09:40 PM Thread Starter
Junior Member
 
Join Date: Dec 2010
Posts: 3
Points: 380
Thanks: 0
Thanked 1 Time in 1 Post
Garage
Ticking sound in my 6.9 IDI

Alright so here is my situation, the other day i replace all 8 glow plugs in my 1986 F-250 With a 6.9 IDI diesel and when i started it up again there was a ticking sound coming from the engine. I was told that it could be a piece of one of the old glow plugs in the cylinder. I drove it around and the sound got a little quieter particularly when it is at an idle. I also topped off the oil which was less than a quart low and it got a little quieter again. Does anybody have any idea what it could be and how i could fix it?
International6.9IDI is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-10-2010, 10:21 PM
Gone Fishin...
 
merlin5577's Avatar
 
Join Date: Dec 2008
Location: Taunton, MA
Posts: 3,099
Points: 13,247
Thanks: 1,058
Thanked 561 Times in 471 Posts
Send a message via AIM to merlin5577 Send a message via Yahoo to merlin5577
Are you sure you tightened all the glow plugs when you put the new ones in? A loose glow plug would cause a ticking sound.

-Robert.

My Fleet;

2011 Volkswagen Jetta TDI 2.0L 6A
2010 Chevrolet Malibu LT 2.4L 6A
2003 Chevrolet Silverado LS 6.6L 5A
1997 GMC Suburban SLT 5.7L 4A

TDG MAFIA
Quote:
If you dont stand behind our troops, feel free to stand in front of them.
Thinking of buying a Duramax? You need to click this link;

Reading material

I am an old Fart;

Toot-Toot

merlin5577 is offline  
post #3 of 4 (permalink) Old 12-11-2010, 12:18 AM
Super Moderator
 
John_G's Avatar
 
Join Date: Dec 2008
Location: Tyler, TX
Posts: 4,247
Points: 74,648
Thanks: 101
Thanked 407 Times in 347 Posts
Did ALL the GPs you removed appear to be complete with rounded tips? If not, then it seems that you may have the tip of one or more GPs bouncing about in the cylinder, which is not good.

Yes, also make SURE you properly Tq the GPs, 18 lb-ft as I recall.

'93 F-250 HD, 7.3L IDI, 5spd - FARM TRUCK
I Support: Trailer brakes an every axle over the towing vehicle's GVW; CDLs for RVers; Safety inspections for ALL vehicles and 6 axle trucks (97K GVW proposal).

Democracy is two wolves and a lamb voting on what to have for lunch. Liberty is a well-armed lamb contesting the vote - Benjamin Franklin

I vote for LIBERTY!
John_G is offline  
post #4 of 4 (permalink) Old 12-11-2010, 01:34 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Dec 2010
Posts: 3
Points: 380
Thanks: 0
Thanked 1 Time in 1 Post
Garage
Some of the plugs didn't come out compleat but they didn't look broken it looked more like they were burnt away.
International6.9IDI is offline  
Reply

Tags
6.9, ford, idi, tick

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ticking sound can anyone help fordvan 6.2L Diesel Engine 0 02-16-2010 12:32 AM
Ticking Sound fryguy 2008-2010 6.4L Power Stroke 4 10-04-2007 01:47 AM
Erratic ticking sound from engine DieselMonk Duramax 2006-2007(LBZ & LLY) 5 08-11-2007 12:45 AM
Ticking sound from turbo strokin 1994-2003 7.3L Power Stroke 3 07-19-2007 09:03 PM
Ticking sound.. blackcloudCTD95 5.9L Cummins 12 Valve (1994-1998.5) 5 06-19-2007 04:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome