89 7.3L running rough and smoking. Non-turbo. - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by MT KingRanch, this thread has received 3 replies and been viewed 7315 times.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-17-2011, 03:08 AM Thread Starter
Junior Member
 
MT KingRanch's Avatar
 
Join Date: Sep 2010
Posts: 51
Points: 23,332
Thanks: 20
Thanked 13 Times in 9 Posts
89 7.3L running rough and smoking. Non-turbo.

Motor has 303k miles on it, is my truck to drive to work. Started out surging, stuttering and running rough, thought it was bad fuel so I've changed the filter 3 times now, first time the sediment bowl had some water and crap in it but last 2 seem to have been ok, pulled some fuel out to sample it but last couple checks show no water in it. Last week on start up it started blowing a lot of whiteish smoke and smells strongly of fuel, no coolant.
Ford tech said it sounded like injector pump, injectors had been replaced at 188k mi. and pump had been checked out ok previously to that but I suppose it's time to replace some parts.
I'm going to put a new fuel pump on just because, and have priced out a new injector pump and injectors at Diesel Care Inc. for about $375 + the cores.
Anyone have any other ideas on things to consider before going this route, am wondering if I possibly just have a bad injector or two. Air leak? Motor still ran fine and started reliably, it still starts fine but running like crap and blowing smoke.
Thanx in advance for any help-Jay

'04.5 F-350 Super Duty King Ranch-BulletProof Diesel EGR Delete/ Remote Oil Cooler w/ thermostat regulated return,By-Pass filter, BPD Scan Gauge II, DieselSite Coolant Filter,4" FlowMaster Exhaust/5" Downpipe, AEM HD Intake,Boost/Fuel PSI/EGT Gauges, Lund Fiberglass Running Boards,Fender Flares and Visor,Front end leveling kit, Toyo Open Country 275-70R-18's, ArchOil 9100 & 6200.
Atlas40 Tuned FICM.
MT KingRanch is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-18-2011, 04:13 AM Thread Starter
Junior Member
Threadstarter
 
MT KingRanch's Avatar
 
Join Date: Sep 2010
Posts: 51
Points: 23,332
Thanks: 20
Thanked 13 Times in 9 Posts
A wondering if their is any kind of filter sock on the fuel tank pickups on these older trucks that can get plugged off?
Changed out lift pump today and no change in running quality, still smoking alot and stuttering/ surging. Guess injectors will be next then injector pump.

'04.5 F-350 Super Duty King Ranch-BulletProof Diesel EGR Delete/ Remote Oil Cooler w/ thermostat regulated return,By-Pass filter, BPD Scan Gauge II, DieselSite Coolant Filter,4" FlowMaster Exhaust/5" Downpipe, AEM HD Intake,Boost/Fuel PSI/EGT Gauges, Lund Fiberglass Running Boards,Fender Flares and Visor,Front end leveling kit, Toyo Open Country 275-70R-18's, ArchOil 9100 & 6200.
Atlas40 Tuned FICM.
MT KingRanch is offline  
post #3 of 4 (permalink) Old 06-22-2011, 04:07 PM
Junior Member
 
Join Date: Nov 2009
Posts: 3,533
Points: 70,131
Thanks: 69
Thanked 655 Times in 578 Posts
I would be looking more towards checking the cylinders for lack of compression. Re move the glow plugs and with an adapter pressurize the cylinder looking for the problem, or do a compression test.
Or you could remove the exhaust manifolds and see if it is from all cylinders or just a couple.
Diagnosis by the ripping and tearing method is a very costly way to fix a problem.
You need information

1988 ford van fresh overhaul, 1991 nissan pick-up 1993 Caprice 2000 GMC S10 Blaser 2007 nbs 3500 GMC 4x4 crew-cab long box 17 inch single wheels Duramax Alison. BW turnover Ball. Furakawa FL35 loader. Retired, HD mechanic, worked on engines all my life. Fabricator welder. electrician. in the process of finishing my new shop. Live in Rock Creek B.C. Wife has a fruit stand.
Johnp3 is offline  
post #4 of 4 (permalink) Old 07-04-2011, 11:55 PM Thread Starter
Junior Member
Threadstarter
 
MT KingRanch's Avatar
 
Join Date: Sep 2010
Posts: 51
Points: 23,332
Thanks: 20
Thanked 13 Times in 9 Posts
Bought a $114 diesel comp. tester and did comp. test on cyls., all were from 330-375 psi. Diesel repair shop told me to look for 300-400 psi. Got any nore ideas? Reman injectors helped a little, motor starts and idles a lot better but can still feel a miss or stutter when driving down road. Less white smoke but still some on startup, smells like fuel, no coolant smell, not loosing coolant either. Am aware of electrolysis problem with right rear cylinder on these motors.
Waiting to talk to Ford dealer after 4th of July holiday before going ahead with anything else.
Can get a rebuilt injector pump from DieselCare Inc. for $325 + $125 core charge. Their reman Delphi Injectors seem to be fine at $16.84 ea.For now!

'04.5 F-350 Super Duty King Ranch-BulletProof Diesel EGR Delete/ Remote Oil Cooler w/ thermostat regulated return,By-Pass filter, BPD Scan Gauge II, DieselSite Coolant Filter,4" FlowMaster Exhaust/5" Downpipe, AEM HD Intake,Boost/Fuel PSI/EGT Gauges, Lund Fiberglass Running Boards,Fender Flares and Visor,Front end leveling kit, Toyo Open Country 275-70R-18's, ArchOil 9100 & 6200.
Atlas40 Tuned FICM.

Last edited by MT KingRanch; 07-04-2011 at 11:57 PM.
MT KingRanch is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
running rough when hot michael8840 1994-2003 7.3L Power Stroke 8 07-08-2010 04:40 AM
6.0 running rough 06Harley350 2003-2007 6.0L Power Stroke 20 09-30-2009 03:54 PM
rough running '02 tommy vestrat 1994-2003 7.3L Power Stroke 1 03-30-2008 03:13 AM
Rough running 7.3??? Help???? Snowaholic 1994-2003 7.3L Power Stroke 3 09-06-2006 04:55 AM
12 v running rough Whitemare 5.9L Cummins 12 Valve (1994-1998.5) 5 09-24-2005 03:10 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome