New injector pump and engine hardly wants to run - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by shaggy1, this thread has received 3 replies and been viewed 1599 times.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-22-2011, 10:15 AM Thread Starter
Junior Member
 
Join Date: Sep 2011
Posts: 3
Points: 451
Thanks: 0
Thanked 0 Times in 0 Posts
Angry New injector pump and engine hardly wants to run

Ok so about 3 weeks ago my 7.3 idi 2X4 auto just stopped running and would not start at all. I got a diesel mechanic to look at it and he said the IP was bad and so i took it to a reliable diesel shop locally to have them rebuild it. After the mechanic installed the rebuilt IP the truck was hard to start and ran about 5 min and died. Today i tried to start it and it started 2 times and it ran for 1 to 2 min tops each time and had white smoke out the exhaust. Any ideas on whats going on? Oh and the truck use to start first time no problems warm or cold prior to the truck dieing on me 3 weeks ago. Any help or suggestions i am thankful for.
shaggy1 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-23-2011, 12:40 AM
1abmechanic
 
Join Date: Feb 2009
Location: Bakersfield,Ca.
Posts: 5
Points: 1,178
Thanks: 0
Thanked 1 Time in 1 Post
White smoke is a usely unburned diesel fuel, But it could be coolant. Does it smell like fuel? If it does then I would check the glow plugs, Are they good?
Is the fuel filter getting fuel? If it is loosen a fuel line a one of the injectors, chank the engine and see if fuel is there. If all of the above check out the IP could be out of time. I don't know how to check that. Why isn't the mechanic who told you the IP was bad fixing it?
1ABMECHANIC is offline  
post #3 of 4 (permalink) Old 10-23-2011, 07:56 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Sep 2011
Posts: 3
Points: 451
Thanks: 0
Thanked 0 Times in 0 Posts
I have fuel to the filter and IP. The truck does not burn coolant, so im guessing it was unburnt fuel. I will get new glow plugs tomorrow from advanced auto parts bec from what they say they carry the oem mc plugs for the truck. I just don't understand why the glow plugs would all the sudden be such a problem now, but hey it wouldn't hurt to change them anyways. Thanks
shaggy1 is offline  
post #4 of 4 (permalink) Old 11-05-2011, 06:59 PM
03 f350 xl 7.3 2wd x-tend
 
powerstrokin350's Avatar
 
Join Date: Jan 2007
Location: Orangevale, California
Posts: 119
Points: 61,161
Thanks: 32
Thanked 5 Times in 5 Posts
Garage
Hey if it were glow plugs wouldn't the white smoke clear up once the truck is warmed up? Because they only help warm things up on cold starts, not once your up and running.

03 f350 7.3l x-tend cab 2wd
& 1993 F-350 7.3L CREW CAB 5SPEED

SINGLES#63
powerstrokin350 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I need an injector pump and a lift pump for a 98.5 24valve CRAZY ROB Whats Been Sold 7 07-02-2009 12:15 AM
Injector Pump and Lift Pump are toast. Now What? 6thFrame 5.9L Cummins (1998.5-2002) 21 05-19-2009 10:32 PM
injector pump DZL BULL 7.3L and 6.9 IDI (Pre 1994) 3 01-03-2009 05:54 PM
injector pump HELP!!!!!!!!PLEASE!!!!!!!! don53wood 6.5L Diesel Engine 3 01-25-2007 12:13 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome