my truck is hard to start - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by idi diesel driver, this thread has received 8 replies and been viewed 2495 times.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-02-2012, 04:52 PM Thread Starter
Junior Member
 
Join Date: Dec 2011
Location: woodbury tn
Posts: 3
Points: 14,480
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
my truck is hard to start

I have a 93 idi that is hard to start and i know that either is hard on them but it is the only way to start it. i have put three sets of injector o rings in it and still leaks. I dont know but maybe a leak some were. can some one please help me out thanks.
idi diesel driver is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-04-2012, 12:16 AM
Junior Member
 
Ky. horseman's Avatar
 
Join Date: Feb 2008
Posts: 69
Points: 22,212
Thanks: 1
Thanked 8 Times in 8 Posts
Garage
First off you gotta stop the leak,if you didn't do it,i'd replace orings caps and lines,you can get complete kits online around 30.00-40.00 bucks,thats where i would start,good luck.
Ky. horseman is offline  
The Following User Says Thank You to Ky. horseman For this addition to TDG:
idi diesel driver (01-04-2012)
post #3 of 9 (permalink) Old 01-04-2012, 01:37 PM Thread Starter
Junior Member
Threadstarter
 
Join Date: Dec 2011
Location: woodbury tn
Posts: 3
Points: 14,480
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
is there any secret to getting the o rings to seal i have used grease and done it dry and still leak.
idi diesel driver is offline  
post #4 of 9 (permalink) Old 01-04-2012, 08:41 PM
Junior Member
 
Ky. horseman's Avatar
 
Join Date: Feb 2008
Posts: 69
Points: 22,212
Thanks: 1
Thanked 8 Times in 8 Posts
Garage
I USE CLEAN DIESEL FUEL TO LUBE,DONT USE GREASE,JUST TAKE YOUR TIME,SHOULD BE NO PROBLEMS,GOOD LUCK.
Ky. horseman is offline  
post #5 of 9 (permalink) Old 01-12-2012, 03:11 PM
Junior Member
 
Join Date: Dec 2011
Location: alabama
Posts: 93
Points: 49,397
Thanks: 10
Thanked 6 Times in 6 Posts
Garage
The last one's I put in do sort of a double click on installation. Make sure the caps are seated all the way down. I used a silicon spray lube on the rings and spayed inside the caps prior to pressing them on. New fuel lines between them and make sure the fuel return line at the back of the engine to the tank is properly sealed.
courtem is offline  
post #6 of 9 (permalink) Old 09-01-2012, 07:32 PM
Junior Member
 
RollinCoal92's Avatar
 
Join Date: Aug 2012
Location: Williams Lake, BC, Canada
Posts: 10
Points: 657
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
another thing to try is emptying your fuel water separator, alot of times that is the culprit.

/ 1987 Ford F-250 / Single Cab / Long Box / 4x4 / 6.9L IDI Turbo /
Canadian Club Member # 63
RollinCoal92 is offline  
post #7 of 9 (permalink) Old 10-10-2012, 02:57 AM
Junior Member
 
Join Date: Dec 2010
Posts: 721
Points: 51,378
Thanks: 51
Thanked 140 Times in 115 Posts
Are you replacing the caps also or just the o-rings? Can you see your leak? If not you may have a fuel pump leaking back to the tank.

Last edited by lenzhotrod; 10-10-2012 at 02:59 AM.
lenzhotrod is offline  
post #8 of 9 (permalink) Old 10-18-2012, 08:07 PM
spanky63
 
Join Date: Oct 2012
Location: Pontiac, IL
Posts: 28
Points: 18,574
Thanks: 0
Thanked 1 Time in 1 Post
Mine was hard to start too.

I had to replace the glow plugs. I found after replacing the glow plugs and putting a new starter in my truck it starts as soon as I hit the key. If the starter is dragging at all it will not get the torq to turn the motor correctly. Pull the starter and have it tested at your local parts store. I didn't think it could be my starter but it was.
Spanky636569 is offline  
post #9 of 9 (permalink) Old 11-13-2012, 05:54 AM
03 f350 xl 7.3 2wd x-tend
 
powerstrokin350's Avatar
 
Join Date: Jan 2007
Location: Orangevale, California
Posts: 119
Points: 61,161
Thanks: 32
Thanked 5 Times in 5 Posts
Garage
I have the same problem only on cold starts in the morning. All my GP light the test light when I test them( after replacing 4) and I explained it to a friend of mine that used to wrench at a ford dealership here and he told me he had a '91 same deal and replaced his injection pump and now his fires right up. Told me those pumps are only rated for 150,000 miles or so. My truck has 362,000. I crank it for 5 sec and then wait 3 sec and crank it again. I don't want to burn up another starter. And when it finally fires… whoa, watch yer lungs

Good luck.

03 f350 7.3l x-tend cab 2wd
& 1993 F-350 7.3L CREW CAB 5SPEED

SINGLES#63

Last edited by powerstrokin350; 11-13-2012 at 06:00 AM.
powerstrokin350 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Start on 98 truck hhrecovery 5.9L Cummins (1998.5-2002) 4 11-17-2009 11:00 PM
truck hard to start need help please ldwzlaw 1994-2003 7.3L Power Stroke 8 10-04-2009 02:30 AM
Truck hard to start! ACC inc. 2003-2007 6.0L Power Stroke 6 11-28-2007 10:35 PM
04-17-13 Hard Start Or No Start - Gpcm Connector Service Kit Available - 6.0l Engine Squatch Ford Oasis requests 0 03-23-2007 12:55 PM
CRANK NO START, HARD START, RUNS ROUGH AT IDLE - 6.0L 2005 F, E-Series,and Excursion PSDPlayer 2003-2007 6.0L Power Stroke 0 10-08-2005 08:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome