Brakes - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Spanky636569, this thread has received 2 replies and been viewed 1080 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-10-2013, 10:39 PM Thread Starter
spanky63
 
Join Date: Oct 2012
Location: Pontiac, IL
Posts: 28
Points: 18,574
Thanks: 0
Thanked 1 Time in 1 Post
Brakes

I have a 1992 ford f-350 7.3 diesel single rear wheels and 2 wheel drive. I have changed the brake booster, the booster check valve, the master cylinder, the two rear wheel cylinders, both calipers, and both rear brake lines. I bled the brake system twice now the second time with a bleeder kit. Now I am having an issue where when you step on the brakes sometimes it feels like you are stepping on a brick and you have to push really hard to get the brakes to do anything. But other times it acts just fine. I found out from ford there is no proportioning valve on this truck does anyone know what might be happening later this month I need to pull a fifth wheel trailer and don't want my brakes having issues.
Spanky636569 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-16-2013, 09:48 PM
Junior Member
 
Ky. horseman's Avatar
 
Join Date: Feb 2008
Posts: 69
Points: 22,212
Thanks: 1
Thanked 8 Times in 8 Posts
Garage
Sounds like a vaccum problem,but I don't know why it doesn't do it all the time,maybe check for a leak in the vaccum hoses and check vaccum pump.Good luck

89 F250 HD 7.3L IDI E4OD TRANNY 4IN" EXHAUST WITH FLOWMASTER 40 SERIES PUMP TURNED UP 1 FLAT SOUP BOWL MOD HOMEMADE AIR INTAKE B&M SHIFTKIT,MANUAL TQ CONV LOCKUP MANUAL GP SWITCH BILLET GRILLE,DRIVING LIGHTS IN BUMPER LED CAB LIGHTS,20% TINTED WINDOWS GOOSENECK AND RECEIVER HITCHES
FUEL TANK VENT MOD
MOSTLY HAULIN HAY AND HORSES 24,000lb.GVW TRANNY COOLER WITH FAN
Ky. horseman is offline  
post #3 of 3 (permalink) Old 10-13-2013, 10:13 PM Thread Starter
spanky63
Threadstarter
 
Join Date: Oct 2012
Location: Pontiac, IL
Posts: 28
Points: 18,574
Thanks: 0
Thanked 1 Time in 1 Post
Thanks

It was a vacuum issue. The vacuum pump quit working properly. I replaced that and problem fixed.
Spanky636569 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
brakes fordsthebest 1994-2003 7.3L Power Stroke 4 01-11-2011 12:41 AM
Brakes. rocweiller 2003-2007 6.0L Power Stroke 14 11-29-2010 01:33 AM
No Brakes redbaronmx319 1994-2003 7.3L Power Stroke 7 03-20-2010 05:42 PM
Parking brakes for electric trailer brakes 04MT Towing and Hauling 8 03-14-2010 04:41 AM
brakes baracr475 2003-2007 6.0L Power Stroke 5 09-28-2006 05:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome