An e4od problem... - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by loprofyle, this thread has received 4 replies and been viewed 2507 times.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-16-2010, 09:53 PM Thread Starter
Junior Member
 
Join Date: Nov 2010
Posts: 5
Points: 478
Thanks: 0
Thanked 0 Times in 0 Posts
An e4od problem...

Basically the "problem" is my stupidity I guess.....

Here is what happened:

(this was all done with transmission in the truck, working underneath)

The solenoid pack went out on my transmission and I bought a new pack.
While removing the solenoid pack I damaged the gasket under it so it had to be replaced.

I removed the solenoid pack, the 2 valve bodies and the sheet metal separator plate.

There is a gasket on each side of the steel plate and the "top" gasket stayed in place holding in most check balls (that I assume are in there).

When dropping the steel plate there were 3 check balls on it, 2 nylon & 1 steel ball.

I installed the new gasket and bolted everything back together and all was good........

Till clean-up.

I find a small blue spring under the truck during clean-up and have no idea where it fell out of.

I am hoping/guessing it goes above one of the check balls but not sure which one. (I would guess the steel one?)

Does anyone know where the spring may have came from?

The truck drove fine if you put it in drive and shifted through all gears properly but if you put it in low gear manually it would just....well I am not sure what it was doing to be honest.
It felt like it was trying to go forward and reverse at the same time but went nowhere.

Now the truck seems to start out in 2nd gear once it warms up.
The first 2-3 miles it starts in first and operates normally but after 3 miles or so it feels like it's starting in 2nd gear and then shifts normally after that.

If I can't fix this then the truck is getting sold as is but I would like to fix it and get more money out of it (going towards a diesel truck).

Any Idea's??

The spring is about 1/8" in diameter and 3/4" long if that helps at all.

Last edited by loprofyle; 11-16-2010 at 09:55 PM. Reason: added info
loprofyle is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-18-2010, 01:39 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2010
Posts: 5
Points: 478
Thanks: 0
Thanked 0 Times in 0 Posts
Ok..

I guess nobody knows anything that would help me, I appreciate everyone reading the question though.

I stumbled across Racer X's e4od rebuild post on here and thought he may be able to help as he seems to know the tranny inside and out.

It was worth a try.

Thanks anyways.

I'll check back daily to see if anyone knows anything.
loprofyle is offline  
post #3 of 5 (permalink) Old 11-20-2010, 12:53 AM
Senior Member
 
trackspeeder's Avatar
 
Join Date: Nov 2005
Location: North Branford CT
Posts: 279
Points: 20,827
Thanks: 15
Thanked 18 Times in 18 Posts
Sounds like you forgot the EPC blow off spring. It sits under a little steel ball. It's home is behind the servo.

01 F250 4X4, 7.3.
90 F350 4X4, 7.3
85 F250 4X2 6.9
08 Arctic Cat 700 4X4, Diesel

Easy button for photos
trackspeeder is offline  
post #4 of 5 (permalink) Old 11-20-2010, 02:55 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2010
Posts: 5
Points: 478
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks

Thanks for the info Track speeder.

Although I am not that knowledgeable about the transmission and am not sure what your talking about.

Are you talking about the steel check ball that came down with the steel separator plate? When I dropped the steel plate there was a steel check ball and 2 nylon balls..... You think it goes above the steel ball or are you talking about another spot?
loprofyle is offline  
post #5 of 5 (permalink) Old 11-20-2010, 03:06 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Nov 2010
Posts: 5
Points: 478
Thanks: 0
Thanked 0 Times in 0 Posts
Track speeder.....

I found a large blown apart schematic of the E4od and found the parts you mentioned and it is where I thought. The schematic shows the spring above the steel check ball so it confirmed that is where I thought it probably went.

Thanks VERY much for your help and soon as I get some time I will pull it back apart and replace the spring. Thank you again.
loprofyle is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
89 f350 e4od problem morsemotorsports 7.3L and 6.9 IDI (Pre 1994) 4 08-23-2009 02:03 PM
E4od! IDImonsterstack 7.3L and 6.9 IDI (Pre 1994) 2 04-03-2008 08:54 PM
e4od KENE4OD Whats Been Sold 8 05-16-2007 07:18 AM
E4od Monsterbox Problem mullins989 1994-2003 7.3L Power Stroke 0 12-09-2006 04:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome