Possible brake problems??... - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by HawaiianSuperDuty, this thread has received 6 replies and been viewed 621 times.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-30-2008, 07:59 PM Thread Starter
Member
 
Join Date: Apr 2006
Posts: 84
Points: 2,988
Thanks: 0
Thanked 0 Times in 0 Posts
Possible brake problems??...

Ok, so last night I'm turning into my driveway applying the brakes when I hear a weird rubbing/grinding sound. It doesn't make the sound when I'm going straight, just when turning and applying the brakes. As I straighten out and come to a stop holding down the brake pedal I hear like a groaning sound...?? Any ideas as to what could be the problem? Brake pads were just changed about a month ago so it cant be that.

About a week or so ago I noticed that I'm leaking power steering fluid, have not pinpointed where it's coming from yet. Not a major leak but I noticed some fluid on my coil springs and the 4-link bars and found the fluid level very low. Any help would be appreciated.

Thank you
Ikaika

Black 2005 F350 CC Fx4 Lariat 6.0 Torqshift, Fabtech 8" 4link lift, 37x12.50 20 Toyo Open Country on 20x12 Black Fuel Hostage, Quad 120, X-monitor, Muffler delete, Acetoned badges, Permatech liner
HawaiianSuperDuty is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-30-2008, 09:50 PM
Senior Member
 
Join Date: Jul 2007
Posts: 461
Points: 7,196
Thanks: 2
Thanked 1 Time in 1 Post
did you check your fluid after it made that noise?

2002 Arizona Beige F250 Ext Cab Short Bed. 7.3L 6spd 4x4 140k
2" leveling kit, 285/75 Mastercraft AT2's,Napa BFF, DiPricol Pryo/Boost, DP F5 NS/stock/hi/40/80/120/140agg-lope, Toolbox, Audio goodies, IH shiftknob
muffler delete, CCV reroute, AIH/Foil delete,
paulkeith is offline  
post #3 of 7 (permalink) Old 01-30-2008, 10:26 PM
TDG MAFIA #101
 
tm0231009's Avatar
 
Join Date: Dec 2007
Posts: 390
Points: 34,898
Thanks: 28
Thanked 5 Times in 5 Posts
Could that have something to do with u-joints going bad?

On the hunt for a 7.3 preferably CC or Ext. Cab SB...Let me know of any deals.


1979 Ford F-100 Ranger, Custom dark purple and silver paint, 15"x8"117 Series Eagle Alloy's, Winston tires, 400 cu - Work In Progress!! http://www.cardomain.com/ride/2570291

"The only dumb question is the one not asked."


TDG MAFIA MEMBER #101
TDG SINGLES CLUB MEMBER #88
tm0231009 is offline  
post #4 of 7 (permalink) Old 01-30-2008, 10:30 PM Thread Starter
Member
Threadstarter
 
Join Date: Apr 2006
Posts: 84
Points: 2,988
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by paulkeith
did you check your fluid after it made that noise?

Yeah I checked it this morning and it was a little low. I'll see if it makes the sound again and go from there. I guess I need to take the battery and battery holder off tomorrow so I can try to find where the leak is. I hope its just a hose!

Ikaika

Black 2005 F350 CC Fx4 Lariat 6.0 Torqshift, Fabtech 8" 4link lift, 37x12.50 20 Toyo Open Country on 20x12 Black Fuel Hostage, Quad 120, X-monitor, Muffler delete, Acetoned badges, Permatech liner
HawaiianSuperDuty is offline  
post #5 of 7 (permalink) Old 01-30-2008, 10:31 PM Thread Starter
Member
Threadstarter
 
Join Date: Apr 2006
Posts: 84
Points: 2,988
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by tm0231009
Could that have something to do with u-joints going bad?

Not sure, I hope not because all I got is 19k on the odo.

Ikaika

Black 2005 F350 CC Fx4 Lariat 6.0 Torqshift, Fabtech 8" 4link lift, 37x12.50 20 Toyo Open Country on 20x12 Black Fuel Hostage, Quad 120, X-monitor, Muffler delete, Acetoned badges, Permatech liner
HawaiianSuperDuty is offline  
post #6 of 7 (permalink) Old 01-31-2008, 05:11 AM
Senior Member
 
StrokerDude's Avatar
 
Join Date: Nov 2006
Location: State of Jefferson (FarNorCal)
Posts: 2,106
Points: 35,450
Thanks: 63
Thanked 99 Times in 88 Posts
Garage
I had a power steering leak that was hard to trace, turned out to be my hydroboost... Just thought I'd throw that out there for ya just in case it might prove useful info. In mine the fluid leaked down off of it, got on my tire, and got all over the side of the truck.

Alex C.

R.I.P. 2006 F-250 CC SB Fx4. w/ 500 RWHP *stolen 7/15/2010*

1990 F350 CCLB 4x4 -- 24V Cummins, 200hp DDP's, SuperB over S475-sx3, Cam and valvesprings, Spe-rite Convertor, Billet input.

www.JeffersonStateDiesel.com --- http://en.wikipedia.org/wiki/State_of_Jefferson

Singles Club # 182 - B.O.M.B Squad # 14 - American Club #23
StrokerDude is offline  
post #7 of 7 (permalink) Old 01-31-2008, 05:45 PM
Senior Member
 
Join Date: Jul 2007
Posts: 461
Points: 7,196
Thanks: 2
Thanked 1 Time in 1 Post
Quote:
Originally Posted by paulkeith
did you check your fluid after it made that noise?

????

2002 Arizona Beige F250 Ext Cab Short Bed. 7.3L 6spd 4x4 140k
2" leveling kit, 285/75 Mastercraft AT2's,Napa BFF, DiPricol Pryo/Boost, DP F5 NS/stock/hi/40/80/120/140agg-lope, Toolbox, Audio goodies, IH shiftknob
muffler delete, CCV reroute, AIH/Foil delete,
paulkeith is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome