'Door Ajar' lamp staying on w/ door closed??? - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by BlownGreenGP, this thread has received 4 replies and been viewed 1630 times.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-02-2008, 09:34 PM Thread Starter
Member
 
BlownGreenGP's Avatar
 
Join Date: Dec 2008
Location: Farmington Hills, MI
Posts: 102
Points: 4,226
Thanks: 1
Thanked 1 Time in 1 Post
'Door Ajar' lamp staying on w/ door closed???

Every once in awhile when I shut my door the 'Door Ajar' lamp stays on w/ the dome light. For now I pulled the dome light relay so it doesn't stay on while driving or if I park the truck over night. But, the 'Door Ajar' lamp is still on from time to time.

Is this a common issue w/ a common repair, like the door switch failing, or something I need to look into myself?

SOLD2004 Dodge 3500-Quadzilla XZ2, 6" Black Mitre Stacks, PPE, DTT Trans

SOLD Early '99 F-250 XLT, 4x4, 6-speed
Diesel Innovations chip: stock, 50, 75, 110hp, 4" lift, Eagle 140 Black 18x10's w/ 35x12.5 Nitto Mud Grapplers, 4" turbo back to dual 5" Aussie stacks

SOLD2000 Grand Prix GTP Sedan
12.83 @ 108.68 mph on street tires
BlownGreenGP is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-02-2008, 10:14 PM
mvwheeler02
 
mvwheeler02's Avatar
 
Join Date: Feb 2006
Location: East Peoria, IL
Posts: 30
Points: 3,875
Thanks: 0
Thanked 0 Times in 0 Posts
i have an 02 f250 and it does the same thing somone said to spray the crap outta the latches with wd40 and it will fix it but i havent tried cause its like 3 degrees outside haha, but your dome light should go off when u drive and hit 2000 rpm or it shifts! hope u find your problem!!

03 EDDIE BAUER EXCURSION, 6.0
9" lift, 36x15.5 mickey mtz's with 18" motos, complete egr delete, sct xcal2, suncoast tranny rebuild, costom f.a.g.g.o.t.s. pump, 5" exhaust, two 12" eclipse subs with a 1000 watt kenwood.


YOU'RE IN AMERICA-SPEAK ENGLISH!

singles club #119
mvwheeler02 is offline  
post #3 of 5 (permalink) Old 02-02-2008, 10:50 PM
 
Join Date: Dec 2005
Posts: 1,410
Points: 2,131
Thanks: 0
Thanked 0 Times in 0 Posts
I've had it happen before on my 01 (PITA since my AMP step stays down) and yes, spraying the latch with WD-40 worked to get it to operate properly again.
DCSpecial is offline  
post #4 of 5 (permalink) Old 02-03-2008, 01:46 AM
Senior Member
 
brendonv's Avatar
 
Join Date: Dec 2008
Location: Seymour, Connecticut
Posts: 442
Points: 37,655
Thanks: 3
Thanked 23 Times in 22 Posts
Did it on my 99. Took the advice from these guys and sprayed wd40 in the latch and havent had the problem since.

Early 1999 F350 DRW Dump, 6spd 4x4, 4" Turbo Back and DIY Intake

Early 1999 F350 SRW 8' Box, 6spd 4x4 Stock
brendonv is offline  
post #5 of 5 (permalink) Old 02-03-2008, 05:22 AM Thread Starter
Member
Threadstarter
 
BlownGreenGP's Avatar
 
Join Date: Dec 2008
Location: Farmington Hills, MI
Posts: 102
Points: 4,226
Thanks: 1
Thanked 1 Time in 1 Post
Thanks guy's

SOLD2004 Dodge 3500-Quadzilla XZ2, 6" Black Mitre Stacks, PPE, DTT Trans

SOLD Early '99 F-250 XLT, 4x4, 6-speed
Diesel Innovations chip: stock, 50, 75, 110hp, 4" lift, Eagle 140 Black 18x10's w/ 35x12.5 Nitto Mud Grapplers, 4" turbo back to dual 5" Aussie stacks

SOLD2000 Grand Prix GTP Sedan
12.83 @ 108.68 mph on street tires
BlownGreenGP is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome