My A/C Sucks... - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Stinger23, this thread has received 7 replies and been viewed 779 times.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-27-2009, 06:57 AM Thread Starter
Turbo Freak
 
Stinger23's Avatar
 
Join Date: Dec 2007
Location: Shawnee, Kansas
Posts: 95
Points: 15,047
Thanks: 0
Thanked 1 Time in 1 Post
My A/C Sucks...

My A/C developed a leak last year. I just ignored it as it was the end of the summer. This spring I vac'd the system and recharged it and put in some stop leak hoping it would seal the small leak. The charge only lasted 2 days before the compressor was kicking off from low charge.

Problem 1: Charged it again and this time there was also red dye in the refrigerant but I could not find anywhere that indicated there was a leak. I looked at all of the oring connections, all over the condensor, compressor, etc. and couldn't find any dye. After 3 charges the leak is small enough that it now takes a week or so before it needs 6-8 oz's to top it off. I still don't know where the leak is, is there a common source of leaks on these trucks?

Problem 2: The A/C only blows 20-24 degrees below outside temp which is ok when it's 80 degrees out and the a/c blows 60 but when it's 100 outside and the a/c is blowing 80 it doesn't get close to cooling the cab down. What would make it not blow out 50-55 degrees when fully charged?

'00 PowerStroke 7.3 6-Speed CrewCab Short Bed 2WD--Purchased December '07--
Mods : 18x9 Moto Metal 958's w/265-65 Nitto's Terra Grapplers, Boost & Pyro Gauges, 7-Position DP-Tuner, DIY Intake, 4" Magnaflow Exhaust, South Bend Clutch, Sony 12" Sub/Enclosure, Kicker 750w Amp, '02 Headlights, Billet Grill,Tow Mirrors,
Coming Soon:Boost Controller, Leveling Kit, Tint
Stinger23 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-27-2009, 12:56 PM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,864
Thanks: 1,507
Thanked 990 Times in 755 Posts
Need to read the pressures to get an accurate diag. But likely a restriction in the system will cause your symptom. Average pressure in an a/c system vary's depending on outside ambient temps. But on an average it should be 30-40psi on the low pressure side and 150-225 on the high pressure side. A restriction will cause low flow of the freon gas. Anything from a clogged orfice tube to too much oil in the system can cause this. Also if your compressor is weak or not producing much pressure on none at all will cause your symptom. I have also seen a leak cause the system to seem like it has pressure but is full of air, will read pressure but when you recover the freon it only has hardly any in it. Floueresant dye with a uv flashlight is usually the best way to detect where a leak is located. But for non visible locations an electronic hand held leak detector is needed. If you can't locate any leak in the engine compartment or condenser in front of the radiator(a good place to look, as rocks etc can cause small holes), then it maybe inside the truck from the evaporator, but that is the most unlikely, but does happen on occasion. Good luck, Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
post #3 of 8 (permalink) Old 08-27-2009, 01:12 PM
Senior Member
 
bushpilot's Avatar
 
Join Date: Aug 2005
Location: Tomball
Posts: 5,365
Points: 19,266
Thanks: 312
Thanked 717 Times in 530 Posts
obviously youve got a leak...you need a freon sniffer to find it if you saw no red dye.
the leak could be just about anywhere, including in the cab / behind the dash around
the evaporator core...you may also have taken a rock in the condenser

take it to an A/C shop and let 'em find the leak w/ a sniffer.

Don R.

'04 350 4WD Lariat Crew Longbed (built 05.04)
-------------------

-------------------

Gear Vendors Dbl Overdrive Install w/ Pics.
135 Amp Alternator Upgrade/Replacement
50 Gal. Aux Tank; Pump, Filter, Wiring
Truck Audio,
CUSTOM Valentine One Install - LINK
$10 Grill Mod. (protects the coolers) !

Block Heater Cord (Rear Mounted w/ Timer) - LINK

REALTIME -CURRENT DIESEL Pricing <HERE>
bushpilot is offline  
post #4 of 8 (permalink) Old 08-27-2009, 05:11 PM Thread Starter
Turbo Freak
Threadstarter
 
Stinger23's Avatar
 
Join Date: Dec 2007
Location: Shawnee, Kansas
Posts: 95
Points: 15,047
Thanks: 0
Thanked 1 Time in 1 Post
I can read the pressures again (I did it earlier this year but forget what they were now). I've got the gauges to do so.

I just bought a leak detector so I'll try that as well and report back...

'00 PowerStroke 7.3 6-Speed CrewCab Short Bed 2WD--Purchased December '07--
Mods : 18x9 Moto Metal 958's w/265-65 Nitto's Terra Grapplers, Boost & Pyro Gauges, 7-Position DP-Tuner, DIY Intake, 4" Magnaflow Exhaust, South Bend Clutch, Sony 12" Sub/Enclosure, Kicker 750w Amp, '02 Headlights, Billet Grill,Tow Mirrors,
Coming Soon:Boost Controller, Leveling Kit, Tint
Stinger23 is offline  
post #5 of 8 (permalink) Old 08-27-2009, 11:58 PM
********* and Mafia #90
 
Bcarriveau's Avatar
 
Join Date: Jul 2007
Location: New Berlin, WI
Posts: 14,261
Points: 92,614
Thanks: 943
Thanked 1,333 Times in 985 Posts
Garage
Send a message via AIM to Bcarriveau Send a message via Yahoo to Bcarriveau
Well theres your problem.


JK, looking forward to see what you find




Bill Carriveau OFFICIAL POO HAULER

ARP studs, sct, Leveling kit,Airdog set at 62psi with no factory pump, leveling kit,5" stacks, under cab lights, Large in the way Fan shroud Removed, bed Lights being Re-did. Large Alternator(250amps)(130 amps was so 2003). On 3rd set of Hgs(soon to be 4th), 2nd set of heads, 2nd tubro, egr cooler, FICM and more. When i Turn the Key it does return a Favor, not always in MY Favor.
Da Rules..Here
http://i449.photobucket.com/albums/q...g?t=1249694332
Windows 7 Takes the WIN!
Windows 8 might take that Win
http://www.bcarriveau.com/
Dear Tequila:
We had a deal. You were supposed to make me sexier, smarter and a better dancer. But I saw the video. And I think we need to talk..


How you name your Thread is Important. Read Here

The TDG TOTQ


Bcarriveau is offline  
post #6 of 8 (permalink) Old 08-31-2009, 08:51 PM Thread Starter
Turbo Freak
Threadstarter
 
Stinger23's Avatar
 
Join Date: Dec 2007
Location: Shawnee, Kansas
Posts: 95
Points: 15,047
Thanks: 0
Thanked 1 Time in 1 Post
OK, I fired up the truck and filled it until the compressor quit shutting off. It was still low but I didn't want to waste any more refrigerant. If I need to fill it more to diagnose it, I will.

Outside Air Temp: 70 degrees
Engine off: 85psi on hi and low sides
Engine on high idle: 175psi hi side, 24psi low side.

Does this say anything about what the problem is or do I need to get it to 30psi on the low side then test again?

'00 PowerStroke 7.3 6-Speed CrewCab Short Bed 2WD--Purchased December '07--
Mods : 18x9 Moto Metal 958's w/265-65 Nitto's Terra Grapplers, Boost & Pyro Gauges, 7-Position DP-Tuner, DIY Intake, 4" Magnaflow Exhaust, South Bend Clutch, Sony 12" Sub/Enclosure, Kicker 750w Amp, '02 Headlights, Billet Grill,Tow Mirrors,
Coming Soon:Boost Controller, Leveling Kit, Tint
Stinger23 is offline  
post #7 of 8 (permalink) Old 08-31-2009, 09:27 PM
I can count to Potatoe
 
Join Date: Dec 2008
Posts: 595
Points: 33,623
Thanks: 4
Thanked 99 Times in 51 Posts
You have a leak somewhere.

The fact that with engine off you have 85 psi on both sides mean there is no restirction, and at high idle your values are fine.

Alo AC is only supposed to drop the temperature 30 degrees, anything more than that is just gravy.

So if its 100 out its only going to blow 70. Yeah it sucks, but roll down your window and see that your AC is doing a good job.

Just take your AC sniffer and see what you can find. If your lucky its the condenser and not something under the dash.
dayusex is offline  
post #8 of 8 (permalink) Old 09-01-2009, 01:21 PM
Senior Member
 
harry6.0's Avatar
 
Join Date: Dec 2008
Location: Spokane WA. area
Posts: 3,051
Points: 142,864
Thanks: 1,507
Thanked 990 Times in 755 Posts
Quote:
Originally Posted by Stinger23 View Post
OK, I fired up the truck and filled it until the compressor quit shutting off. It was still low but I didn't want to waste any more refrigerant. If I need to fill it more to diagnose it, I will.

Outside Air Temp: 70 degrees
Engine off: 85psi on hi and low sides
Engine on high idle: 175psi hi side, 24psi low side.

Does this say anything about what the problem is or do I need to get it to 30psi on the low side then test again?
Since your still a bit low on the freon fill level, your pressures will read lower all around. But 24 psi on the low side is not to far off at all, unless when you raise the rpm up higher the it starts dropping real low or into a negative/vacuum reading. It definitely is a leak somewhere. Freon leaks can be tricky to find. Invest in a small uv flashlight and a can of uv dye freon and you can usually find the smallest leaks that are undetectable by most other methods. Harry

Jan 03' built 6.0/F250cc4wd trqsft/SCT-tuned by KEM-Performance/Garrett Powermax vg-turbo/blue spring mod/gauges=egt+boost+fuel+SG2/exhaust/airaid intake/DR 4.5 lift/dual bilsteins/315's/greasable ball joints/powerstop/smittybuilt/kc lights/high idle mod/roll-n-lock/Mobil Delvac1 ESP 5W40 with (Archoil AR9100 in the oil) and (AR6200 in the fuel)
harry6.0 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ups sucks!!! R33615 The Parking Lot 19 05-20-2009 02:00 AM
man this sucks newtodiesel The Parking Lot 6 01-07-2009 01:12 AM
Well this sucks.. blackcloudCTD95 The Parking Lot 9 01-18-2008 04:28 AM
This sucks mattsn 2003-2007 6.0L Power Stroke 13 09-19-2007 12:54 AM
It sucks when you have Kat The Parking Lot 1 04-17-2006 11:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome