&%@#! Electrical again - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by budtoh3zo, this thread has received 8 replies and been viewed 838 times.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-03-2009, 12:59 AM Thread Starter
Senior Member
 
Join Date: Dec 2008
Location: Little Smoky
Posts: 1,415
Points: 38,282
Thanks: 42
Thanked 105 Times in 104 Posts
&%@#! Electrical again

so after i had both high beams burn out at once, now all my signal lights burnt out at once wtf is going on? The signal lights on the mirror still work so im assuming that its on the same circut as the rest? also bc of this have no brake lights of course except for the 3rd brake light. any ideas?

2008 F-350 Lariet 6.4L 170,000 km spartan tuned 275 daily
2006 yamaha Vmax
2003 F-350 XLT 6.0L just bought 215,000 km all stock for now.
2003 suzuki 1000 GSX-R
1993 F-250 460
1978 F-150 stock waiting for a paint job

Near GP alberta.

CC#58
budtoh3zo is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 12-03-2009, 01:31 AM
Senior Member
 
4play's Avatar
 
Join Date: Dec 2008
Location: norman, ok
Posts: 1,700
Points: 41,545
Thanks: 55
Thanked 387 Times in 342 Posts
Is this on the 03 in your sig? Sounds like your multi-function switch ( turn signal switch ) everything you mentioned that has gone out goes through this switch. Sometimes you can mess with the emergency flasher switch pushing it on/off to get things to work again. I have seen quite a few of these switches fail so i am just making a guess.

My motto: Be nice, be polite, but have have a plan to kill everyone that you meet.

94 F250 IDI turbo, auto 2wd.. ATS housing, 3" down, 4" exh, guages. 104k miles got totalled by a damn mustang (parts now).

98 12v, 4x4 quad cab. auto with BD T/C & V/B, Banks Big head, Exh brake, AFC modded, 16.5ish*, KDP gone, 60lb springs, 4K-GSK, BHAF, pyro, trans, and boost guages. 4" straight pipe,

72 AM General M35A2, LDT465-1C "Whistler" Turbo, PTO winch.
4play is offline  
post #3 of 9 (permalink) Old 12-03-2009, 01:52 AM Thread Starter
Senior Member
Threadstarter
 
Join Date: Dec 2008
Location: Little Smoky
Posts: 1,415
Points: 38,282
Thanks: 42
Thanked 105 Times in 104 Posts
no its my 08. with the emergancy flashers only the mirrors flash still. im sure all the bulbs are burnt havent took them out yet. need to get to a parts store and get some new bulbs.

2008 F-350 Lariet 6.4L 170,000 km spartan tuned 275 daily
2006 yamaha Vmax
2003 F-350 XLT 6.0L just bought 215,000 km all stock for now.
2003 suzuki 1000 GSX-R
1993 F-250 460
1978 F-150 stock waiting for a paint job

Near GP alberta.

CC#58
budtoh3zo is offline  
post #4 of 9 (permalink) Old 12-03-2009, 02:44 AM
Senior Member
 
4play's Avatar
 
Join Date: Dec 2008
Location: norman, ok
Posts: 1,700
Points: 41,545
Thanks: 55
Thanked 387 Times in 342 Posts
have you checked fuses? Still the only two things in common is the turn-signal switch and smart junction box. does the flash to pass function work? if you tilt the wheel up or down does anything start working?

My motto: Be nice, be polite, but have have a plan to kill everyone that you meet.

94 F250 IDI turbo, auto 2wd.. ATS housing, 3" down, 4" exh, guages. 104k miles got totalled by a damn mustang (parts now).

98 12v, 4x4 quad cab. auto with BD T/C & V/B, Banks Big head, Exh brake, AFC modded, 16.5ish*, KDP gone, 60lb springs, 4K-GSK, BHAF, pyro, trans, and boost guages. 4" straight pipe,

72 AM General M35A2, LDT465-1C "Whistler" Turbo, PTO winch.
4play is offline  
post #5 of 9 (permalink) Old 12-03-2009, 11:40 PM
R.I.P. DAD
 
SEABEE08FX4's Avatar
 
Join Date: Dec 2008
Location: Montgomery, Texas
Posts: 3,800
Points: 44,555
Thanks: 368
Thanked 289 Times in 205 Posts
Take it in to the dealer for warranty work, sounds like a short though. Possibly condensation in your harness also.

R.I.P. TMCS (SS) Brooks R Newell, I will forever miss you.

OneBigAssMistakeAmerica

2008 F-250 FX4



NMCB-28, KICKIN BUTT SINCE 1942

American club member #40
FOSP Club # 1
My sense of humor is an acquired taste, if you dont like it....... ACQUIRE some taste.
SEABEE08FX4 is offline  
post #6 of 9 (permalink) Old 12-04-2009, 01:25 AM Thread Starter
Senior Member
Threadstarter
 
Join Date: Dec 2008
Location: Little Smoky
Posts: 1,415
Points: 38,282
Thanks: 42
Thanked 105 Times in 104 Posts
warrenty has been over for a long time. got them working again all bulbs were burnt replaced them, then the fuse popped replaced it and all is good. not sure what caused it. goes to the dealer on thursday to see if they can find anything.

2008 F-350 Lariet 6.4L 170,000 km spartan tuned 275 daily
2006 yamaha Vmax
2003 F-350 XLT 6.0L just bought 215,000 km all stock for now.
2003 suzuki 1000 GSX-R
1993 F-250 460
1978 F-150 stock waiting for a paint job

Near GP alberta.

CC#58
budtoh3zo is offline  
post #7 of 9 (permalink) Old 12-04-2009, 04:17 AM
Senior Member
 
4play's Avatar
 
Join Date: Dec 2008
Location: norman, ok
Posts: 1,700
Points: 41,545
Thanks: 55
Thanked 387 Times in 342 Posts
Its a stretch here but once I had a vehicle brought to me that was blowing bulbs and fuses randomly. What I found was a bad alternator. It was going to full field and running voltages up past 18v. Things like light bulbs and fuses can be the first things to go.

My motto: Be nice, be polite, but have have a plan to kill everyone that you meet.

94 F250 IDI turbo, auto 2wd.. ATS housing, 3" down, 4" exh, guages. 104k miles got totalled by a damn mustang (parts now).

98 12v, 4x4 quad cab. auto with BD T/C & V/B, Banks Big head, Exh brake, AFC modded, 16.5ish*, KDP gone, 60lb springs, 4K-GSK, BHAF, pyro, trans, and boost guages. 4" straight pipe,

72 AM General M35A2, LDT465-1C "Whistler" Turbo, PTO winch.
4play is offline  
The Following User Says Thank You to 4play For this addition to TDG:
budtoh3zo (12-04-2009)
post #8 of 9 (permalink) Old 12-04-2009, 04:26 PM Thread Starter
Senior Member
Threadstarter
 
Join Date: Dec 2008
Location: Little Smoky
Posts: 1,415
Points: 38,282
Thanks: 42
Thanked 105 Times in 104 Posts
thanks I thought about that and been monitoring it highest I see is 14.7 volts. should be good where. I got it narrowed down to passenger rear light or command start

2008 F-350 Lariet 6.4L 170,000 km spartan tuned 275 daily
2006 yamaha Vmax
2003 F-350 XLT 6.0L just bought 215,000 km all stock for now.
2003 suzuki 1000 GSX-R
1993 F-250 460
1978 F-150 stock waiting for a paint job

Near GP alberta.

CC#58
budtoh3zo is offline  
post #9 of 9 (permalink) Old 12-05-2009, 01:32 AM Thread Starter
Senior Member
Threadstarter
 
Join Date: Dec 2008
Location: Little Smoky
Posts: 1,415
Points: 38,282
Thanks: 42
Thanked 105 Times in 104 Posts
Well i think i got it fixed there was a connector that was hanging and seemed to be getting water in it. so i turned it on its side and all has been fine so far.

2008 F-350 Lariet 6.4L 170,000 km spartan tuned 275 daily
2006 yamaha Vmax
2003 F-350 XLT 6.0L just bought 215,000 km all stock for now.
2003 suzuki 1000 GSX-R
1993 F-250 460
1978 F-150 stock waiting for a paint job

Near GP alberta.

CC#58
budtoh3zo is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need electrical help bechapman1979 5.9L Cummins (2003-2007.5) 1 07-19-2009 11:55 AM
electrical help SSpeeDEMONSS The Parking Lot 17 05-21-2009 04:15 AM
electrical help SSpeeDEMONSS The Parking Lot 5 12-31-2008 05:29 PM
Electrical help hopeful 6.0 General Ford Truck and Excursion 3 02-02-2007 02:58 AM
Need some electrical help here please oldskool 5.9L Cummins (Pre 1994) 8 07-27-2006 05:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome