Engine runs well but!!! - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by dzljon, this thread has received 2 replies and been viewed 994 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-11-2011, 04:30 PM Thread Starter
Senior Member
 
dzljon's Avatar
 
Join Date: Dec 2006
Posts: 622
Points: 52,682
Thanks: 40
Thanked 60 Times in 47 Posts
Garage
Engine runs well but!!!

The cummins has ALOT of power it is running top notch but here are vitals that jump out at me, from a dead stop with normal throttle to accelerate 1/4-1/2 egts are 650-750, boost 19-22 psi(seems high) and it moves almost to good and there is 0 smoke out the tail pipe but the down side is it seems like it is using more fuel than it should, if you guys can share what you are seeing that would help out.... Happy Veterans day

and just to be clear this is the stock charger, stock injector, and i only have a quadzilla max mileage module, i will install a vgt off a 2009 using fleeces controller after my broken ribs heal

99.5 F250, VGT 5.9 CR cummins

Last edited by dzljon; 11-11-2011 at 04:32 PM.
dzljon is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-16-2011, 04:35 PM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,834
Points: 56,495
Thanks: 302
Thanked 691 Times in 599 Posts
Garage
Tune it back to stock and see what happens. Could be the tuning.

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air
Optima Redtop 34Rs


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2016 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #3 of 3 (permalink) Old 11-24-2011, 12:10 PM Thread Starter
Senior Member
Threadstarter
 
dzljon's Avatar
 
Join Date: Dec 2006
Posts: 622
Points: 52,682
Thanks: 40
Thanked 60 Times in 47 Posts
Garage
update, found fuel a seep on the fuel filter delete part from glacier diesel, i think it just needs a new seal.

99.5 F250, VGT 5.9 CR cummins
dzljon is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine runs rough when a/c on in gear bigblue777 2003-2007 6.0L Power Stroke 3 11-12-2009 03:28 AM
Check engine light, runs bad, turn key off then on, runs fine? Stevie Mac 1994-2003 7.3L Power Stroke 10 09-21-2009 01:50 AM
engine runs then stalls sgowan 1994-2003 7.3L Power Stroke 1 07-02-2007 03:56 PM
weird trouble codes, engine runs rough Powersmoker113 1994-2003 7.3L Power Stroke 0 05-25-2007 01:04 AM
04-9-3 Driveability - Runs Rough And/or Low Power - 6.0l Diesel Engine Only Squatch Ford Oasis requests 0 03-23-2007 12:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome