This is odd - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by dzljon, this thread has received 9 replies and been viewed 2584 times.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-08-2012, 12:57 AM Thread Starter
Senior Member
 
dzljon's Avatar
 
Join Date: Dec 2006
Posts: 622
Points: 52,679
Thanks: 40
Thanked 60 Times in 47 Posts
Garage
This is odd

today i had the valve cover off to inspect a few things put it back on and the engine, started and leaked checked good, went inside chaged my clothes and went to start it again, but it wont start, fuel pump wont come on so with the being the most apparent problem that is what i started trouble shooting, and it started with checking to see if power was getting to the pump and it was a no go so now i needed to figure out why that is, since i have a painless harness installed on the engine is is pretty straight foward where the relay and fuse is, checked power at the fuse(good) 12v so that is a good sign go to the relay verified 12v constant power, ground is good, but this is where it started getting interesting, the switched power is commanded by the ecm and i was only getting 6 volts (actually 5.66V) and a continuity check also reveiled the swtched power has a path to groun with the relay removed, so i figure i would wire in a differnt relay and get the pump going, got everything connected turn the key on and we have fuel moving so i go to see if it will start and nothing but cranking!!! so now i am thinking my ecm has gone bad, how i have no idea! but this is very odd to me, does anyone else have any ideas?

99.5 F250, VGT 5.9 CR cummins
dzljon is offline  
The Following User Says Thank You to dzljon For this addition to TDG:
Jesse M. (09-11-2016)
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-08-2012, 03:30 AM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,834
Points: 56,477
Thanks: 302
Thanked 691 Times in 599 Posts
Garage
can you pull any codes off the ecm?

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air
Optima Redtop 34Rs


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2016 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #3 of 10 (permalink) Old 04-08-2012, 10:07 AM Thread Starter
Senior Member
Threadstarter
 
dzljon's Avatar
 
Join Date: Dec 2006
Posts: 622
Points: 52,679
Thanks: 40
Thanked 60 Times in 47 Posts
Garage
Quote:
Originally Posted by neeltburn View Post
can you pull any codes off the ecm?
when i initially hook up the scanner it will tell me test passed no codes, but if i try to read codes again there is a commmunication error, i am pretty sure the ecm is bad but i dont understand how it started ran perfect and then wont restart it is odd...

99.5 F250, VGT 5.9 CR cummins
dzljon is offline  
post #4 of 10 (permalink) Old 04-08-2012, 02:02 PM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,834
Points: 56,477
Thanks: 302
Thanked 691 Times in 599 Posts
Garage
Do you get a CAN-BUS Error? check the relay for your ECM, but sounds like your on the right track.

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air
Optima Redtop 34Rs


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2016 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #5 of 10 (permalink) Old 04-09-2012, 01:47 AM Thread Starter
Senior Member
Threadstarter
 
dzljon's Avatar
 
Join Date: Dec 2006
Posts: 622
Points: 52,679
Thanks: 40
Thanked 60 Times in 47 Posts
Garage
my engine is SCI so i should not see a CAN error, but just like anyone in this position, I would like to know why it happened so i dont ruin another one, but this one ran perfect for the year i have had it, so maybe it was just its time to go.
Does anyone have a good recomendation for a good spot to get ecm;s repair and flashed? i may go down this road if it is economical?

99.5 F250, VGT 5.9 CR cummins
dzljon is offline  
post #6 of 10 (permalink) Old 04-09-2012, 02:54 AM
ADMIN/MAFIA
 
neeltburn's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 4,834
Points: 56,477
Thanks: 302
Thanked 691 Times in 599 Posts
Garage
I would call Aden out as GOS or maybe even Bob Wagner ( US Smarty Guru) and see where they get their ecms from.

"Only accurate rifles are interesting" -Townsend Whelen

2012 Ram 2500 Crew Cab Big Horn
6.7L 68RFE 4wd
Yeah its stock.
Edge Insight CTS / Line-X / Access Bed Cover
B&W Turnover Ball / Companion Hitch
Pac Brake Air Bags
On Board Air
Optima Redtop 34Rs


2010 John Deere 2305
2010 Jeep Wrangler JK Unlimited Rubicon/ Tuned with some toys.
2016 Keystone Impact 311 Toyhauler






9-11-2001 NEVER FORGET
neeltburn is offline  
post #7 of 10 (permalink) Old 04-10-2012, 10:10 PM Thread Starter
Senior Member
Threadstarter
 
dzljon's Avatar
 
Join Date: Dec 2006
Posts: 622
Points: 52,679
Thanks: 40
Thanked 60 Times in 47 Posts
Garage
got a new(used) ecm with similar settings on the way, this should fix my problem..

99.5 F250, VGT 5.9 CR cummins
dzljon is offline  
post #8 of 10 (permalink) Old 04-13-2012, 09:31 PM Thread Starter
Senior Member
Threadstarter
 
dzljon's Avatar
 
Join Date: Dec 2006
Posts: 622
Points: 52,679
Thanks: 40
Thanked 60 Times in 47 Posts
Garage
putthe new ecm in, engine starts and idles but no throttle input so i need to calibrate it with the correct software, but on the upside it proves my trouble shooting correct.... i wish it would have been a sensor....

99.5 F250, VGT 5.9 CR cummins
dzljon is offline  
post #9 of 10 (permalink) Old 04-14-2012, 03:35 AM
Newbie
 
Join Date: Dec 2008
Posts: 128
Points: 21,115
Thanks: 40
Thanked 23 Times in 20 Posts
Glad you figured it out!

2002 Ford F350 Crewcab 4x4 7.3 PSD, powered by a 2004 5.9L Cummins

820 HP on 05/19/12
Deputydog is offline  
post #10 of 10 (permalink) Old 04-27-2012, 11:09 PM Thread Starter
Senior Member
Threadstarter
 
dzljon's Avatar
 
Join Date: Dec 2006
Posts: 622
Points: 52,679
Thanks: 40
Thanked 60 Times in 47 Posts
Garage
truck is fixed and back on the road, I learned quite abit about ecms over this ordeal, for any one wanting to install a electronic motor i.e first gen 24 valve or common rail, GET THE VIN NUMBER! it will save you time also you HAVE to use the exact same part number ecm, i learned that there is at least 3 different numbers from 03-04 and to find one with the same part number and EXACT same calibration is freakin rediculous! unless you pay $1700 from the dealer and you can only do that if you have the freakin vin number...

99.5 F250, VGT 5.9 CR cummins
dzljon is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome