which O2 sensor is which? need to replace 2 of 4 - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by SSpeeDEMONSS, this thread has received 14 replies and been viewed 5324 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 10-25-2010, 10:14 PM Thread Starter
off to another home
 
SSpeeDEMONSS's Avatar
 
Join Date: Feb 2006
Posts: 15,472
Points: 66,185
Thanks: 585
Thanked 1,365 Times in 1,112 Posts
Garage
Send a message via Yahoo to SSpeeDEMONSS
which O2 sensor is which? need to replace 2 of 4

its a 2000 2500 6.0 vortec. i went to smog it and it failed due to 2 oxygen sensors. passed the actual smog though. the codes it has are P0141 and P0161. O2 sensor heater fault(bank 1 sensor 2 and bank 2 sensor 2). are those both the post cat sensors? once i replace them, how can i clear the codes?

Garrett






BRING BACK THE OLD TDG!
oh well, i have a map to the darkside

SSpeeDEMONSS is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 10-25-2010, 11:05 PM
Gone Fishin...
 
merlin5577's Avatar
 
Join Date: Dec 2008
Location: Taunton, MA
Posts: 3,099
Points: 13,071
Thanks: 1,058
Thanked 561 Times in 471 Posts
Send a message via AIM to merlin5577 Send a message via Yahoo to merlin5577
Yes, both of those are the rear (post cat) sensors. When replacing them, disconnect the battery and then after 2 complete ignition cycles the light should go out.

-Robert.

My Fleet;

2011 Volkswagen Jetta TDI 2.0L 6A
2010 Chevrolet Malibu LT 2.4L 6A
2003 Chevrolet Silverado LS 6.6L 5A
1997 GMC Suburban SLT 5.7L 4A

TDG MAFIA
Quote:
If you dont stand behind our troops, feel free to stand in front of them.
Thinking of buying a Duramax? You need to click this link;

Reading material

I am an old Fart;

Toot-Toot

merlin5577 is offline  
The Following User Says Thank You to merlin5577 For this addition to TDG:
SSpeeDEMONSS (10-26-2010)
post #3 of 15 (permalink) Old 10-26-2010, 01:24 AM Thread Starter
off to another home
Threadstarter
 
SSpeeDEMONSS's Avatar
 
Join Date: Feb 2006
Posts: 15,472
Points: 66,185
Thanks: 585
Thanked 1,365 Times in 1,112 Posts
Garage
Send a message via Yahoo to SSpeeDEMONSS
thanks! that will be simple.

Garrett






BRING BACK THE OLD TDG!
oh well, i have a map to the darkside

SSpeeDEMONSS is offline  
post #4 of 15 (permalink) Old 11-15-2010, 08:23 PM Thread Starter
off to another home
Threadstarter
 
SSpeeDEMONSS's Avatar
 
Join Date: Feb 2006
Posts: 15,472
Points: 66,185
Thanks: 585
Thanked 1,365 Times in 1,112 Posts
Garage
Send a message via Yahoo to SSpeeDEMONSS
i replaced the sensors, had the battery unhooked when i did so, and the light is still on. what gives?

Garrett






BRING BACK THE OLD TDG!
oh well, i have a map to the darkside


Last edited by SSpeeDEMONSS; 11-15-2010 at 08:34 PM.
SSpeeDEMONSS is offline  
post #5 of 15 (permalink) Old 11-15-2010, 08:42 PM
Gone Fishin...
 
merlin5577's Avatar
 
Join Date: Dec 2008
Location: Taunton, MA
Posts: 3,099
Points: 13,071
Thanks: 1,058
Thanked 561 Times in 471 Posts
Send a message via AIM to merlin5577 Send a message via Yahoo to merlin5577
Like I said, it will take a few ignition cycles for the light to go out. Drive the truck for a few days and the light should go out.

-Robert.

My Fleet;

2011 Volkswagen Jetta TDI 2.0L 6A
2010 Chevrolet Malibu LT 2.4L 6A
2003 Chevrolet Silverado LS 6.6L 5A
1997 GMC Suburban SLT 5.7L 4A

TDG MAFIA
Quote:
If you dont stand behind our troops, feel free to stand in front of them.
Thinking of buying a Duramax? You need to click this link;

Reading material

I am an old Fart;

Toot-Toot

merlin5577 is offline  
post #6 of 15 (permalink) Old 11-16-2010, 05:17 PM Thread Starter
off to another home
Threadstarter
 
SSpeeDEMONSS's Avatar
 
Join Date: Feb 2006
Posts: 15,472
Points: 66,185
Thanks: 585
Thanked 1,365 Times in 1,112 Posts
Garage
Send a message via Yahoo to SSpeeDEMONSS
i changed them out on friday and been driving around and the light is still on.

Garrett






BRING BACK THE OLD TDG!
oh well, i have a map to the darkside

SSpeeDEMONSS is offline  
post #7 of 15 (permalink) Old 11-16-2010, 06:03 PM
Gone Fishin...
 
merlin5577's Avatar
 
Join Date: Dec 2008
Location: Taunton, MA
Posts: 3,099
Points: 13,071
Thanks: 1,058
Thanked 561 Times in 471 Posts
Send a message via AIM to merlin5577 Send a message via Yahoo to merlin5577
Have the codes pulled again and see if its still the 02 sensors. My Suburban had the same codes a few years ago and thats what I did to fix the problem.

Not to sound like a wise ***, but you did plug the sensors in when you installed them, correct?

-Robert.

My Fleet;

2011 Volkswagen Jetta TDI 2.0L 6A
2010 Chevrolet Malibu LT 2.4L 6A
2003 Chevrolet Silverado LS 6.6L 5A
1997 GMC Suburban SLT 5.7L 4A

TDG MAFIA
Quote:
If you dont stand behind our troops, feel free to stand in front of them.
Thinking of buying a Duramax? You need to click this link;

Reading material

I am an old Fart;

Toot-Toot

merlin5577 is offline  
post #8 of 15 (permalink) Old 11-17-2010, 03:55 PM Thread Starter
off to another home
Threadstarter
 
SSpeeDEMONSS's Avatar
 
Join Date: Feb 2006
Posts: 15,472
Points: 66,185
Thanks: 585
Thanked 1,365 Times in 1,112 Posts
Garage
Send a message via Yahoo to SSpeeDEMONSS
Quote:
Originally Posted by merlin5577 View Post
Have the codes pulled again and see if its still the 02 sensors. My Suburban had the same codes a few years ago and thats what I did to fix the problem.

Not to sound like a wise ***, but you did plug the sensors in when you installed them, correct?
haha. yes, theyre plugged in and clipped. i guess ill have to rent a scanner from autozone to check them then.

Garrett






BRING BACK THE OLD TDG!
oh well, i have a map to the darkside

SSpeeDEMONSS is offline  
post #9 of 15 (permalink) Old 11-18-2010, 01:03 AM
496 Cubic Inches
 
496 BB's Avatar
 
Join Date: Jul 2009
Location: Central Ohio
Posts: 245
Points: 43,758
Thanks: 2
Thanked 29 Times in 21 Posts
Go over to Johnnys house and use EFI Live.

2001 HD 8.1L 4x4 Crew SB LT

EFI Live, K&N CAI, MSD, Plug mod (in testing), 160* T-Stat, Flomaster 40 Series SS (Duals)(No tails), Custom H-Pipe, (2) RF P2410's in custom down fire box, Rockford Old Skool 250aii amp, AirLift bags, On board compressor, Custom mount gauges, Body colored trim, 285 Revo ATV's, 16x10 Ions, 6K HID Lows & Fogs, Blue LED Dash, Blue LED Switches, Blue LED Footwell Lights, Blue LED Interior Lighting, and so much more....


Some people are like Slinkies ... not really good for anything, but you can't help smiling when you see one tumble down the stairs


Better to remain silent and be thought a fool, than to speak and remove all doubt
496 BB is offline  
post #10 of 15 (permalink) Old 11-18-2010, 04:39 PM Thread Starter
off to another home
Threadstarter
 
SSpeeDEMONSS's Avatar
 
Join Date: Feb 2006
Posts: 15,472
Points: 66,185
Thanks: 585
Thanked 1,365 Times in 1,112 Posts
Garage
Send a message via Yahoo to SSpeeDEMONSS
Quote:
Originally Posted by 496 BB View Post
Go over to Johnnys house and use EFI Live.
thats too much work and the old guy never answers his phone.

Garrett






BRING BACK THE OLD TDG!
oh well, i have a map to the darkside

SSpeeDEMONSS is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
7.3L IDM replace, need help. jimbotismo 1994-2003 7.3L Power Stroke 14 01-12-2012 03:14 PM
How to remove and replace ICP sensor on 6.0 rickou812 Ford - Modification instructions, Product installs and Tech Articles 1 01-26-2011 12:19 AM
96 CPS replace Burner718 1994-2003 7.3L Power Stroke 3 02-26-2009 03:42 AM
Cat 3116e: Fuel Temp Sensor & Boost Pressure Sensor probablecause Medium and Heavy Duty 0 02-03-2009 01:54 AM
Replace cat or not lilgsx 2003-2007 6.0L Power Stroke 8 11-28-2005 02:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome