HELP 07 Duromax - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by mblue, this thread has received 18 replies and been viewed 2184 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 10-07-2009, 03:49 AM Thread Starter
 
Join Date: Oct 2009
Posts: 3
Points: 422
Thanks: 0
Thanked 0 Times in 0 Posts
HELP 07 Duromax

I have a 07 that replaced an 04. Everything is stock except for a k and n air filter. Changed oil and fuel filter last Thursday along with the passenger side headlamp. I opened the air filter box thinking it would give me more hand room, wrong. Everything is good until last Friday heading home from work up the Manchester bridge entrance ramp to I-610 over the channel and "engine at reduced power" message. Topped the bridge and everything is good, punched it and away we go 75mph plus. Went to orielly and reset the truck Saturday. Got a mass air flow reading. Heading home yesterday and BAM, same thing. Everything is good when I level out on top of the bridge, hit 85 mph plus on the way home. The engine light is still on but the truck runs as normal. Any suggestions?
mblue is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 10-07-2009, 05:44 AM
Pardue the Traveler
 
New 0mega's Avatar
 
Join Date: Jun 2009
Location: Forestburg Alberta Canada
Posts: 4,023
Points: 51,411
Thanks: 101
Thanked 253 Times in 238 Posts
Garage
Send a message via Yahoo to New 0mega
Sorry to say its the K&N air filter. Either some dust, water or oil has gotten around the filter and has landed on the MAF sensor.

Smoke!!! Smoke!!!! Are you Smoking yet?
2007.5 Sierra 2500HD SLE 6.6L Duramax Extended Cab Long Box Z71 Fass 150/95, Rare Parts G2 hd tie rods, EFi Live, DSP5 a tune from Duramaxtuner.com, MBRP 4" Downpipe back, Edge CTS Insight, Cognito Idler/Pitman Arm Braces, PPE Deep Transmission pan, deep pan filter, Transgo Jr kit
Canadian Club member #2 https://www.thedieselgarage.com/forum...light=Canadian
Singles Club member #250
https://thedieselgarage.com/forums/image.php?type=sigpic&userid=23125&dateline=124580  0528
For those whom are looking at a Duramax check this thread out.https://www.thedieselgarage.com/forum...ad.php?t=92868
New 0mega is offline  
post #3 of 19 (permalink) Old 10-07-2009, 05:59 AM
LBZ
 
Join Date: Jan 2009
Posts: 42
Points: 652
Thanks: 0
Thanked 3 Times in 3 Posts
Garage
Quote:
Originally Posted by New 0mega View Post
Sorry to say its the K&N air filter. Either some dust, water or oil has gotten around the filter and has landed on the MAF sensor.
Yup, sounds the same to me. Remove your maf and clean it off. I have used brake clean spray in the past but some say it hurts it. I've never had a problem though.
LBZ is offline  
post #4 of 19 (permalink) Old 10-08-2009, 02:13 AM
CRAZY CANUCK
 
BriteWhiteRam's Avatar
 
Join Date: Oct 2006
Location: Alberta, Canada
Posts: 4,320
Points: 63,254
Thanks: 350
Thanked 506 Times in 416 Posts
Garage
The K&N are notorious for letting through dust which clogs the MAF sensor, its due to the dust mixed with the K&N's oil and it sticks to everything..... my suggestion, get rid of your K&N and put the stock airbox back on, the stock unit flows as good or better, and is more efficient at stopping dust particles, and the stock filter will hold more dust before its efficiency drops off

Do the PPE airbox mod and you will be much better off than with the K&N, i will never put a K&N on my truck, they just aren't reliable

Aaron the Crazy Canuck
2006 Chevrolet Silverado LT 2500: LBZ - Allison, Greystone Metallic, 4x4,PPE airbox mod, missing muffler/cat, EFILive tuned by Nick at duramaxtuner, MA tie-rod sleeves and Grade C headgaskets
Totalled!! May 2nd 2008-2005 Dodge Ram 3500 laramie: Cummins auto, plain white, rebuilt tranny
1986 Mercury Capri - 5.0L, AOD, shorty headers, acell ignition, Holly street dominator intake, Holly 625 vacuum secondaries carb, Dual glass packs "my little yellow terror"

DURAMAX INDEX; You want a Duramax? you want to click on this >>The Duramax Index

Canadian Club Member #1
Singles Club member #186
Ridin Dirty Club #5


TDG MAFIA


Check out the NEW and IMPROVED TDG Truck Poll!
TDG TOTQ
BriteWhiteRam is offline  
post #5 of 19 (permalink) Old 10-08-2009, 03:47 AM Thread Starter
Threadstarter
 
Join Date: Oct 2009
Posts: 3
Points: 422
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the replies. Can you believe the kandn filter was cheaper than the oem? Remember the headlight part where I opened the filter box trying to get my fat hand in there to replace the bulb? Well I looked in there today and I did not get the filter back into place, 1/2 inch gap. It was my fault, sipping whiskey while working on the truck. Put the filter into place and reset the code. I'll keep ya"ll posted. I really like this truck, only problem so far is the back tires lose tread un proportional to the front tires. I love keeping up with and leaving the 3k# imports here in yuppieland.
mblue is offline  
post #6 of 19 (permalink) Old 10-10-2009, 12:10 AM
Toyaholic
 
Join Date: Sep 2009
Location: Hewitt,NJ
Posts: 250
Points: 42,022
Thanks: 10
Thanked 15 Times in 14 Posts
if you use brake clean DO NOT USE NON CHLORINATED! it WILL melt it.

01 Chevy CC/SB 4WD. Not Quite Stock.
vrabel is offline  
post #7 of 19 (permalink) Old 10-10-2009, 02:52 AM Thread Starter
Threadstarter
 
Join Date: Oct 2009
Posts: 3
Points: 422
Thanks: 0
Thanked 0 Times in 0 Posts
Truck is running great so far.
mblue is offline  
post #8 of 19 (permalink) Old 10-10-2009, 03:00 AM
LBZ
 
Join Date: Jan 2009
Posts: 42
Points: 652
Thanks: 0
Thanked 3 Times in 3 Posts
Garage
Right on
LBZ is offline  
post #9 of 19 (permalink) Old 10-10-2009, 12:36 PM
Senior Member
 
Join Date: May 2005
Posts: 3,939
Points: 47,783
Thanks: 27
Thanked 60 Times in 44 Posts
mblue....sounds like a University of Michigan name. Where is Mich are you?

Glad to hear the truck is back up and running well.
TheBac is offline  
post #10 of 19 (permalink) Old 10-10-2009, 03:22 PM
Gone Fishin...
 
merlin5577's Avatar
 
Join Date: Dec 2008
Location: Taunton, MA
Posts: 3,099
Points: 12,996
Thanks: 1,058
Thanked 561 Times in 471 Posts
Send a message via AIM to merlin5577 Send a message via Yahoo to merlin5577
Quote:
Originally Posted by BriteWhiteRam View Post
The K&N are notorious for letting through dust which clogs the MAF sensor, its due to the dust mixed with the K&N's oil and it sticks to everything..... my suggestion, get rid of your K&N and put the stock airbox back on, the stock unit flows as good or better, and is more efficient at stopping dust particles, and the stock filter will hold more dust before its efficiency drops off

Do the PPE airbox mod and you will be much better off than with the K&N, i will never put a K&N on my truck, they just aren't reliable
Sorry Aaron but I have to disagree. I've run K&Ns for years in multiple vehicles and have never had a problem. I also know a lot of people that have run them as well with no problems. Every time i've seen or heard of a problem with one its because of user error. Too much oil on cleaning, improper install, etc...

Quote:
Originally Posted by mblue View Post
Thanks for the replies. Can you believe the kandn filter was cheaper than the oem? Remember the headlight part where I opened the filter box trying to get my fat hand in there to replace the bulb? Well I looked in there today and I did not get the filter back into place, 1/2 inch gap. It was my fault, sipping whiskey while working on the truck. Put the filter into place and reset the code. I'll keep ya"ll posted. I really like this truck, only problem so far is the back tires lose tread un proportional to the front tires. I love keeping up with and leaving the 3k# imports here in yuppieland.
I rest my case...

No offense meant to anyone, mistakes happen.


-Robert.

My Fleet;

2011 Volkswagen Jetta TDI 2.0L 6A
2010 Chevrolet Malibu LT 2.4L 6A
2003 Chevrolet Silverado LS 6.6L 5A
1997 GMC Suburban SLT 5.7L 4A

TDG MAFIA
Quote:
If you dont stand behind our troops, feel free to stand in front of them.
Thinking of buying a Duramax? You need to click this link;

Reading material

I am an old Fart;

Toot-Toot


Last edited by merlin5577; 10-10-2009 at 03:25 PM.
merlin5577 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome