05 stumbling - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by bikernut, this thread has received 1 replies and been viewed 2119 times.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-02-2015, 09:04 PM Thread Starter
tameing the Dually Beast
 
Join Date: Feb 2006
Posts: 20
Points: 1,590
Thanks: 0
Thanked 0 Times in 0 Posts
05 stumbling

have a 05 3500 4x4 and driving along the truck starts to stumble if feeding it fuel and then shuts down in the limp mode. I then hit the brake to stop and the truck returns to normal except check engine light stays on and runs fine for a while and then starts it all over again. Chevy dealer a while back found a chafed wire going to the fuel injector regulator and repaired and it was going great and then started acting up again, back to the dealer to check previous repair and everything was okay, they have tried a bunch of things but haven't found anything else, hoping some one has heard of this or experienced the same and can tell me what was done to solve it. no mods done all stock.
thanks

Born to ride into the wind
2016 GMC Denali 3500 Dually
2003 GMC 3500 4X4 Dually Dump (Red)
2007 KZ [email protected] Toy Hauler (White with stripes)
2015 Harley FLHTCUTG Trike
1995 Harley FLT (2 tone Red)
1992 Chevy S-10 Blazer 4X4 (Maroon)(wife's)
1978 Pontiac Trans Am GTA (Black)
John Deere 316 Tractor (John Deere Green)
1997 New Holland 555E Backhoe/Loader
bikernut is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-13-2015, 10:58 PM Thread Starter
tameing the Dually Beast
Threadstarter
 
Join Date: Feb 2006
Posts: 20
Points: 1,590
Thanks: 0
Thanked 0 Times in 0 Posts
having trouble with my 05 6.6 with the PO090 code and no start. dealer fixed frayed wire one that went from the FICM to Regulator and the problem seemed to go away. 1 month later the same problem with the same code, dealer could find nothing wrong the placed a call to TAC, they recommended that restring new wire from FICM to Regulator which they did and it seemed fine no more code. let it set for 2 days and went to go Christmas shopping this morning and a no start problem again, had neighbor come over with code scanner and low and be hold the Code PO090 shows up again, this has cost me almost $800 so far and I need an answer can anyone help?? thanks

Born to ride into the wind
2016 GMC Denali 3500 Dually
2003 GMC 3500 4X4 Dually Dump (Red)
2007 KZ [email protected] Toy Hauler (White with stripes)
2015 Harley FLHTCUTG Trike
1995 Harley FLT (2 tone Red)
1992 Chevy S-10 Blazer 4X4 (Maroon)(wife's)
1978 Pontiac Trans Am GTA (Black)
John Deere 316 Tractor (John Deere Green)
1997 New Holland 555E Backhoe/Loader
bikernut is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
POS stumbling on takeoff and now hard starting Chobeeman 5.9L Cummins (2003-2007.5) 5 02-08-2010 01:49 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome