Need help asap - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by DmaxDusty, this thread has received 2 replies and been viewed 547 times.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-04-2008, 08:34 PM Thread Starter
 
Join Date: Oct 2007
Posts: 14
Points: 759
Thanks: 0
Thanked 0 Times in 0 Posts
Need help asap

Okay so just the other day my 03' silverado's speedometer started to act up...Then it started working better for a couple of days. Then the other day I started my truck and now all the gauges don't work (entire cluster just sits as if the truck were off) do I need to just replace my cluster?? I know alot of the 03's had crappy stepper motors which is what I thought I was experiencing but it threw me when they all don't respond now...... Thanks
DmaxDusty is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-05-2008, 12:18 AM
Kat
 
Join Date: Dec 2008
Posts: 1,699
Points: 3,492
Thanks: 0
Thanked 0 Times in 0 Posts
Kat is offline  
post #3 of 3 (permalink) Old 01-05-2008, 02:30 AM
Senior Member
 
Join Date: May 2005
Posts: 3,939
Points: 47,888
Thanks: 27
Thanked 60 Times in 44 Posts
Have your batteries load tested first. The cluster had to see a minimum voltage to "wake up" and if one or both the batteries are discharging, then this will occur.

If the batteries check out ok, then look into cluster replacement.
TheBac is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome