02 LB7 starts and shuts down - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by dmaxlb7, this thread has received 13 replies and been viewed 5431 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 07-27-2009, 01:15 AM Thread Starter
Junior Member
 
Join Date: Jun 2009
Location: mn
Posts: 37
Points: 30,707
Thanks: 5
Thanked 9 Times in 2 Posts
02 LB7 starts and shuts down

I took it to the dealer and they said it was a bad crankshaft position sensor. Replaced that, turns out that's not the problem. I had my friend's computer on it and the only code it threw was an old security code. We cleared it but it didn't help. Anyone have an idea what it could be? Any info would be greatly appreciated.
dmaxlb7 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 07-27-2009, 05:28 PM
Pardue the Traveler
 
New 0mega's Avatar
 
Join Date: Jun 2009
Location: Forestburg Alberta Canada
Posts: 4,023
Points: 51,411
Thanks: 101
Thanked 253 Times in 238 Posts
Garage
Send a message via Yahoo to New 0mega
Have you checked the fuel filter, is your lift pump not working properly, check the injectors? Thats what I can think of for now.

Smoke!!! Smoke!!!! Are you Smoking yet?
2007.5 Sierra 2500HD SLE 6.6L Duramax Extended Cab Long Box Z71 Fass 150/95, Rare Parts G2 hd tie rods, EFi Live, DSP5 a tune from Duramaxtuner.com, MBRP 4" Downpipe back, Edge CTS Insight, Cognito Idler/Pitman Arm Braces, PPE Deep Transmission pan, deep pan filter, Transgo Jr kit
Canadian Club member #2 https://www.thedieselgarage.com/forum...light=Canadian
Singles Club member #250
https://thedieselgarage.com/forums/image.php?type=sigpic&userid=23125&dateline=124580  0528
For those whom are looking at a Duramax check this thread out.https://www.thedieselgarage.com/forum...ad.php?t=92868
New 0mega is offline  
post #3 of 14 (permalink) Old 07-27-2009, 05:34 PM
is here and there.
 
Rcannon's Avatar
 
Join Date: Dec 2008
Posts: 10,573
Points: 74,196
Thanks: 691
Thanked 1,110 Times in 665 Posts
Images: 11
Filter housing crack? If you recently changed your filter you may have air leak in the system.

Life changes, so roll with it, not against it.
Rcannon is offline  
post #4 of 14 (permalink) Old 07-28-2009, 03:55 AM Thread Starter
Junior Member
Threadstarter
 
Join Date: Jun 2009
Location: mn
Posts: 37
Points: 30,707
Thanks: 5
Thanked 9 Times in 2 Posts
It seems to be an ignition issue. The filter is new. It fires up, runs for a few seconds and shuts down. The rail pressure and all that seems fine.
dmaxlb7 is offline  
post #5 of 14 (permalink) Old 07-28-2009, 12:42 PM
is here and there.
 
Rcannon's Avatar
 
Join Date: Dec 2008
Posts: 10,573
Points: 74,196
Thanks: 691
Thanked 1,110 Times in 665 Posts
Images: 11
If it starts, why would you say it's an ignition issue?
You say the filter is new, how new? Has it run since you replaced the filter?

Life changes, so roll with it, not against it.
Rcannon is offline  
post #6 of 14 (permalink) Old 07-29-2009, 12:15 AM
Gone Fishin...
 
merlin5577's Avatar
 
Join Date: Dec 2008
Location: Taunton, MA
Posts: 3,099
Points: 12,994
Thanks: 1,058
Thanked 561 Times in 471 Posts
Send a message via AIM to merlin5577 Send a message via Yahoo to merlin5577
Since the Duramax engines do not have a lift pump, and the engine fires right up, I doubt its a fuel problem. My guess would be the coolant temperature sensor. If the sensor was bad it would do exactly what your describing. Is your check engine light on?

-Robert.

My Fleet;

2011 Volkswagen Jetta TDI 2.0L 6A
2010 Chevrolet Malibu LT 2.4L 6A
2003 Chevrolet Silverado LS 6.6L 5A
1997 GMC Suburban SLT 5.7L 4A

TDG MAFIA
Quote:
If you dont stand behind our troops, feel free to stand in front of them.
Thinking of buying a Duramax? You need to click this link;

Reading material

I am an old Fart;

Toot-Toot

merlin5577 is offline  
post #7 of 14 (permalink) Old 07-30-2009, 04:53 AM
CRAZY CANUCK
 
BriteWhiteRam's Avatar
 
Join Date: Oct 2006
Location: Alberta, Canada
Posts: 4,320
Points: 63,253
Thanks: 350
Thanked 506 Times in 416 Posts
Garage
Quote:
Originally Posted by dmaxlb7 View Post
It seems to be an ignition issue. The filter is new. It fires up, runs for a few seconds and shuts down. The rail pressure and all that seems fine.
well it cant be an ignition issue because if it runs, then it is igniting the fuel, diesels are a "compression ignition" engine, they create extreme pressures in the cylinders which creates heat and that starts the combustion of the diesel fuel, theres no spark plugs, no coils, no distributor..... im sorry if you knew that, just trying to spread the knowledge of the mighty diesel

I would have to agree with Merlin tho...

Aaron the Crazy Canuck
2006 Chevrolet Silverado LT 2500: LBZ - Allison, Greystone Metallic, 4x4,PPE airbox mod, missing muffler/cat, EFILive tuned by Nick at duramaxtuner, MA tie-rod sleeves and Grade C headgaskets
Totalled!! May 2nd 2008-2005 Dodge Ram 3500 laramie: Cummins auto, plain white, rebuilt tranny
1986 Mercury Capri - 5.0L, AOD, shorty headers, acell ignition, Holly street dominator intake, Holly 625 vacuum secondaries carb, Dual glass packs "my little yellow terror"

DURAMAX INDEX; You want a Duramax? you want to click on this >>The Duramax Index

Canadian Club Member #1
Singles Club member #186
Ridin Dirty Club #5


TDG MAFIA


Check out the NEW and IMPROVED TDG Truck Poll!
TDG TOTQ
BriteWhiteRam is offline  
The Following User Says Thank You to BriteWhiteRam For this addition to TDG:
merlin5577 (07-30-2009)
post #8 of 14 (permalink) Old 07-30-2009, 05:21 AM
Pardue the Traveler
 
New 0mega's Avatar
 
Join Date: Jun 2009
Location: Forestburg Alberta Canada
Posts: 4,023
Points: 51,411
Thanks: 101
Thanked 253 Times in 238 Posts
Garage
Send a message via Yahoo to New 0mega
Could it be a blown fuse?

Smoke!!! Smoke!!!! Are you Smoking yet?
2007.5 Sierra 2500HD SLE 6.6L Duramax Extended Cab Long Box Z71 Fass 150/95, Rare Parts G2 hd tie rods, EFi Live, DSP5 a tune from Duramaxtuner.com, MBRP 4" Downpipe back, Edge CTS Insight, Cognito Idler/Pitman Arm Braces, PPE Deep Transmission pan, deep pan filter, Transgo Jr kit
Canadian Club member #2 https://www.thedieselgarage.com/forum...light=Canadian
Singles Club member #250
https://thedieselgarage.com/forums/image.php?type=sigpic&userid=23125&dateline=124580  0528
For those whom are looking at a Duramax check this thread out.https://www.thedieselgarage.com/forum...ad.php?t=92868
New 0mega is offline  
post #9 of 14 (permalink) Old 08-06-2009, 11:57 PM
Senior Member
 
Join Date: Jan 2009
Posts: 1,409
Points: 4,854
Thanks: 34
Thanked 40 Times in 30 Posts
Auto or manual?
mckey73 is offline  
post #10 of 14 (permalink) Old 08-18-2009, 09:37 PM
stock is boring
 
Join Date: Jan 2009
Location: Franklin co.,PA
Posts: 214
Points: 17,818
Thanks: 9
Thanked 7 Times in 7 Posts
My '04 is doing the exact same thing and blowing a lot of white/gray smoke.

'04 LB7 4DR LONG BED 4x4
'02 LB7 REG CAB Utility body 2wd
dragnsled is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
shuts off garbageman_7 1994-2003 7.3L Power Stroke 4 07-26-2009 10:28 PM
Truck idles good then just shuts off 7.3stroker281 1994-2003 7.3L Power Stroke 8 01-31-2008 01:54 PM
6.5 Shuts off by itself Ronzoni007 6.5L Diesel Engine 15 08-14-2007 01:27 PM
6.5 diesel shuts off driving:( Liftedpsd 6.5L Diesel Engine 1 05-31-2007 01:54 PM
99 7.3 shuts down in the rain thw1 1994-2003 7.3L Power Stroke 4 01-08-2007 08:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome