tranny help - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by 516rider, this thread has received 14 replies and been viewed 3182 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 01-07-2010, 03:03 AM Thread Starter
Junior Member
 
516rider's Avatar
 
Join Date: Jul 2009
Location: pickerington ohio
Posts: 219
Points: 40,857
Thanks: 0
Thanked 3 Times in 2 Posts
Images: 3
Garage
tranny help

hey i went to go move my truck tonight to let my granpa in the garage. when i went to go put it in reverse my odometer read "range shift inhibited" i have no clue what that means but i ened up pushing it out of the way. when i put it into drive it shifts real hard and makes a loud noise. any help??
516rider is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 02-05-2010, 04:19 AM
Junior Member
 
Join Date: Dec 2007
Posts: 7
Points: 123
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same problem. I have a 2005 2500 crew cab. 122k miles I was driving on freeway my engine light came on and I noticed truck wasn't shifting. I got to my buddys house and when I put it in reverse it said "range shift inhibited". When I got back from hockey game it shifted fine engine light was still on. on the drive home it wouldn't shift gears. I checked tranny fluid all fine. It shifted real hard when I put it in drive and and then wouldn't shift out of 2nd (i think) car wouldn't go over 30 at 1900 rpm and indicator lights don't show what gear I'm in.

HELP

Will
whoone is offline  
post #3 of 15 (permalink) Old 02-05-2010, 12:08 PM Thread Starter
Junior Member
Threadstarter
 
516rider's Avatar
 
Join Date: Jul 2009
Location: pickerington ohio
Posts: 219
Points: 40,857
Thanks: 0
Thanked 3 Times in 2 Posts
Images: 3
Garage
i was told it was an electrical conection that was loose or something in the valve body. i just went ahead and droped a suncoast stage 5 tranny in it. because the guys were charging too much and it was cheaper for me to go ahead a build my tranny

2004 chevy 2500 duramax lly. no cat or anything resignator capped pcv rerouted, ats stage 3 internals with transgo shift kit, isspro ev2 gauges, custom 4 inch straight pipe with 6 inch tip, afe intake, efi live tunning, fass 150, moded cp3, injectors opened 45%, 64mm cheetah turbo soon to be replaced with twins
516rider is offline  
post #4 of 15 (permalink) Old 02-05-2010, 12:21 PM
Junior Member
 
DrHolliday's Avatar
 
Join Date: Feb 2008
Location: From Ohio, live in Havelock, NC
Posts: 182
Points: 20,262
Thanks: 6
Thanked 40 Times in 32 Posts
I know you got yours fixed 516, but whoone... get the codes read. Auto zone should be able to read them, post them up and we can help you better.

Chris
2006 Chevy 2500HD LBZ/Allison ECSB 4x4 Greystone metallic

S475, 3" boost tubes, 5" intake, Custom Y-Bridge
Tuning and Transmission by Diesel Addiction . A special thanks to Dustin for all the help.

12.42 @ 106.3 (stock injectors, CP3, and turbo, no drugs!)
7.83 @ 86.2 1/8th
531 RWHP / 940 RWTQ 10/11/08 on Wayne's Dyno in Jville NC

USMC 2002-present
DrHolliday is offline  
post #5 of 15 (permalink) Old 02-06-2010, 04:15 AM Thread Starter
Junior Member
Threadstarter
 
516rider's Avatar
 
Join Date: Jul 2009
Location: pickerington ohio
Posts: 219
Points: 40,857
Thanks: 0
Thanked 3 Times in 2 Posts
Images: 3
Garage
yea sorry but i gotta say if you got the money it is worth it to have a buil tranny. good luck

2004 chevy 2500 duramax lly. no cat or anything resignator capped pcv rerouted, ats stage 3 internals with transgo shift kit, isspro ev2 gauges, custom 4 inch straight pipe with 6 inch tip, afe intake, efi live tunning, fass 150, moded cp3, injectors opened 45%, 64mm cheetah turbo soon to be replaced with twins
516rider is offline  
post #6 of 15 (permalink) Old 02-06-2010, 11:49 AM
Member
 
Join Date: Jun 2006
Posts: 232
Points: 24,703
Thanks: 21
Thanked 2 Times in 2 Posts
Garage
My 04.5 was doing the same thing,codes came up and i changed 2 solenoids that showed on scanner.Well,i went out a week later in it and had got in it a little from a stop.The dang thing did it again,came up one of the solenoids i had changed.I went to napa and put some tranny repair stuff they have,it is a two part mix with sum synthetic stuff.I noticed my tranny is shifting smoother and has not limped since,thank goodness.
dirtrider is offline  
post #7 of 15 (permalink) Old 02-08-2010, 05:08 AM
Junior Member
 
Join Date: Dec 2007
Posts: 7
Points: 123
Thanks: 0
Thanked 0 Times in 0 Posts
Well, Here is the update, I took it in and had the codes pulled. It came up with Seven (7) codes one was a low voltage code one was the remote sensor and one was the transmission computer. I thought I was screwed... I had the remote sensor replaced. Water had gotten into it and was oozing out of it after the mechanic had it in his warm non snowed in garage for a day. After the switch was replaced five of the codes went away. It turned out the power supply to the transmission computer had come out of the loom and was rubbing on the inner fender and chaffed the wire so only 1 or 2 strands were all that was sending power to the computer. That was the low voltage code, and 4 hours of chasing electrical wires. The other code was fixed when the proper voltage went to the computer after the wired was repaired.

I was very relieved. I didn't want to rebuild the tranny.
Thanks for your help and suggestions.
whoone is offline  
post #8 of 15 (permalink) Old 02-09-2010, 03:53 PM Thread Starter
Junior Member
Threadstarter
 
516rider's Avatar
 
Join Date: Jul 2009
Location: pickerington ohio
Posts: 219
Points: 40,857
Thanks: 0
Thanked 3 Times in 2 Posts
Images: 3
Garage
yea i had that same code. the low voltage one. i thought it was my sub i have in my truck. it still shows up. which fender well should i look at

2004 chevy 2500 duramax lly. no cat or anything resignator capped pcv rerouted, ats stage 3 internals with transgo shift kit, isspro ev2 gauges, custom 4 inch straight pipe with 6 inch tip, afe intake, efi live tunning, fass 150, moded cp3, injectors opened 45%, 64mm cheetah turbo soon to be replaced with twins
516rider is offline  
post #9 of 15 (permalink) Old 02-11-2010, 12:54 AM
Member
 
Join Date: Jun 2006
Posts: 232
Points: 24,703
Thanks: 21
Thanked 2 Times in 2 Posts
Garage
Man,mine has done the stupid limp 2 more times.Both times it showed up as solenoid e and malfunctioned transmission computer so i pulled off the road both times and checked and cleared it with my scanner.It will do okay normal driving but when i push it hard every now and then it will pop shift and throw the same code even though i have already changed that solenoid.I only have 108,000 miles on it,seems like the allison would last longer.
dirtrider is offline  
post #10 of 15 (permalink) Old 02-17-2010, 01:08 AM
Junior Member
 
Join Date: Dec 2007
Posts: 7
Points: 123
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 516rider View Post
yea i had that same code. the low voltage one. i thought it was my sub i have in my truck. it still shows up. which fender well should i look at

Mine was on the drivers side coming out of the fuse box. It went down and forward to the transmission computer. I haven't had any problems since . My mechanic had his code reader on it while he chased it down it was fluctuating from 1 volt to 10 volts
whoone is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranny ? Taylor34 5.9L Cummins (1998.5-2002) 12 01-09-2009 02:05 PM
tranny rebuild kits! need help asap tranny is shot...f'in dodge auto trans blksmk 5.9L Cummins 12 Valve (1994-1998.5) 5 12-26-2008 10:55 PM
which tranny do I have bubafats 5.9L Cummins (2003-2007.5) 2 10-17-2007 04:23 AM
Tranny....... CSIPSD General Ford Truck and Excursion 27 01-26-2007 01:49 AM
Which tranny PSmokinD 1994-2003 7.3L Power Stroke 35 02-18-2006 02:51 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome