8V92TA stalls at idle sometimes - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by jjb, this thread has received 22 replies and been viewed 2481 times.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 06-08-2016, 05:25 AM Thread Starter
jjb
Junior Member
 
Join Date: Jun 2016
Location: NJ
Posts: 11
Points: 1,813
Thanks: 0
Thanked 1 Time in 1 Post
8V92TA stalls at idle sometimes

I have an 8V92TA in a Military truck that stalls occasionally once warm. I also notice it will run rough at highway speed almost like its not getting enough fuel. It idles very low and sometimes the tach reads 0. At cold start I get about 7-800 rpms.

Any ideas where I should start looking?

Its a military rebuild by Diesel Exchange. It has less than 300 miles on it.
jjb is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 06-09-2016, 03:16 AM
Junior Member
 
Join Date: Apr 2008
Posts: 17
Points: 46,668
Thanks: 0
Thanked 1 Time in 1 Post
Try filters yet?
opus is offline  
post #3 of 23 (permalink) Old 06-09-2016, 03:42 AM Thread Starter
jjb
Junior Member
Threadstarter
 
Join Date: Jun 2016
Location: NJ
Posts: 11
Points: 1,813
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by opus View Post
Try filters yet?
I have them but have been putting it off since its a real pain to bleed. There is no primer pump and the fuel has a long way to go from the tank.

You think it could be that simple? I would think if it was a filter issue it would happen all of the time?
jjb is offline  
post #4 of 23 (permalink) Old 06-09-2016, 05:04 PM
Junior Member
 
Join Date: Apr 2008
Posts: 17
Points: 46,668
Thanks: 0
Thanked 1 Time in 1 Post
Yes, it could still be filters. Are they new filters? Has the engine been sitting for a long time? Excessive smoke...what color?
I didnt know it was doing it sporadically. If you have a 2 stroke DD, you should always have on hand a primer of some sort. Lots of people use a weed spray bottle, some use an electric fuel pump.
opus is offline  
post #5 of 23 (permalink) Old 06-10-2016, 04:49 AM Thread Starter
jjb
Junior Member
Threadstarter
 
Join Date: Jun 2016
Location: NJ
Posts: 11
Points: 1,813
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by opus View Post
Yes, it could still be filters. Are they new filters? Has the engine been sitting for a long time? Excessive smoke...what color?
I didnt know it was doing it sporadically. If you have a 2 stroke DD, you should always have on hand a primer of some sort. Lots of people use a weed spray bottle, some use an electric fuel pump.
No excessive smoke. The engine was reman'd in 2010 and I just put it in this truck last year. So it sat for 5 years but it was never run after it was rebuilt.

Not really sporadically. When its cold it seems find but at operating temp it stalls but not always. Usually when I get off the throttle quickly.
jjb is offline  
post #6 of 23 (permalink) Old 06-10-2016, 05:08 AM
Junior Member
 
Join Date: Apr 2008
Posts: 17
Points: 46,668
Thanks: 0
Thanked 1 Time in 1 Post
You know, I think you'll find your best answer to this over at the busconversion.com forum. Those guys are aces with 2 strokes. They take you step by step through diagnosing it.
opus is offline  
post #7 of 23 (permalink) Old 06-10-2016, 05:09 AM Thread Starter
jjb
Junior Member
Threadstarter
 
Join Date: Jun 2016
Location: NJ
Posts: 11
Points: 1,813
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by opus View Post
You know, I think you'll find your best answer to this over at the busconversion.com forum. Those guys are aces with 2 strokes. They take you step by step through diagnosing it.
I'll give it a shot thanks.
jjb is offline  
post #8 of 23 (permalink) Old 06-10-2016, 05:30 AM
Junior Member
 
Join Date: Apr 2008
Posts: 17
Points: 46,668
Thanks: 0
Thanked 1 Time in 1 Post
Being a military engine is a non DDEC. That should eliminate electrical issues. I'm still thinking fuel starvation. Dirty air filter would give smoke.
Messed up injector? I'll watch over there for you.
opus is offline  
post #9 of 23 (permalink) Old 06-11-2016, 03:17 AM
Senior Member
 
Join Date: Dec 2008
Posts: 502
Points: 48,812
Thanks: 74
Thanked 54 Times in 43 Posts
Whats the oil pressure like?
Les2 is offline  
post #10 of 23 (permalink) Old 06-11-2016, 09:24 PM
Junior Member
 
Oxbow12's Avatar
 
Join Date: Jan 2013
Location: Idaho
Posts: 271
Points: 56,556
Thanks: 752
Thanked 69 Times in 51 Posts
8v92TA was always mechanical injection, no?
Oxbow12 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
8v92ta questions oleblue6banger Medium and Heavy Duty 7 07-24-2011 05:31 PM
Truck stalls crb478 1994-2003 7.3L Power Stroke 13 01-09-2009 03:45 PM
stalls while idle in drive brnofrd 5.9L Cummins 12 Valve (1994-1998.5) 4 06-25-2007 05:57 PM
Drive like Granny=OK, Drive like Earnhardt=stalls at idle GeneralLeo 1994-2003 7.3L Power Stroke 3 09-15-2006 04:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome