2001 kenworth w900l cab heater breaker - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by GTCooper, this thread has received 3 replies and been viewed 541 times.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-11-2016, 02:24 AM Thread Starter
Junior Member
 
GTCooper's Avatar
 
Join Date: Jul 2014
Location: Mississippi
Posts: 17
Points: 16,022
Thanks: 3
Thanked 0 Times in 0 Posts
2001 kenworth w900l cab heater breaker

My a/c is not working. Worked all day till I hit a bump and it is intermediate now. Will come on for about 2 seconds pops again. Have replaced everything but the blower motor and breaker. Any suggestions would be greatly appreciated. I am mechanically inclined but not an electrician or mechanic by trade

Sent from my SM-N920V using Tapatalk
GTCooper is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-11-2016, 02:42 PM Thread Starter
Junior Member
Threadstarter
 
GTCooper's Avatar
 
Join Date: Jul 2014
Location: Mississippi
Posts: 17
Points: 16,022
Thanks: 3
Thanked 0 Times in 0 Posts
Did some more snooping. It is the cab a/c relay that is clicking, not the cab htr breaker. Swapped relay with another one same thing, no go?

Sent from my SM-N920V using Tapatalk
GTCooper is offline  
post #3 of 4 (permalink) Old 07-17-2016, 12:59 AM
Junior Member
 
Join Date: Jul 2014
Posts: 51
Points: 22,368
Thanks: 0
Thanked 1 Time in 1 Post
Did you replace the the little resister thing just inside the passenger deer?


Sent from my iPhone using Tapatalk
Crudekw is offline  
post #4 of 4 (permalink) Old 07-17-2016, 02:12 AM Thread Starter
Junior Member
Threadstarter
 
GTCooper's Avatar
 
Join Date: Jul 2014
Location: Mississippi
Posts: 17
Points: 16,022
Thanks: 3
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Crudekw View Post
Did you replace the the little resister thing just inside the passenger deer?


Sent from my iPhone using Tapatalk
Yes. Have replaced everything now. Just replaced blower motor. Have fan but a/c compressor will not kick in. Replaced breaker and relay. Have power at a/c switch in cab, no power at a/c clutch

Sent from my SM-N920V using Tapatalk
GTCooper is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
06 kenworth heater problems.... snowman_w900 Medium and Heavy Duty 2 12-12-2011 02:21 AM
Supplimental Cab Heater... Mbixler 2008-2010 6.4L Power Stroke 6 12-21-2007 06:56 AM
Rapid cab heater Mower Man 2008-2010 6.4L Power Stroke 7 10-30-2007 11:15 PM
2001 F-250 XLT X-cab 7.3 TD housted Whats Been Sold 2 06-11-2007 04:54 AM
Kenworth W900L ROOSTER CRUISER!!! Hybrid_4x4_Superduty Whats Been Sold 0 08-30-2005 11:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome