NTC 400 MISFIRE UNDER LOAD - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by jab002, this thread has received 1 replies and been viewed 312 times.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-16-2017, 03:03 PM Thread Starter
Junior Member
 
Join Date: Nov 2017
Posts: 2
Points: 260
Thanks: 0
Thanked 0 Times in 0 Posts
NTC 400 MISFIRE UNDER LOAD

I've got a '88 Ford LTL9000 w/ cummins NTC400 in it. We started having overheating issues going over mountains. Long story short we ended up replacing thermostats, water pump, radiator (low flow), and water pump belt. Still overheating, found 2 cracked heads. replaced all 3 head (new from cummins not reman). put old injectors back in. ran fine until we put load behind it and it starts to miss and when you stop at stop sign it wants to cut off like starving for fuel. on interstate you can really hear and feel miss. replaced injectors, no difference. Fuel filter is half full, changed suction line and filter. didn't help. but a different fuel pump on, same thing. put original pump back and started testing. stuck return off gear pump in bucket, no bubbles, service manual tells me that means it's not sucking air. also ran air test on AFC signal line to pump, pass that test, held 20 - 25 psi for 10 seconds or longer. stuck new suction line in bucket and no difference in fuel filter being half full. my next step is to put air test on injectors to see if an oring got rolled or something.... but I'm afraid it's going to pass that test too seeing how it did w/ old injectors and new injectors.. any help would be muchly appreciated, thanks in advance!! ps.. it was not missing before it was torn into to replace heads.
jab002 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-17-2017, 07:47 PM
Junior Member
 
Jasong's Avatar
 
Join Date: Feb 2015
Location: Plant City Fl
Posts: 314
Points: 35,581
Thanks: 41
Thanked 26 Times in 25 Posts
I know nothing about this engine.
That said, something sounds wrong with that half full fuel filter.
I wonder why it was running hot, it seems the initial problem still exists.
Jasong is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cat injector misfire under heavy load Truck engine machinist Medium and Heavy Duty 8 08-13-2013 01:08 AM
Cummins ntc 400 pump help lumbertm Medium and Heavy Duty 4 11-21-2012 06:17 AM
Water pump for 400 ntc CR Toney Medium and Heavy Duty 2 05-08-2011 05:57 PM
NTC 400 BC1 - Feels like it has a high speed / high load miss bell206b3 Medium and Heavy Duty 20 01-01-2010 03:21 AM
cummins ntc 400 kevin Medium and Heavy Duty 20 11-29-2006 06:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome