Anyone familiar with dt466e engines? 626 code no smoke just spins and spins.. - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by Cjmac, this thread has received 4 replies and been viewed 1297 times.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-14-2018, 04:20 AM Thread Starter
Junior Member
 
Cjmac's Avatar
 
Join Date: Feb 2018
Posts: 5
Points: 294
Thanks: 0
Thanked 0 Times in 0 Posts
Anyone familiar with dt466e engines? 626 code no smoke just spins and spins..

Hello, been reading about dt466e engines for last few hours and am not sure what to think of the problem we have..

Truck has been sitting for a few years. Died on road was towed back to yard and sat..

Other day I started tinkering with it to see if I could find a direction to move with it.. un hooked fuel lines connected to emote tank with new fuel. Refilled filter primed . The hand pump leaks but seems to be pushing fuel as it should.

The engine will crank and crank but will not fire. No smoke, nothing.

Guages sweep, then as cranking re sweep.
No tach signal when cranking.

Code 626

Have checked fuses and pulled wires.. is the best next step to actually remove the wiring harness for engine to inspect, or is there common areas with known faults? Cleaned wires on starter and gave them all a tug. Pulled plug out of firewall to check for corrosion. All seems real clean.

This is a 98 4300 by the way..

1 40 fuse in battery box
2x 5 fuses under dash.
1x ecm relay on cowl

Any ideas?

Thanks!
Chris in Washington
Cjmac is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-14-2018, 04:22 AM Thread Starter
Junior Member
Threadstarter
 
Cjmac's Avatar
 
Join Date: Feb 2018
Posts: 5
Points: 294
Thanks: 0
Thanked 0 Times in 0 Posts
Edit, this is a 98 4700
Cjmac is offline  
post #3 of 5 (permalink) Old 02-14-2018, 02:39 PM
Junior Member
 
Jasong's Avatar
 
Join Date: Feb 2015
Location: Plant City Fl
Posts: 314
Points: 35,580
Thanks: 41
Thanked 26 Times in 25 Posts
This code is a general ECM fault. Connections between the battery and the ECM are possibly loose or corroded.
Jasong is offline  
post #4 of 5 (permalink) Old 02-14-2018, 04:49 PM
Ol Dirt Contractor
 
Lowboy's Avatar
 
Join Date: Dec 2008
Location: Minden Nevada
Posts: 2,803
Points: 64,429
Thanks: 299
Thanked 318 Times in 212 Posts
Our DT466 did the same thing not long ago.. I changed the cam sensor and it fired right back up and has been fine ever since..

I was Anti-Obama before it was cool!
Leno: ‘Remember the Old Days When Obama’s Biggest Embarrassment Was Joe Biden'

Ernie Hasse+ Bill Gaither America Medley
XCR 800cc Polaris Triple with Turbo, Nitrous & RMI
96 F250 7.3 Hypermax Stage III’s, H2 for now, Wide Open Performance long block. Spearco Intercooler 4” downpipe Suncoast Tranny, Terminator Oil
Newest--2015 Black VW Golf SportWagen TDI DSG Nav Roof 18" Avignon's Valentine One
Early 99 F250 SD 7.3 almost stock for now
87 Turbo Intercooled T-Bird stock
98 379 Pete 15.8L CAT 3406E 5DS Borg Warner 175963 Turbo P5 Nathan Horns Johnson Matthey 600 HP DPF 2017 CA registered emissions legal
More Milwaukee V28 Tools than Tim Allen has!
Remember, nozzle size matters at the pump
Lowboy is offline  
post #5 of 5 (permalink) Old 02-14-2018, 05:22 PM Thread Starter
Junior Member
Threadstarter
 
Cjmac's Avatar
 
Join Date: Feb 2018
Posts: 5
Points: 294
Thanks: 0
Thanked 0 Times in 0 Posts
We have a dt530e engine on a stand, that I pulled the cam sensor from to see if it would help. No change. But this engine didn't run either.. so maybe bad cam sensor there too? Pretty cheap, may have to get a new one to check that off the list..

Thanks for your input
Cjmac is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
DT466E smoke after deceleration. balls electric Medium and Heavy Duty 1 02-27-2010 01:23 AM
Help! - DTC code 544 on dt466e ASE-mech Medium and Heavy Duty 5 10-07-2009 03:36 AM
DT466E / Code 333 Blaster Medium and Heavy Duty 2 07-06-2009 04:46 PM
how fast a turbo spins Deezle1 Dodge - Modification instructions, Product installs and Tech Articles 2 02-07-2008 06:22 AM
ULSD fuel used in older engines / Smoke and strong emissions. Any thoughts? Jakegypsum Medium and Heavy Duty 5 05-06-2007 06:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome