C15 MXS Conversion Issue - Diesel Truck Forum - TheDieselGarage.com
Thread Details Posted by ilovedetroits, this thread has received 3 replies and been viewed 1098 times.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-14-2018, 05:26 AM Thread Starter
Junior Member
 
ilovedetroits's Avatar
 
Join Date: Oct 2018
Posts: 8
Points: 2,063
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
C15 MXS Conversion Issue

Hey guys I'm new here just looking for some help here, i have a 06 peterbilt 379 that has a mxs c15 and i just did a single turbo conversion, i used a borg warner 177148 turbo and a 6nz manifold, i got everything together and it starts and runs Good, has about 80 psi of fuel pressure, the issue I'm having is it only wants to make 20 psi of boost, i had the iva delete done and i backed all of those off and plugged the oil galley that feeds them, also unhooked the iva oil pressure sending unit, i have no check engine lights at all, anyhow it is turned up to about 580-600 now and i know 20 psi boost is to little for that and i have plugged the wastegate, checked cac and boots for leaks, it fuels hard till it hits 20 psi and then just stops fueling, BUT I was driving it around and shifted into the next gear and all of a sudden it had full fuel and made about 38-40 psi in boost but then i shifted again and back to 20 psi it went and i can't get it to full fuel any more than that one time, side note i took the resistors out of the boost wire that i had in there before any help is appreciated, some people have told me to try boost sensors it just threw me in a loop when it did full fuel that one time and made 40 psi any help is so so appreciated

series 60 750 hp
c15 de acert 650hp
blowing smoke and making her choke since 1998
ilovedetroits is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-14-2018, 06:58 AM Thread Starter
Junior Member
Threadstarter
 
ilovedetroits's Avatar
 
Join Date: Oct 2018
Posts: 8
Points: 2,063
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
I also have the coolant diverter valve solenoid unplugged if that matters i haven't tried hooking it up to see if that changes anything i will first thing monday

series 60 750 hp
c15 de acert 650hp
blowing smoke and making her choke since 1998
ilovedetroits is offline  
post #3 of 4 (permalink) Old 11-22-2018, 08:09 PM
Junior Member
 
Join Date: Dec 2016
Posts: 18
Points: 15,171
Thanks: 0
Thanked 1 Time in 1 Post
That sounds like an ECM issue to me.
I've done at least 50 of those on the pretty same way as you did.
Replaced the turbo and manifold, and backed the vvas off.

I recommend that you visit the web site of a guy that does my tunes https://truckecmtunes.com/
They are expensive compared to some other solutions, but they sure are worth it.

PS. Maybe try to plug everything back in (talking about electrical connectors) - maybe it will help.
bruce1954 is offline  
post #4 of 4 (permalink) Old 12-19-2018, 12:56 PM
Junior Member
 
CR Toney's Avatar
 
Join Date: Apr 2011
Location: Gull Lake, SK Canada
Posts: 229
Points: 65,596
Thanks: 8
Thanked 36 Times in 29 Posts
Garage
ILoveDetroits fuel pressure should be higher. 105 psi at 1700 rpm. Replace fuel pump change/shim fuel pressure regulator. A guy wanted me to turn his MXS up 50 HP. We needs to make sure he had air and fuel first. He had 80 psi. Upped it to 105 and his hp came back. Gained 1/2 gear in the hills loaded. I'd check for boost leaks. On 75% of the trucks I see I find a leak. Windex bottle with soapy water. Every intercooler boot and tanks on intercooler. A ScangaugeD is useful for monitoring things and they are inexpensive.

'95 T800 N14 13sp DO 4.33 gears
'89 W900B 444 Cummins CPL 1280 18sp 3.55 w/2sp axles 19ft CIM grain/silage box
'03 Dodge 2500 4x4 6sp modded just right
'05 Dodge 3500 4x4 6sp w/ Triple C hydra bed
Smarty Touch Centramatics ATS ex manifolds
'06 IH 4300 DT466 Alison 245HP
Authorized Ekotuning.com dealer
CR Toney is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Diesel Truck Forum - TheDieselGarage.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
C15 MXS Conversion Issue ilovedetroits Introductions 0 10-14-2018 05:22 AM
2008 c15 injector issue cdwood388 Medium and Heavy Duty 3 11-13-2014 02:45 AM
Headgasket issue C15 6NZ kenw007 Medium and Heavy Duty 3 02-05-2013 05:44 AM
mxs acert josh G Medium and Heavy Duty 0 01-28-2010 03:43 AM
solenoid above oil cooler on a mxs cat bigswede Medium and Heavy Duty 4 06-16-2009 11:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome