The Diesel Garage banner

1 - 5 of 5 Posts

·
Junior Member
Joined
·
12 Posts
Discussion Starter #1
Well heres the deal, i was driving my 01 f350 down the road at about 70 and stopped for fuel in the hudson wi area then i noticed the throttle cut out a few times so i proceeded to drive and then all of a sudden the truck went into limp mode almost. It will not go above 15mph and blows blue smoke but you can tell its a very rich mixture of fuel. Idles just fine and it wants to get to speed but just blows the blue smoke and "cuts out". Used a 1/4 tank withtin a 40mile range. Tried throwing a scan tool on it and nothing and then checked; oil pressure, coolant temp sensor, air temp sensor, and then checked the oil. Oil was 2 quarts too low. No engine light one coolant is fine, oil pressure was normal, and running temp was fine. Checked air filter and battery terminals. Any suggestions as to what is happening? I know the electronic throttles tend to go out on these and was thinking a failing throttle is causing this. Any help would be great. Thanks!
 

·
SRW Cartell #27
Joined
·
487 Posts
Im not a tech but i would look for a boost leak. sounds like you are not building boost. just my $.02. Check the boost tubes going to the cooler you might have a bad one.
 

·
Junior Member
Joined
·
12 Posts
Discussion Starter #3
So figured out what it was. I was inside while gf was pumping "diesel" but she really put 87 octane in it. Oh yeah not thrilled by any means. I thought i could trust her to put diesel in it. Oh well i guess it means its a good reason for better injectors. :peelout
 

·
SRW Cartell #27
Joined
·
487 Posts
:eek:
 

·
Another day in paradise
Joined
·
284 Posts
My heart just sunk reading that. ( Gets locking fuel cap and " NO you can't touch my truck honey". I love you........but............ )
 
1 - 5 of 5 Posts
Top