The Diesel Garage banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi guys i got a dt466 that had some low fuel pressure codes and a ICP code we changed the ICP sensor and started it but still low pressure codes its struggling to start. When we get it startes we hook up our computer and it says it has 47.0psi and we need 60-75 with throttle to the floor it gets only to 50psi. So maybe a blockage some where? Were scratching our heads. We already cleared the filter housing got new filter.. Checked the lines from filter to pump no blockage the pump is good all O rings are seated correctly. Also tested the check valve at bottom of filter housing and she works perfect Where can this low pressure issue be coming from
 

·
Registered
Joined
·
4 Posts
I have a 2005 international dt466 with low fuel pressure and no start. I can get it started sometimes and only has about 43 psi and runs badly. It does have a low fuel pressure code and multiple inj codes but I think that is from low fuel pressure. It has new lift pump new hand prime pump new fuel pressure regulator new filter cleaned screen I am at a loss what else could it be?
 

·
Junior Member
Joined
·
335 Posts
Couple of things, check the quick connect o-ring, the oring on the fuel line that goes into the back of the filter housing.
How much pressure are you getting in the HPOP system ? ICP needs to be >500 PSI to start.
 

·
Registered
Joined
·
4 Posts
Couple of things, check the quick connect o-ring, the oring on the fuel line that goes into the back of the filter housing.
How much pressure are you getting in the HPOP system ? ICP needs to be >500 PSI to start.
I have 11 to 1200 on crank hpop is good
 

·
Registered
Joined
·
4 Posts
Yes I did. Also
Update I got fuel pressure up , I replaced the line from tank to filter housing but also had to put a new pump on it. The one I just put on wasn’t good( go figure).
Now I have 3 injector codes and think it’s the harness going bro change that next. It runs just weak and not good.
 

·
Registered
Joined
·
4 Posts
Hey I have got my truck up to 60 to 65 psi fuel pressure but it’s still acting like it isn’t getting enough fuel ( can’t get it to crank) I can spray either to it it will start and run but just with either. It has a brand new set of injectors and all oil rail seals. It has new crank and cam sensor and new injector wiring harness. It has new hand primer and lift pump. It also has new regulator in bottom of fuel filter housing. What can I be missing? It also has new line from tank to filter housing
 
1 - 7 of 7 Posts
Top