The Diesel Garage banner

1 - 20 of 35 Posts

·
Senior Member
Joined
·
417 Posts
Discussion Starter #1
Truck was purchased new in Sept 05 and it now has 39k miles... It has had roughly about 20 oil changes since new and I added cat1 elc at about 20k along with a filter kit(4070) other than that it is stock... I'm original owner

About 50 miles ago it threw a solid check engine light that stayed on for a while then it went out but I checked for a code and there was none stored, I'm gonna have to try a different scanner...

It sits idle fine and soon as I give it a little fuel it coughs and puffs out a cloud of black smoke... Sometimes it will do it right at 1200rpms and sometimes it goes to 1800 and does it... It feels sluggish and I don't want to push it hard so I've been keeping the rpms below 2k and even then it has the feel of missing and stumbling causing it to puff smoke.. It has slowly gotten worse over the last few miles and so I decided to pull the egr valve cleaned it then put it back together to find it the same... I unplugged the egr and still the same, didn't throw a cel either...

What else can I easily check...
Thank you for any help that you can offer.
 

·
Senior Member
Joined
·
417 Posts
Discussion Starter #2
Been googling for some time now and really can't pinpoint what to work on to figure this out but will be pulling out the ebp tube and sensor to give it a good cleaning... I'll try to get to sensor and tube this coming week and post back the results... After that I'm gonna have to dig out the turbo to clean it up... Truck sits alot and recently it was off for almost 2 months with batteries unplugged and that is when the check engine light came on, right after I connected batteries and took a 60 mile trip with it... At about 40 miles of the trip light came on and I felt a slight power surge that has now gotten worse

Meanwhile if anyone can throw any thoughts on what it may be it is greatly appreciated...
 

·
Member
Joined
·
1,213 Posts
Getting it scanned for codes w/ a quality code reader is a high priority.

What did the valve and intake look like when you pulled the EGR valve? What did you use to clean the EGR valve? Were you careful to avoid getting the cleaning fluid into the solenoid?

Very likely you are on the right track w/ a turbo cleaning.

I would love to find a stock 06 or 07 for sale w/ 39k miles!
 

·
Senior Member
Joined
·
417 Posts
Discussion Starter #4
I used the Bluetooth ELM327 with TORQUE Pro app and nothing was stored... I can get acess to a basic actron scanner or will just take it to AutoZone to try for a reading..

Valve was pretty sooty but dry fluffy and brushed right off easily with a brass brush, I just picked out the corners with a screwdriver... No caked on soot and it open and closed fully by hand fine... I finished it off with carb cleaner at very low pressure while aiming down away from those holes that go to top of valve so there should not have been any cleaner shot in there unless just a mist... While I let it dry I scraped around the inside of manifold and vacuumed the crap out of it...

Truck is Sept05 build and has more than 39k, it's actually at 39,280ish lol... This low mileage is what is now causing my issues I'm sure and all the oil changes I didwould never stop this from happening but hope to find the fix soon... It's gonna sit again now until I get time to pull the ebp and hope that is it... If I get another scanner I'll test that as well...

Wait... I forgot isn't the engine warrantied to 100k miles... I knew there was a reason I didn't want to put on too many miles too fast, I wanted the warranty to last me a long time... I gotta call Ford
:grin2:
 

·
Senior Member
Joined
·
3,051 Posts
5yrs or 100k whichever comes first, so warranty is gone unless you purchased an extended warranty.

Anyhow, like Mark mentioned, get scanned for fault codes first before doing anything....my guess is it will have a cylinder contribution fault or injector low voltage-ficm issue fault code.

Black smoke along with misfire like symptoms is almost always a faulty injector.

Harry
 
  • Like
Reactions: RET423

·
Senior Member
Joined
·
417 Posts
Discussion Starter #6
5yrs or 100k whichever comes first, so warranty is gone unless you purchased an extended warranty.
I know I was just kidding :grin2: I should call my local dealer and tell them I didn't know it was 5years and I was saving the mileage to keep the warranty going>:) sure they would have a kick and call me an idiot after...


I'll try to get it scanned with a better scanner this week to see if there is a code stored
 
  • Like
Reactions: harry6.0

·
Senior Member
Joined
·
417 Posts
Discussion Starter #7 (Edited)
harry6.0;1409977 Anyhow said:
But why isn't the cel staying on anymore? It was on for about 25 miles then shut itself off then came on again for about another 10 miles... All this was during the course of multiple days... I know the light works as it does come on before start up...

Truck did have a hard time starting after I cleaned the valve, it kept cranking and I had to stop for a few secs then I tried again and it fired up a bit out of the ordinary... The way it is running it should be throwing a flashing cel and it isn't even on solid.
 

·
Member
Joined
·
1,213 Posts
To help you any further, we need codes, and we need live engine data:

KOEO, post EBP, MAP, and Baro values.

At idle, post MAP, EBP and VGT % duty cycle. Do the same at 1200 rpm and then at 2000 rpm.

Make sure your VGT actuator connector is fully plugged in. Same thing for MAP and EBP.

Check MAP hose for cracking of the rubber and check MAP and EBP tube for plugging.
 

·
Senior Member
Joined
·
3,051 Posts
Should have some type of stored fault code in system.

I have seen a faulty injector that can set a fault code intermittently, if you use a high end scan tool and monitor cylinder contribution readings while driving truck, it will usually show up something in readings if injector issue is your problem.

You can also try unplugging egr valve temporarily and see if symptoms change, although it will most certainly set a check engine light too.

Also monitor ficm output readings, should be 47-49v at all times.

Harry
 
  • Like
Reactions: bismic

·
Member
Joined
·
1,213 Posts
Truck was purchased new in Sept 05 and it now has 39k miles... It has had roughly about 20 oil changes since new and I added cat1 elc at about 20k along with a filter kit(4070) other than that it is stock... I'm original owner

About 50 miles ago it threw a solid check engine light that stayed on for a while then it went out but I checked for a code and there was none stored, I'm gonna have to try a different scanner...

It sits idle fine and soon as I give it a little fuel it coughs and puffs out a cloud of black smoke... Sometimes it will do it right at 1200rpms and sometimes it goes to 1800 and does it... It feels sluggish and I don't want to push it hard so I've been keeping the rpms below 2k and even then it has the feel of missing and stumbling causing it to puff smoke.. It has slowly gotten worse over the last few miles and so I decided to pull the egr valve cleaned it then put it back together to find it the same... I unplugged the egr and still the same, didn't throw a cel either...

What else can I easily check...
Thank you for any help that you can offer.
The best thank you (IMO) is to post up what you find when the problem is resolved!!
 

·
Senior Member
Joined
·
3,051 Posts
Guess I missed the unplugging of egr valve already.

Anyhow, good to see you on here Mark, been really busy at work these day's.

Agree, need outcome from OP, or at least some fault code readings.

Harry
 

·
Member
Joined
·
1,213 Posts
Good to see you posting too Harry. Had to buy some Archoil recently and felt bad it wasn't from you!!

I sure miss the old days on TDG .... (before the Russians hacked the site)!

Hope work isn't crazy .... sometimes busy is a good thing though!
 
  • Like
Reactions: harry6.0

·
Senior Member
Joined
·
417 Posts
Discussion Starter #13
Been getting up 5am coming back home 7pm and that left me no time to do anything... But did remember I had a brand new scangauge II somewhere in the house and so I just connected that to scan codes and there are 8 stored...

P0202
P0261
C2102
P0264
C2402

It said 8 stored but only see these five... Unless it counts the same code twice on a couple of them...

Truck sits long periods of time and I have found small nut shells in the engine area from chipmunks I'm sure and so wonder if the little ****s chewed any wires...

Least I now have codes to help figure this out
 

·
Member
Joined
·
1,213 Posts
P0261 #1 Injector - Circuit Low (open circuit):; FICM has detected an open injector circuit. Injector circuit open or defective coil.

P0264 #2 Injector - Circuit Low (open circuit): FICM has detected an open injector circuit. Injector circuit open or defective coil.

P0202 Cylinder 2 Injector Circuit / Open

Inspect for electrical issues with these two injectors: their connectors, or the wiring harness.

Also, have your alternator tested (specifically check for A/C voltage)

The chassis codes (C codes) are not specific to diesels. Not exactly sure what they are.
 

·
Member
Joined
·
1,213 Posts
fyi - The scangauge is not the best code reader. sometimes it will throw "ghost codes", or even codes that are "gasser" codes.
 

·
Senior Member
Joined
·
417 Posts
Discussion Starter #16
20170610_110825_zpsynhbmhen.jpg Photo by filipe_rocha3 | Photobucket

20170610_110846_zpsk918niau.jpg Photo by filipe_rocha3 | Photobucket

20170610_110905_zpsoy1rdrbz.jpg Photo by filipe_rocha3 | Photobucket

20170610_114045_zpsq4x0staa.jpg Photo by filipe_rocha3 | Photobucket

Couldn't figure out how to resize pics to upload directly here so hope this works... These pics just show what the intake looks like after 39k miles... I have all the parts to reroute the vent through a catch filter and have never made time to get it done. I just need some time...
 

·
Senior Member
Joined
·
417 Posts
Discussion Starter #17

·
Senior Member
Joined
·
417 Posts
Discussion Starter #18

·
Senior Member
Joined
·
417 Posts
Discussion Starter #19

·
Senior Member
Joined
·
417 Posts
Discussion Starter #20
1 - 20 of 35 Posts
Top