The Diesel Garage banner

1 - 3 of 3 Posts

·
Junior Member
Joined
·
144 Posts
Discussion Starter #1
So I've got a 4r100 that won't shift to 3rd. My trucks on 38s and was mud bogging and took it swimming and got a little water maybe a quart in the tranny over a gallon in the front rearing and barely any in the back and it seems like it shifted after I got it out then went straight to the river so never got past first gear long story short I was climbing a huge hill and it was rough then at the top I mashed the throttle and hit a pot hole (it was dark) and the od light started blinking thought nothing of it so got out to the highway few hours latter and no 3rd gear instantly assume electrical sense it was under water so I checked the fluid didn't seem to have water drove about 40 miles at like 45 mph and the light started blinking checked the fluid again and seen it was a little high and had water in it si I get home take it to a local tranny shop they plug it in and pull 3rd solenoid bad they change it same thing running the diagnostic on the highway he said the computer says it's shifting but it's not so I brought it home checked all the wiring for water and after that I seem to have no power but still no 3rd... Sorry for the looong write up!! Anyway I heard to check the valve body anyone have any ideas what I need to check exactly?? Thanks:)
 

·
Junior Member
Joined
·
144 Posts
Discussion Starter #3
Well I found one night out cruising back roads the nice rough ones it started working for another 7000 miles then it started slipping in all gears and could smell it was burned up so just grabbed another one up stuck it in the new one went 68 miles and I lost 3rd gear same exact thing as the other one pisses me off!! Lol so any ideas anyone has is appreciated but hey at least this one has a warranty just prefer not to need it sense they always take forever lol
 
1 - 3 of 3 Posts
Top