The Diesel Garage banner

1 - 11 of 11 Posts

·
Junior Member
Joined
·
17 Posts
Discussion Starter #1
I have serious turbo lag. Going down flat highway, 65mph, 5psi of boost. Step into it and it takes 15 seconds to go from 5 psi to 15 psi. And has a max of 20 psi. I don't remember it being this slow to build boost. Only thing I physically see is the joints on the exhaust manifold. One of them I can turn the metal band and clamps. Don't see any soot though. Any thoughts? Things to check?

Sent from my SM-N950U using Tapatalk
 

·
Ol Dirt Contractor
Joined
·
2,803 Posts
I'd be seriously looking at possible gate or turbo malfunction... No leaks or soot showing points right back to the turbo.. Make sure there is no restriction out to the stack..
 

·
Member
Joined
·
410 Posts
Charge Air cooler leaking? Hoses or boots to or from Charge Air Cooler leaking? Your symptoms are almost identical I had on my 3406B CAT. Tiny crack about 2" long in top row of my Charge Air Cooler. Took forever to find it. Problem solved.
 

·
Junior Member
Joined
·
17 Posts
Discussion Starter #6
Charge Air cooler leaking? Hoses or boots to or from Charge Air Cooler leaking? Your symptoms are almost identical I had on my 3406B CAT. Tiny crack about 2" long in top row of my Charge Air Cooler. Took forever to find it. Problem solved.
Replaced hoses and clamps this past Monday while at home. Seemed to help a little. Going to change the wastegate and test cac when I get back in, Monday or Tuesday. I'm thinking that's what it will end up being is the cac.

Sent from my SM-N950U using Tapatalk
 

·
Member
Joined
·
410 Posts
I also had a hole in my CAC about 5 years ago. Repaired it with JB Weld. It was still holding solid this year when the crack appeared and I replaced the whole thing. FYI
 

·
Junior Member
Joined
·
17 Posts
Discussion Starter #8
I also had a hole in my CAC about 5 years ago. Repaired it with JB Weld. It was still holding solid this year when the crack appeared and I replaced the whole thing. FYI
Yeah. If it doesn't pass the leak down test, I'm just going to replace it. Looks like the original 17 years old.

Sent from my SM-N950U using Tapatalk
 

·
Junior Member
Joined
·
17 Posts
Discussion Starter #9
Well doing some checking and trying to replace wastegate, and wouldn't you know it. One of the bolts broke off in the housing. Also discovered an exhaust leak where down pipe meets turbo. Would that cause an issue?

Sent from my SM-N950U using Tapatalk
 
1 - 11 of 11 Posts
Top