The Diesel Garage banner

1 - 8 of 8 Posts

·
Junior Member
Joined
·
172 Posts
Discussion Starter #1
Have 02 started surging at idle now it shut down going down the road.It will start right back up.Getting worse no codes.Going to check fuel pressure new lift pump 30k ago.Fount rust in filter housing lift pump sounds noisey now.But there is no misfire or white smoke just like it was shut off with the key.Changed the cam sensor didn't make a difference.
 

·
ADMIN/MAFIA
Joined
·
4,834 Posts
Could be early signs of lift pump failure, see if you can get a gauge on it and see what its pushing. Could also be a fuel filter, there should not be rust in the filter bowl. Surging could also be related to the APPS sensor.
 

·
Junior Member
Joined
·
172 Posts
Discussion Starter #3
was told that it could be faulty injector compression sealing gaskets,truck stumbles or stalls at idle but not all the time,sometimes while driving almost like a misfire or backfire.
 

·
ADMIN/MAFIA
Joined
·
4,834 Posts
Sounds like its time to pull the injectors and have them pop tested that way you are sure of that is the problem, but it sounds like injector time.
 

·
Senior Member
Joined
·
1,189 Posts
lift pump will do the same thing too. the vp will pull enough fuel to idle but no more if the lines are plugging up with rust it may not even be able to pull enough to idle might be time for new lines, or just save the hassle of that and put on a fass
 

·
Junior Member
Joined
·
172 Posts
Discussion Starter #6
put a clear filter in before lift pump.Put new lift pump in.Truck still shutting down or sputtering randomly.Sometimes runs fine half the day.Voltage to the vp is good.
 

·
Senior Member
Joined
·
1,189 Posts
put a clear filter in before lift pump.Put new lift pump in.Truck still shutting down or sputtering randomly.Sometimes runs fine half the day.Voltage to the vp is good.
what filter are you running before lift pump? it's not stock then. also a new factory lift pump will not run very well if it gets crap in it. they are a waste of money. they can live 2hrs or a long time you just never know what your getting.
 

·
Senior Member
Joined
·
2,063 Posts
Check everthing from the fuel tank to the injectors, but it sounds like the VP died. More than likely you will need a new lift pump, fuel filter, and a VP injection pump. Good luck.
 
1 - 8 of 8 Posts
Top