The Diesel Garage banner

1 - 2 of 2 Posts

·
Senior Member
Joined
·
403 Posts
Discussion Starter #1
buddy barry bought a "red" ford f250 4x4 at the auction and of course it broke down on the way back to the great white north. he thought is was the fuel pump so we tossed one in the tank. it still has the same problem with only idleing for a short time then quitting. we then borrowed a code reader thing and came up with PO190 - PO191 FUEL RAIL PRESSURE SENSOR. can anyone help us out on this. we are 1100kms from the nearest big city and everyone we phone all they say is haul the truck in.

also we need the axles that go in the hubs with u-joints. ebay has everything but these because they say it is a dealer only part.

thansk
KoO
Published Author
 

·
Senior Member
Joined
·
1,700 Posts
You can verify fuel pressure with a mechanical guage, or if the scanner you borrowed has PID data, I would be curious on what the FRP (fuel rail pressure sensor) sensor is reading for fuel pressure.

fuel rail pressure sensor is on the fuel rail at the drivers side, it has a elec connector and a vacuum hose going to it. check the connector and vac hose integrity.

Since you have a P0190 and P0191, I would suspect the problem is in the sensor. I have had a few in the past go bad and it would make the engine running crappy and die at times too.

You may not be able to find one locally or have to go to a dealer, but to get the truck going again maybe you can unplug it for now, sometimes that will help.
 
1 - 2 of 2 Posts
Top